Results 1 to 5 of 5

Thread: Internal error: create_lsc_credential_omp:3690 (GSA 5.0.1) in OpenVAS

  1. #1
    Join Date

    Internal error: create_lsc_credential_omp:3690 (GSA 5.0.1) in OpenVAS

    I downloaded and installed Kali Linux to my hard drive from the the kali-linux-1.10-amd64.iso file.

    I've updated OpenVAS using, modified the /etc/default/openvas-manager and /etc/default/greenbone-security-assistant files to allow access outside of the local system, installed alien, rpm, nsis, and fakeroot to clear the rpm and nsis install messages when running ./openvas-check-setup --v7.

    I am now able to initial scans and run reports, but I'm not able to create credentials. I receive the following error:

    Internal error: create_lsc_credential_omp:3690 (GSA 5.0.1)

    An internal error occurred while creating a new credential. It is unclear whether the credential has been created or not. Diagnostics: Failure to receive response from manager daemon.
    Your options (not all may work):
    'Back' button of browser | Assumed sane state | Logout

    I've Googled the error and there isn't much posted about it except the following:

    [Openvas-discuss] Internal error: create_lsc_credential_omp:3690 (GSA 5.0.1) (Solved)

    Their solution was to copy /etc/openvas/gnupg directory to the /var/lib/openvas/gnupg directory.

    In my install the only thing located in /etc/openvas are three .conf files (gsad_log.conf, openvasmd_log.conf, and pwpolicy.conf). So I don't think this will work properly.

    Is there a particular log that I should be looking at?

    Any ideas on how to resolve this issue would be greatly appreciated? Thank you for your help in this matter!

  2. #2
    Join Date
    Same issue here!
    Any solution provided?

  3. #3
    solved for me:

    apt-get install alien nsis rpm

    start openvas services with lazykali

    Last edited by [email protected]; 2015-06-06 at 06:59.

  4. #4
    Join Date
    Log file proved to be useful. OpenVAS credential issue resolved.
    As I have found out, when OpenVAS is creating Local Security Checks - LSC Credentials messages are logged in file /var/log/openvas/openvasmd.log one. According to these messages the error had something to do with GNU Privacy Guard - GnuPG utility gpg not able to use home directory. Actual message logged was: Setting GnuPG homedir failed: No such file or directory one.
    OpenVAS version 8 used in Kali 1.1.0a release has this home directory set to /var/lib/openvas/gnupg/ one. But this directory was not present! Creating it as root user simply resolved the issue.
    Worth mentioning is that OpenVAS Manager stores private key and password parts of target credentials encrypted. Whenever a first credential object gets created, it is logged in log file that a new key generation is starting. The key generation could take some time. While waiting it is advised to generate some load in Linux system (like with ls -laR / command and even more operations) because gpg is using kernel random number generator. The kernel generator gets entropy (randomness) from all kinds of places, among them is interrupt timing, for certain interrupts. Moving the mouse (and typing, disk activity, etc.) will all generate interrupts and thus more entropy to the system which will reduce the waiting time for key generation. The amount of entropy in kernel can be read using cat /proc/sys/kernel/random/entropy_avail command.

  5. #5
    Join Date
    Worked for me. Thx!

Similar Threads

  1. OpenVAS 8 Internal error while creating credentials
    By dss in forum General Archive
    Replies: 2
    Last Post: 2015-06-16, 10:35
  2. Replies: 2
    Last Post: 2015-06-06, 06:09

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts