Results 1 to 9 of 9

Thread: Kali Linux running with some Lag

  1. #1
    Join Date
    2013-Mar
    Posts
    20

    Kali Linux running with some Lag

    Hello All,
    Just wondering is anyone having some funny issue with running virutalbox and Kali Linux? The reason why I'm asking is that it take a little long to open programs, or just lags some times when moving the mouse and stuff. I thought it would be fast and stuff. Please let me know you guys notice some strange the way it's running. My spec are below and I have a pretty fast pc.

    I7-3820
    8 gig
    64 bit.
    The virutalbox specs as follow 3 gig and 60 gig of space. 3 process set for this vm machine.

  2. #2
    I am experiencing the VM hanging when writing / saving information.
    Have checked the hashes and the downloaded file is fine.

    System;
    Win7
    8GB ram

    VMware Player v5.0.2
    2 GB specified for Kali VM.

    Am trying to figure out whether this is a VMware player issue, but it works fine for BT5R3
    so have a feeling it may be something to do with the vmware image.
    There are quite a few articles on trouble shooting VM freezes during I/O activity, will
    be digging into it.

    I have been doing some checks ;

    So when running Kali, all is looking good, until I decide to open a file at which point the VM freezes.
    (I was opening a README text file in leafpad)



    So checking the realtime output of the vmware log on my system in powershell for a bit when messing in the VM;
    Code:
     
    Get-Content -Path "path\to\vmware-log" -Wait
    and noted that each time this freeze happens, the following is logged ;

    2013-03-18T10:59:32.483+01:00| vmplayer| W110: Failed to get guest launch hierarchy: Maximum items (512) reached for menu 0
    2013-03-18T10:59:32.502+01:00| vmplayer| W110: Failed to get guest launch hierarchy: Maximum items (512) reached for menu 0
    2013-03-18T10:59:32.508+01:00| vmplayer| W110: wui::CGuestLaunchMenuWnd::BuildMenu: Non-null GuestApp but the icon list was empty
    2013-03-18T10:59:32.552+01:00| vmplayer| W110: wui::CGuestLaunchMenuWnd::BuildMenu: Non-null GuestApp but the icon list was empty
    2013-03-18T10:59:32.553+01:00| vmplayer| W110: wui::CGuestLaunchMenuWnd::BuildMenu: Non-null GuestApp but the icon list was empty
    2013-03-18T10:59:32.555+01:00| vmplayer| W110: wui::CGuestLaunchMenuWnd::BuildMenu: Non-null GuestApp but the icon list was empty
    2013-03-18T10:59:32.557+01:00| vmplayer| W110: wui::CGuestLaunchMenuWnd::BuildMenu: Non-null GuestApp but the icon list was empty
    2013-03-18T10:59:32.557+01:00| vmplayer| W110: wui::CGuestLaunchMenuWnd::BuildMenu: Non-null GuestApp but the icon list was empty
    2013-03-18T10:59:32.558+01:00| vmplayer| W110: wui::CGuestLaunchMenuWnd::BuildMenu: Non-null GuestApp but the icon list was empty
    2013-03-18T10:59:32.558+01:00| vmplayer| W110: wui::CGuestLaunchMenuWnd::BuildMenu: Non-null GuestApp but the icon list was empty
    2013-03-18T11:00:02.831+01:00| vmplayer| I120: vmClientCore::VMWindow::SetVirtualScreenSize: Denied resize request because target size == current guest size
    This behaviour is consistent when opening and closing files and it also affects the host PC to a certain extent, so still not truly sure whether a VMware issue
    or an issue in the VMware image itself..
    It happened when I opened an image file (in viewer), and when I closed the image.


    *sigh*

    Will see if teh googles can help me, but falling short so far.

    Any pointers greatly appreciated as always
    Last edited by sickn3ss; 2013-03-21 at 02:50.

  3. #3
    Join Date
    2013-Mar
    Posts
    9
    Are you running the "Live" mode or you have installed completly Kali Linux in your virtualization machine? There is a little difference of performance between the two options.

  4. #4
    Join Date
    2013-Mar
    Posts
    20
    I too have the same issue as well as the home fiolder takes about 7 to 10 seconds to open while running in VMWare Workstation. I have noticed a lot of mouse lag as well. Anybody have a heads up on this?

  5. #5
    Join Date
    2013-Mar
    Posts
    85
    @n1tr0g3n if by mouse lag you mean slow movement you might want to check out this page, it may solve that issue: http://docs.kali.org/general-use/ins...ols-kali-guest

  6. #6
    Join Date
    2013-Mar
    Posts
    5
    I don't know what window manager you are using but in my case I also experienced some lag when opening programs, mouse movement. I found it was related to GnomeShell. Even running in fallback mode produced the same results. As a test I switched to xfce and the machine is running snappy again. Haven't gone back to try and tweak any settings in Gnome for better performance but will post back with any results.

  7. #7
    Join Date
    2013-Mar
    Posts
    1
    Im having the same issue as well. Running vmware fusion. None of my other *nix VM's have this problem. Occurs frequently when using a text editor and loading or saving files
    I didnt have this problem on BT5

    My kali vm has 4gb ram so its not a memory issue

  8. #8
    I was simply running the VM image as provided for Kali, so installation not required.

    In any case I switched over to using Virtual Box instead and the problem is gone, Kali runs great


    Not sure why it the mouse icon keeps on spinning for so long after opening locations (Places), but whatever, I am a happy camper
    that it works as it should now !

  9. #9
    Join Date
    2013-Mar
    Posts
    38
    I too had this issue with vmware workstation 9 after doing an install of kali to it. Others have posted about this as well in other threads, it seems like writing to disk in vmware (even with vmware tools installed) hangs up the VM.


    I was too lazy to research a true fix for it, so I just switched over to oracles virualbox until someone smarter finds a 100% fix for the vmware problem.

    https://www.virtualbox.org/

    If you have an alfa 036h you may have to fiddle to get it connected but its much easier than working with the vmware issue.

Similar Threads

  1. Kali linux running slow
    By spencermat in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-05-02, 18:39
  2. Running applications in Kali Linux
    By shingster08 in forum General Archive
    Replies: 1
    Last Post: 2015-01-18, 00:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •