Results 1 to 10 of 10

Thread: alfa awus036h realtek rtl8187l problems

  1. #1
    Join Date
    2013-Oct
    Posts
    6

    alfa awus036h realtek rtl8187l problems

    hello there , first of all i want to say that i am new here and in linux world so be pacient with me ...

    i have a notebook where i install the kali linux

    Distributor ID: Kali
    Release: 1.1.0
    Codename: moto
    3.14-kali1-686-pae GNU/Linux


    i had wifi usb adapter "Alfa awus036h" that i use in my backtrack system and work nice with out problems

    i connected to my note and kali see the adapter , i connected in my wifi and all work perfect ... BUT ..

    when i try to change the TX-Power there i have problem the commands

    #iw reg set BO

    #ifconfig wlan1 down

    #iwconfig wlan1 txpower 25

    but the iwconfig give TX-Power=20 dBm


    i try any info that i found in internet but nothing happen ... the other think is that i cant change the power management

    #iwconfig wlan1 power on
    Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan1 ; Operation not supported.

    in rfkill list all is no


    #lsusb
    Bus 004 Device 006: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

    #airmon-ng
    wlan1 Realtek RTL8187L rtl8187 - [phy2]


    i dont know what else to try before put the adapter to trash and buy a new one ... when i connected back to backtrack the adapter work and configured properly

    anyone to help me ???

    thanx

  2. #2
    Join Date
    2013-Mar
    Posts
    18
    Same exact problem. No solution that I've found has worked for me...

  3. #3
    Join Date
    2013-Jun
    Posts
    94
    Try plugging it in after boot up and testing the power to it...

  4. #4
    Join Date
    2014-Jun
    Posts
    71
    same exact card
    same exact problem
    no solution yet.. I usually have to power down the machine running on Virtual Box or deactivated it .
    sucks

  5. #5
    Join Date
    2015-Apr
    Posts
    14
    Hello,
    Looks like in Kali Linux no more tx power 30 by default for Bolivian region. Anyway try this tread

  6. #6
    Join Date
    2013-Mar
    Posts
    8
    You can try to set default region Venezuela.( iw reg set VE )

    There is a new Regdomain in Kali.

  7. #7
    Join Date
    2015-May
    Posts
    8
    I used another guide, they are quite similar but this one is newer. Anyway it worked out great.
    http://superuser.com/questions/87988...ndows-or-linux

  8. #8
    Join Date
    2014-Jun
    Posts
    71
    Quote Originally Posted by drumbo View Post
    You can try to set default region Venezuela.( iw reg set VE )

    There is a new Regdomain in Kali.
    How do we set the region to VE?
    Thanks!

  9. #9
    Join Date
    2013-Mar
    Posts
    8
    First try:

    iw reg set VE


    and check:

    iw reg get



    To make the change permanent, edit the file /etc/default/crda and it has a line:

    REGDOMAIN=

    Change that to

    REGDOMAIN=VE

  10. #10
    Join Date
    2014-Jun
    Posts
    71
    Quote Originally Posted by drumbo View Post
    First try:

    iw reg set VE


    and check:

    iw reg get



    To make the change permanent, edit the file /etc/default/crda and it has a line:

    REGDOMAIN=

    Change that to

    REGDOMAIN=VE

    are there any adverse effects?

Similar Threads

  1. Can't compile rtl8187l driver for ALFA AWUS036H
    By Davelister in forum ARM Archive
    Replies: 2
    Last Post: 2016-10-16, 18:54
  2. Replies: 4
    Last Post: 2015-09-16, 17:57

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •