Results 1 to 12 of 12

Thread: Postgres will not start

  1. #1
    Join Date
    2015-Apr
    Posts
    3

    Postgres will not start

    Hi there! Excited about my new install on a Nexus 7 (2012). I've used the Windows based installer twice to install NetHunter on my Nexus and each time I have had a problem with the Postgres DB starting.

    Everytime I try to start postgres using "service postgresql start" I encounter an issue which says the following:

    could not create shared memory segment: Function not implemented
    Failed system call was shmget(key=5432001, size=39460864, 03600)


    If I enter "man shmget", I get a man page for the function.

    I would appreciate any help!

  2. #2
    Join Date
    2013-Mar
    Posts
    31
    Did you update your chroot through the Nethunter menu yet? Cuz i get a postgres error whenever i do my first upgrade and it tries to update metasploit. I need to go back to the menu after the update and enable apache and metasploit, update chroot again, get 1 more error, then go back to the menu and disable metasploit and update chroot a 3rd time and everything goes smooth from there.

    Not sure if this helps you at all, especially since i'm running a Nexus 5, but since i just recently got a Nexus so i could play with Nethunter and then once i had my phone stable, we got the Lollipop update, i've done quite a bit of flashing. I always have to do the those same 3 steps to update my chroot for the first time.

  3. #3
    Join Date
    2015-Apr
    Posts
    12
    I had to install NH about 4 times before I got it working.

  4. #4
    Join Date
    2015-Apr
    Posts
    3
    Hi i have the same problem that you wit thar service and the other to, please check if your kernel have google on his name, if is it like that yo have to flash the kernel, it seems to appear a bug when you install net hunter you can find the kernel here in the issue #196 of the proyect on github https://github.com/offensive-securit...ter/issues/196

    Regards

  5. The first step is to look at why it is not starting up by examining the logs.
    you can download play store for android here: https://chplaya.blogspot.com/
    Play Store for PC: https://chplaya.blogspot.com/2016/10...-xach-tay.html
    Last edited by thunguyethyc; 2017-03-22 at 16:16.

  6. #6
    Join Date
    2014-Sep
    Posts
    176
    There appears to be an issue with kernel in N7 2012 not flashing during install. I'm unsure if its related to installer or update zip. I haven't made any changes to the android install side so I'm curious on where the flashing error is occurring.

    I've been working on the N7 2012 lollipop update in the mean time so I hope to have something out soon.

    https://github.com/offensive-securit...ter/issues/196

  7. #7
    Join Date
    2015-Apr
    Posts
    3
    Awesome! Thanks for the replies! I will check out flashing the kernel over. I checked the logs, and they're all basically a repeat of the failed system call noted above.

  8. #8
    Join Date
    2015-Apr
    Posts
    3
    Yup. Replacing the kernel worked like a charm. Thanks!

  9. #9
    Join Date
    2015-Jul
    Posts
    2
    I have the same shared memory issue right now. Latest kernel, updated apt, updated chroot... Any ideas? I'll dig through the log...

  10. #10
    I had to install NH about 4 times before I got it working.

  11. #11
    Join Date
    2018-Aug
    Posts
    2
    Quote Originally Posted by kpoeticg View Post
    Did you update your chroot through the Nethunter menu yet? Cuz i get a postgres error whenever i do my first upgrade and it tries to update metasploit. I need to go back to the menu after the update and enable apache and metasploit, update chroot again, get 1 more error, then go back to the menu and disable metasploit and update chroot a 3rd time and everything goes smooth from there.

    Not sure if this helps you at all, especially since i'm running a Nexus 5, but since i just recently got a Nexus so i could play with Nethunter and then once i had my phone stable, we got the Lollipop update, i've done quite a bit of flashing. I always have to do the those same 3 steps to update my chroot for the first time.
    I am facing the same problem.
    Could u please list the steps to solve it.

  12. #12
    Join Date
    2018-Aug
    Posts
    2
    Hi could you pliz telk which kernel you flashed

Similar Threads

  1. Install Openvas 9 with Postgres on Kali linux Rolling
    By Egerod in forum Community Generated How-Tos
    Replies: 8
    Last Post: 4 Weeks Ago, 19:41
  2. Install Openvas 8 with Postgres on Kali linux Rolling
    By 0x4E0x650x6FŽ in forum How-To Archive
    Replies: 0
    Last Post: 2016-08-02, 16:28
  3. Replies: 0
    Last Post: 2014-02-25, 22:25
  4. Replies: 0
    Last Post: 2013-04-01, 13:04

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •