Results 1 to 2 of 2

Thread: unmet dependencies

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2015-Apr
    Posts
    1

    unmet dependencies

    Whatever i install i got these errors
    You might want to run 'apt-get -f install' to correct these.The following packages have unmet dependencies:
    apache2 : Depends: apache2-mpm-worker (= 2.2.22-13+deb7u4) but it is not installed or
    apache2-mpm-prefork (= 2.2.22-13+deb7u4) but 2.4.10-10 is installed or
    apache2-mpm-event (= 2.2.22-13+deb7u4) but it is not installed or
    apache2-mpm-itk (= 2.2.22-13+deb7u4) but it is not installed
    Depends: apache2.2-common (= 2.2.22-13+deb7u4) but it is not installed
    apache2-mpm-prefork : Depends: apache2 (= 2.4.10-10)
    libapache2-mod-php5 : Depends: apache2 (>= 2.4)
    libncurses5 : Depends: libtinfo5 (= 5.9-10) but 5.9+20140913-1+b1 is installed
    E: Unmet dependencies. Try using -f.

    I have tried apt-get install -f
    Apt-get all clean
    Sudo dpkg --configure-a
    Apt-get install (all above missing packages name) but invain..plzz help me with this im not being able to do anyyyything

  2. #2
    Join Date
    2015-Feb
    Posts
    5
    Try this:
    1. apt-get install --reinstall apache2
    or
    2. dpkg --purge apache2
    apt-get install apache2
    or
    3. apt-get install --fix-missing

Similar Threads

  1. Unmet Dependencies
    By Hunt3rdude in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-12-10, 20:52
  2. libsnmp15 unmet dependencies
    By brutuz in forum TroubleShooting Archive
    Replies: 6
    Last Post: 2013-07-20, 07:37
  3. mini iso - unmet dependencies
    By gpowers in forum Installing Archive
    Replies: 7
    Last Post: 2013-05-18, 10:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •