Results 1 to 5 of 5

Thread: Rapsberry Pi 2 will not boot with Kali Linux v1.1.0.

  1. #1

    Exclamation Kali Linux v1.1.0 .img file transferred to SD Card generates no valid partition table

    My RapsBerry Pi 2 B boots Ubuntu 14.04LTS fine in a 32GB SD HC Card, but it does not boot at all (nothing on screen) when trying with Kali Linux v1.1.0

    I tried transferring the .img file from Linux by doing:

    # dd if=kali-1.1.0-rpi2.img of=/dev/sdb bs=512k
    and from Windows by using Win32DiskImager.
    This is the result:

    luis@Chomsky:~$ sudo fdisk -l
    Disco /dev/sdb: 61.9 GB, 61924704256 bytes
    64 cabezas, 32 sectores/pista, 59056 cilindros, 120946688 sectores en total
    Unidades = sectores de 1 * 512 = 512 bytes
    Tamaño de sector (lógico / f*sico): 512 bytes / 512 bytes
    Tamaño E/S (m*nimo/óptimo): 512 bytes / 512 bytes
    Identificador del disco: 0x9b40c48c
    El disco /dev/sdb no contiene una tabla de particiones válida
    My Linux is in spanish, sorry, but the last line translates to: "/dev/sdb has no valid partition table".
    I have tested this with a 8GB SD Card, and a 64GB SD XC Card, but results are the same (no image at all).
    I have tried by firstly creating some valid ms-dos type partition table by using gparted, but it seems to be removed after the dd process.

    What is going on here, and what could I check to solve this?

    Thanks you.
    Last edited by Sopalajo de Arrierez; 2015-05-03 at 11:19.

  2. #2
    Join Date
    Down Under
    I don't have Kali on my pi but I thought I'd ask,

    Have you made sure the image you have downloaded has the correct sha1sum?
    chown -R us ./base

  3. #3

    Checksum verified.

    Quote Originally Posted by staticn0de View Post
    I don't have Kali on my pi but I thought I'd ask
    Thanks you.
    It is hard to believe that the .img file available at a so widely used distro like Kali Linux could be damaged, so the problem should be another one.
    Quote Originally Posted by staticn0de View Post
    Have you made sure the image you have downloaded has the correct sha1sum?
    Indeed, this is my obtained (by Total Commander checksum SHA1 generator):
    485ea11cdaf9b0f89c798548ba4d9a64bc196129 *kali-1.1.0-rpi2.img
    Maybe it could be worth to try any other RapsBerry image, like "Raspberry Pi A/B+" or "Raspberry Pi A/B+ TFT"? Of course I would prefer the RapsBerry Pi 2 .img.

  4. #4
    This sounds like you might of had dropout on the usb bus of your computer try a different usb port and maybe a different computer

  5. #5
    Finally solved: Firefox had (who knows why?) downloaded:

    as a file named:


    Note the missing ".xz" part.
    I have detected it with:

    file kali-1.1.0-rpi2.img

    I saw the output info as not the appropriate for a image file.

    Thanks you anyway, staticn0de (the SUM, indeed, was correct ;-) ).

Similar Threads

  1. VNC on rapsberry pi with Kali won't connect?
    By david1234 in forum General Archive
    Replies: 1
    Last Post: 2022-08-15, 22:59
  2. rapsberry pi start up command help
    By faconix in forum ARM Archive
    Replies: 0
    Last Post: 2016-01-01, 00:58

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts