Results 1 to 4 of 4

Thread: Can not boot in Kali after installing it

  1. #1

    Angry Can not boot in Kali after installing it

    >>I have a toshiba satellite laptop that came with windows 8
    >> I disabled secure boot and UEFI BOOT
    >> I enabled CMS BOOT
    >> This allowed to finally boot into my usb and installing Kali
    >> Kali Installation was successful
    >> GRUB Installation was sucessful
    >> I reboot my laptop
    >> System seems to be unable to find GRUB after reboot
    >> Tries to boot from Atheros Network card and I get this message

    Code:
    Intel UNDI, PXE-2.0 (build 083)
    For atheros PCIE Ethernet Controller v2.0. 
    Check cable connection!
    PXE-M0F Exiting Intel PXE ROM.
    No bootable device -- insert boot disk and press any key

    I have tried changing my boot options using a number of configurations and it did not work.


    I had to go back to my bios and enable UEFI BOOT but that just goes straight to my windows 8!!


    Aidez moi, SVP

  2. #2
    Join Date
    2015-May
    Posts
    4
    Make a live boot in Kali and post your partition table

  3. #3
    Join Date
    2014-Oct
    Posts
    28
    Download and make a live usb using this http://sourceforge.net/projects/boot-repair-cd/ if you you can use chroot from anything really. But this makes it simple. Use advanced settings to install the newest version of grub-uefi and do not install anything else so pay attention to what its asking to install, like linux-generic.... No. Just install the stuff related to UEFI. This will fix it and you will be up and running, make sure you are connected to the internet in the live distro so it can grab the latest packages. When i install Kali UEFI, it normally just gives a black screen. It needs the updated uefi-grub which for me was 2.02 and kali does not install that i believe it was like 1.98. This regardless should do the trick I have used this to fix boot issues for a while now.

    Good luck

    Quote Originally Posted by jesusadolforodriguez View Post
    >>I have a toshiba satellite laptop that came with windows 8
    >> I disabled secure boot and UEFI BOOT
    >> I enabled CMS BOOT
    >> This allowed to finally boot into my usb and installing Kali
    >> Kali Installation was successful
    >> GRUB Installation was sucessful
    >> I reboot my laptop
    >> System seems to be unable to find GRUB after reboot
    >> Tries to boot from Atheros Network card and I get this message

    Code:
    Intel UNDI, PXE-2.0 (build 083)
    For atheros PCIE Ethernet Controller v2.0. 
    Check cable connection!
    PXE-M0F Exiting Intel PXE ROM.
    No bootable device -- insert boot disk and press any key

    I have tried changing my boot options using a number of configurations and it did not work.


    I had to go back to my bios and enable UEFI BOOT but that just goes straight to my windows 8!!


    Aidez moi, SVP
    Last edited by Cyb3rg0d; 2015-05-11 at 14:15. Reason: added info

  4. #4
    Join Date
    2013-Jul
    Posts
    16
    I solved that problem by using the boot manager, refind, and installing it to the root of the drive, not on its own ESP.

Similar Threads

  1. Can't boot Windows 7 after installing Kali on USB and HDD
    By rice fungus in forum TroubleShooting Archive
    Replies: 12
    Last Post: 2017-11-13, 20:31
  2. Installing shim bootloader to boot kali under secure boot
    By _defalt in forum General Archive
    Replies: 1
    Last Post: 2017-08-18, 07:00
  3. Installing Kali 2.0 boot problem
    By Dottieee in forum Installing Archive
    Replies: 5
    Last Post: 2015-08-17, 20:12
  4. Installing GRUB boot loader to master boot record.
    By Vinylninja in forum Installing Archive
    Replies: 0
    Last Post: 2014-01-20, 16:57
  5. Installing Kali with XP (Dual boot)
    By sNova in forum Installing Archive
    Replies: 7
    Last Post: 2013-07-22, 23:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •