Results 1 to 4 of 4

Thread: java JDK (1.8.0) in browser cannot be re-enabled again after first disable.

  1. #1
    Join Date

    java JDK (1.8.0) in browser cannot be re-enabled again after first disable.

    Hey Guys,

    I've installed the latest java release and followed the installation procedure
    successfully but when it came to testing the browser (iceweasel) I can't
    re-enable the browser plugin.

    When first installed, the browser and the java plugin worked as expected,
    when I disable the java plugin through the java control panel and then
    re-enable, the browser refuses to register the plugin.

    Again, when I checked aboutlugins page java was registered but after
    the disable and re-enable no java plug is registered.

    I deleted all home directory preferences and let java rebuild all the preferences
    from new but still no luck. It did work again after deleting the whole install and
    re-installing which is not an option.

    I've also deleted the old versions of java that were in the usr/lib/jvm just in
    case their was a clash but still no luck. Also checked to see if I am using
    the 64bit version of everything and all is OK.

    Has anyone encountered anything similar or able to reproduce these
    results successfully or not (at your own risk!).

    Is this a java or kali issue?

  2. #2
    Join Date
    Found this post
    that refers to the pluginreg.dat file in the user profile in the ~/.mozilla/firefox
    directory. It seems that it has black listed the java plugin for some odd reason.

    It seems like it is a mozilla issue.

  3. #3
    Join Date
    Deleted the pluginreg.dat file and the icewesel rebuild the file and now java is enabled.

  4. #4
    Join Date
    A potential solution is to leave it enabled in the Java control panel but
    to disable the plugin within the browser add-ons for convenience.

Similar Threads

  1. translate:Browser Landing Page Browser Landing Page
    By fairycn in forum Building Archive
    Replies: 0
    Last Post: 2022-03-08, 10:04
  2. non-PAE enabled laptop build
    By martialhax in forum Building Archive
    Replies: 2
    Last Post: 2013-05-07, 22:16

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts