Results 1 to 6 of 6

Thread: Metasploit and Postgresql Doesn't start

  1. #1
    Join Date
    2015-May
    Posts
    4

    Exclamation Metasploit and Postgresql Doesn't start

    I have installed nethunter on my nexus 7 tab (2012) and have updated all the packages except metasploit because it is giving me an error.
    I have tired starting postgresql but keep getting this error. (http://i.imgur.com/qhBwZSS.png). And when i try to update metasploit i get this error right here (http://i.imgur.com/SbguIeE.png). I tired stopping metasploit to update it but since its not fully installed it didnt help me. I know alot of people are getting this error and i really dont wish to re-flash my device again and again just to fix the error. Is there a quick patch or fix for this. Metasploit is the only thing thats stopping my device from being 100% configured and i need metasploit. What could be the issue?

  2. #2
    Join Date
    2014-Nov
    Posts
    16
    I had that problem quite a few times with my nexus 7 and it was 95% of the time due to a non compatable rom or not wiping my nexus 7 completely before flashing Nethunter.

    Reboot your device and do an apt-get dist-upgrade and see if that does the trick. If not you may have to reinstall Nethunter.
    Last edited by C1M7; 2015-05-22 at 02:01.

  3. #3
    Join Date
    2014-Mar
    Posts
    163
    i get the metasploit error everytime i update it .
    the way i solve it was this way :
    service metasploit stop
    service postgresql start
    dpkg --configure metasploit
    however , the next time metasploit updates i need to do the same thing to fix it .
    Note : Nexus 7 does not have enough memory to run metasploit , here i can start metasploit on terminal but after a few minutes the tablet crashes and restart without root .
    Metasploit is too heavy for 500M ram memory .(because the other 500M are already been used by the rom services)
    there could me a way to tweak the settings of the cyanongenmod rom to enable more ram before get into crash , but i never try it . (out of time)

  4. #4
    Join Date
    2015-May
    Posts
    4
    you dont have the right kernel. you need Kernel-groupertilapia-kitkat-12042014

  5. #5
    Join Date
    2014-Mar
    Posts
    163
    i have the right kernel , i can solve this problem (i think) , i just did not yet patience to do it .
    Maybe also because i know hot to fix it temporarily .
    I was messing with some configs here .
    I just posted that in case anyone had that issue and did not knew how to fix it right away .

  6. #6
    Join Date
    2015-Jun
    Posts
    9
    Also I have a problem after updating



    how to fix it?

Similar Threads

  1. Unable to start Postgresql so I can run Metasploit
    By OldHackerWannabe in forum General Archive
    Replies: 4
    Last Post: 2018-02-05, 13:08
  2. Postgresql won't start
    By DrDinosaur in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2015-07-20, 12:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •