I have installed kali linux live with persistence mode as suggested in "http://docs.kali.org/downloading/kali-linux-live-usb-persistence" and everything was working fine, but few days back i got following problem -

I have updated openvpn and openssl to 2.3 and 1.2 respectively and executed following command -

sudo which openvpn -> [/usr/bin/openvpn]
sudo which openssl -> [/usr/sbin/openssl]
sudo which openssl -> [Displaying correct version that is 1.2]
sudo which openvpn -> [displayed correct version but one weird thing that it were still pointing to older version on openssl]

While installing openvpn i have compiled it with latest version of openssl as suggested at "http://stackoverflow.com/questions/24063382/compile-openvpn-with-custom-openssl"

./configure --prefix=/opt/custom-openvpn OPENSSL_SSL_LIBS="-L/usr/openssl-1.0.1h/ -lssl" OPENSSL_SSL_CFLAGS="-I/usr/openssl-1.0.1h/include/" OPENSSL_CRYPTO_LIBS="-L/usr/openssl-1.0.1h/ -lcrypto" OPENSSL_CRYPTO_CFLAGS="-I/usr/openssl-1.0.1h/include/"

Now i explored more and tried to find at what all locations i have openssl and found openssl at one more place "/usr/live/....squafs.filesystem/rootfs/usr/sbin/openssl" and also found that it still has older version. I tried to update this as well but failed since the above location is read only file system. Now i am stuck (1) How to update this openssl so that openvpn start pointing to correct one also (2) i am confused while compiling openvpn when i provided correct openssl why it still chosen older version that is at live location?

Also this may be the case for other packages also like openvpn which also installed at live location as well as my usb location, so what should be the startegy to handle this.

Please help i am completely stuck here.