I'm setting up my system to dual boot Windows 8.1 and Kali Linux. The computer I'm doing this on is a Sony Vaio SVF15N17CXB (https://docs.sony.com/release/specs/...17CXB_mksp.pdf). The part that I think is causing the problem is the graphics drivers. This computer has integrated Intel graphics and an NVIDIA GeForce GT 735M. It came with Windows 8 pre-installed with UEFI. So, here's what I've done so far (in a nutshell):
1.) Created EFI Kali Linux (1.1.0a - 64 bit) bootable USB
2.) Disabled Secure Boot in the BIOS
2.) Booted and used the graphical install to add a 160 GB partition to the hard drive.
3.) Installed Kali Linux to the hard drive (it said it completed successfully)

After the install GRUB came up once, but the screen was just a black screen with no cursor or anything. I tried CTRL-ALT 1-7 to no avail. When I couldn't get anywhere, I powered off the computer by holding down the power button (I know, that's bad), and then the computer booted directly to Windows. It continued to boot to Windows on every reboot, like GRUB wasn't even there. I needed to have some way to get back to the Kali installation. After some researching, I decided maybe I just needed to reinstall GRUB, so to do that I attempted to boot from the Kali USB so I could use run Kali Live to fix the installation. When I ran Kali from the USB drive in Live mode, I again got a black screen, no cursor or anything, just a black screen. At a loss, I booted the computer off of an Ubuntu USB because I thought it was important to be able to try to boot to Kalia and I was hoping that I could get a command prompt or something. When I tried to boot Ubuntu Live, I got the same black screen as Kali, but here I could edit the GRUB boot commands off the USB so I added nomodeset to the Live Ubuntu boot and that got me into Ubuntu so that I could run boot-repair and reinstall GRUB. That brings me to where I am now. With GRUB installed again, I can boot into Windows 8.1 and everything works fine. However, when I try to boot Kali (regular or recovery), I get a simple black screen with no cursor. I attempted to edit the GRUB entry to add nomodeset since that "fixed" things for Ubuntu Live, but all that did was let Kali boot to a black screen with a blinking cursor as opposed to a black screen with no cursor. Before the black screen loaded with the cursor though, I did see the message "Cannot turn on display power on i915." From my searching online, it looks like this is related to the Intel graphics driver and that's why I think that maybe the problem is just a goofy Intel graphics driver and no NVIDIA driver, but I can't seem to figure out how to boot Kali into just a command line (or so I can see anything). Additionally, I performed the graphical install of Kali in the first place with no problem so I would assume there's some way I can get into the installation to try to get the graphics drivers working correctly, but I can't figure it out. I would appreciate any help or assistance anyone could give me to get my install up and running.