Results 1 to 1 of 1

Thread: Hybrid Intel/ATI graphics drivers on a full install on Dell laptop.

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2015-Jun
    Posts
    2

    Unhappy Hybrid Intel/ATI graphics drivers on a full install on Dell laptop.

    I'm using a Dell Latitude E6540 with a hybrid Intel GPU and AMD 8790M. This is Kali 1.1.0a. I've done a full install on the SSD, this is not live or VM. I occasionally see a black screen with a non-blinking cursor in the top left. I am able to get to tty1 by pressing ctrl+alt+F1 and log in. Graphical mode fails to start about half the time and that was before I attempted to install the AMD drivers. This issue is happening out of the box, immediately after a fresh install.

    I followed the instructions here in attempt to install the AMD drivers but when I do it seems everything but the actual driver installs, I get no errors and afterwards apt-get says everything is installed including the fglrx-driver. System info tells me the driver installed is "Gallium 0.4 on llvmpipe (LLVM 0x209)" and Catalyst Control Center says no ATI driver is installed. The good news is that gnome fallback still loads about half the time. It would seem that the mesa driver is still in use or perhaps the integrated Intel GPU is throwing things for a loop? I didn't go through the steps of changing GRUB yet as the driver says its not installed at all so I didn't see the point. Also if its important this is dual booted with Win7.

    If it is possible I'd love to have the AMD GPU working for cracking purposes and I'm pretty sure sorting this out would fix the issue of the GUI not loading half the time. I'm new to this issue with AMD/ATI drivers as I've made it a point to avoid ATI in the past but. ..company laptops, ya know? That said, if their's any more info or outputs you'd need let me know because I'm not sure what commands would show you what you'd need to know to help me out on this. Thank you for any assistance.
    Last edited by Futurist; 2015-06-24 at 13:10.

Similar Threads

  1. Replies: 3
    Last Post: 2015-12-24, 02:26
  2. Replies: 9
    Last Post: 2014-12-29, 16:14
  3. Hybrid Graphics problem - Intel HD 3000 / AMD Radeon HD 6630
    By Kraako in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-03-29, 14:30

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •