Results 1 to 5 of 5

Thread: OCLHashcat error 1001

  1. #1
    Join Date
    2015-Jul
    Posts
    3

    OCLHashcat error 1001

    Hey everybody, first time posting here (just joined today) so I hope I'm in the right place.

    I'm trying to work with oclHashCat64 on Kali version 1.1.0. I was able to get my ATI drivers installed, and verified it's version 14.10.1006 which is needed per this list: http://bit.ly/1dEuFxo

    I was initially getting an error: "error while loading shared libraries: libOpenCL.so.1: cannot open shared object file: No such file or directory" but I searched and found
    https://forums.kali.org/showthread.p...ll=1#post41546

    which said to run apt-get install amd-libopencl1 1.3-3 I did that and I get through that error now. Immediately after accepting the EULA I get a new error

    clGetPlatformIDs() -1001

    It's right after the line that says "Generating bitmap tables with 16 bits..." if that helps.

    Any suggestions are greatly appreciated!

  2. #2
    Join Date
    2015-Jul
    Posts
    3
    It was suggested that I run "clinfo" and I got this output:

    terminate called after throwing an instance of 'cl::Error'
    what(): clGetPlatformIDs
    Aborted

    Does anybody have a suggestion?

  3. #3
    Join Date
    2013-Mar
    Location
    localhost
    Posts
    41
    run hashcat directly without OCL , because it's already installed
    root@lab:~# hashcat
    Usage: hashcat [options] hashfile [mask|wordfiles|directories]

    Try --help for more help.
    root@lab:~#
    r00tv.org
    telegram @bondbenz

  4. #4
    Join Date
    2015-Jul
    Posts
    3
    I checked that out, but doing a benchmark it says that it's only using my CPU and not my GPU, which is why I wanted to use oclhashcat. Is there a way to get hashcat to use my gpu?

  5. #5
    Join Date
    2015-Jul
    Location
    bd-dha
    Posts
    2

    Install OclHashcat on kali linux.

    Quote Originally Posted by gokumatrix View Post
    I checked that out, but doing a benchmark it says that it's only using my CPU and not my GPU, which is why I wanted to use oclhashcat. Is there a way to get hashcat to use my gpu?

    $ sudo apt-get update && sudo apt-get install oclHashcat

    after try to run

    $ oclhashcat

    if good it;s ok if not

    Nvidia driver : http://docs.kali.org/general-use/ins...-on-kali-linux


    Amd driver: $apt-get install amd-libopencl1 1.3-3

    thanks it will be fine.

Similar Threads

  1. oclHashcat error
    By elidd1 in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2015-12-27, 23:40
  2. oclhashcat on Nethunter... Possible or not ?
    By Rajnish357 in forum NetHunter General Questions
    Replies: 2
    Last Post: 2015-10-12, 15:30
  3. oclHashcat
    By Flipper in forum General Archive
    Replies: 5
    Last Post: 2015-01-31, 14:51
  4. Getting error message when runing oclhashcat+
    By scorpoin in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-11-13, 17:50

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •