Results 1 to 1 of 1

Thread: apt-get update error on latest beta

  1. #1
    Join Date
    2013-May
    Posts
    10

    apt-get update error on latest beta

    Greetings,

    I'm using latest beta version and my source list is below

    Code:
    #########Official
    deb http://http.kali.org/kali kali main non-free contrib
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    
    #Bleeding Edge
    deb http://repo.kali.org/kali kali-bleeding-edge main
    when I run apt-get update , I get following error

    Code:
    W: Failed to fetch http://http.kali.org/kali/dists/kali/main/binary-amd64/Packages  Hash Sum mismatch
    
    E: Some index files failed to download. They have been ignored, or old ones used instead.

    even tried with

    Code:
     apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      accountsservice apg cdrdao cups-pk-helper dnsmasq-base empathy-common
      fonts-cantarell gcalctool gdm3 gir1.2-gtk-2.0 gir1.2-javascriptcoregtk-1.0
      gir1.2-webkit-1.0 gnome-backgrounds gnome-control-center-data
      gnome-dictionary gnome-disk-utility gnome-font-viewer
      gnome-icon-theme-extras gnome-online-accounts gnome-packagekit
      gnome-packagekit-data gnome-screenshot gnome-system-log
      gstreamer0.10-plugins-ugly gucharmap libavahi-gobject0 libavahi-ui-gtk3-0
      libbsd-dev libburn4 libcairo-script-interpreter2 libcaribou-gtk-module
      libcaribou-gtk3-module libchamplain-0.12-0 libchamplain-gtk-0.12-0
      libclang-common-dev libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin
      libcluttergesture-0.0.2-0 libffi-dev libgdict-1.0-6 libgdict-common
      libgdu-gtk0 libgeocode-glib0 libgmp-dev libgmpxx4ldbl libhttp-parser2.1
      libisofs6 libjavascriptcoregtk-1.0-dev libjim0debian2 libjs-underscore
      libjte1 libllvm3.0 libmx-1.0-2 libmx-bin libmx-common libnl-route-3-200
      libnm-glib-vpn1 libnm-gtk-common libnm-gtk0 libopencore-amrnb0
      libopencore-amrwb0 libpcrecpp0 libpixman-1-dev libreadline-dev
      libreadline6-dev librest-extras-0.7-0 libsidplay1 libsnmp-perl
      libsocialweb-client2 libsocialweb-common libsocialweb-service libsocialweb0
      libtelepathy-farstream2 libtidy-0.99-0 libtinfo-dev libunique-3.0-0
      libxcb-render0-dev libxcb-shm0-dev libxcomposite-dev libxcursor-dev
      libxdamage-dev libxext-dev libxfixes-dev libxi-dev libxinerama-dev
      libxml2-dev libxml2-utils libxrandr-dev libxrender-dev llvm-3.0 llvm-3.0-dev
      llvm-3.0-runtime mobile-broadband-provider-info modemmanager mousetweaks
      network-manager network-manager-gnome perl-cisco-copyconfig pkg-config
      python-argcomplete python-bson python-bson-ext python-gridfs
      python-lightblue python-pip python-pymongo python-pymongo-ext python-tidylib
      ruby-addressable ruby-ansi ruby-atomic ruby-buftok ruby-daemons
      ruby-dataobjects ruby-dataobjects-mysql ruby-dataobjects-postgres
      ruby-dataobjects-sqlite3 ruby-dm-core ruby-dm-do-adapter ruby-dm-migrations
      ruby-dm-sqlite-adapter ruby-em-websocket ruby-equalizer ruby-erubis
      ruby-eventmachine ruby-execjs ruby-faraday ruby-http ruby-http-parser.rb
      ruby-librex ruby-libv8 ruby-memoizable ruby-msfrpc-client ruby-msgpack
      ruby-multi-json ruby-multipart-post ruby-naught ruby-parseconfig ruby-rack
      ruby-rack-protection ruby-ref ruby-rubyzip ruby-simple-oauth ruby-sinatra
      ruby-term-ansicolor ruby-therubyracer ruby-thread-safe ruby-tilt
      ruby-twitter ruby-uglifier ruby-yajl sound-theme-freedesktop
      telepathy-gabble telepathy-logger telepathy-salut thin usb-modeswitch
      usb-modeswitch-data vino wpasupplicant x11proto-composite-dev
      x11proto-damage-dev x11proto-fixes-dev x11proto-randr-dev
      x11proto-render-dev x11proto-xext-dev x11proto-xinerama-dev
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
      beef-xss bluelog bluemaho build-essential clang g++ g++-4.6 g++-4.7 gccxml
      ghc ghc-prof golismero libatk1.0-dev libbluetooth-dev libc-dev-bin libc6-dev
      libcairo2-dev libexpat1-dev libfontconfig1-dev libfreetype6-dev
      libgdk-pixbuf2.0-dev libghc-base-unicode-symbols-dev
      libghc-base-unicode-symbols-prof libghc-monad-control-dev
      libghc-monad-control-prof libghc-transformers-base-dev
      libghc-transformers-base-prof libghc-transformers-dev
      libghc-transformers-prof libglib2.0-dev libgtk2.0-dev libopenobex1-dev
      libpango1.0-dev libpcap-dev libpcap0.8-dev libpcre3-dev libpng12-dev
      libsoup2.4-dev libsqlite3-dev libssl-dev libstdc++6-4.6-dev
      libstdc++6-4.7-dev libusb-dev libwebkit-dev libwebkitgtk-dev libxft-dev
      powerfuzzer python-ctypeslib python-dev python2.7-dev ruby-dev ruby1.8-dev
      ruby1.9.1-dev vega zlib1g-dev
    0 upgraded, 0 newly installed, 55 to remove and 120 not upgraded.
    13 not fully installed or removed.
    After this operation, 897 MB disk space will be freed.
    Do you want to continue [Y/n]? Y    
    Setting up initscripts (2.88dsf-59.2) ...
    update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match mountkernfs.sh Default-Start values (S)
    update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match mountkernfs.sh Default-Stop values (none)
    insserv: script checkroot.sh: service mtab already provided!
    update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match hostname.sh Default-Start values (S)
    update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match hostname.sh Default-Stop values (none)
    insserv: script checkroot.sh: service mtab already provided!
    update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match mountdevsubfs.sh Default-Start values (S)
    update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match mountdevsubfs.sh Default-Stop values (none)
    insserv: script checkroot.sh: service mtab already provided!
    update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match checkroot.sh Default-Start values (S)
    update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match checkroot.sh Default-Stop values (none)
    insserv: script checkroot.sh: service mtab already provided!
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing initscripts (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of util-linux:
     util-linux depends on initscripts (>= 2.88dsf-59.2~); however:
      Package initscripts is not configured yet.
    
    dpkg: error processing util-linux (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     initscripts
     util-linux
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Reagrds
    Scorpoin
    Last edited by scorpoin; 2015-07-19 at 12:37.

Similar Threads

  1. Latest update - killed zenmap
    By AfterBurn in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-06-03, 16:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •