Results 1 to 3 of 3

Thread: Metasploit - Updated repo?

  1. #1
    Join Date
    2015-Aug
    Posts
    2

    Metasploit - Updated repo?

    I'm continuing to get 404 errors when trying to update metasploit:

    Code:
    The following extra packages will be installed:
      metasploit-framework
    The following packages will be upgraded:
      metasploit metasploit-framework
    2 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
    Need to get 232 MB of archives.
    After this operation, 21.5 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Err http://http.kali.org/kali/ kali/main metasploit-framework amd64 4.11.3-2015063001-1kali0
      404  Not Found
    Err http://http.kali.org/kali/ kali/non-free metasploit amd64 4.11.3-2015063001-1kali0
      404  Not Found
    Failed to fetch http://http.kali.org/kali/pool/main/m/metasploit-framework/metasploit-framework_4.11.3-2015063001-1kali0_amd64.deb  404  Not Found
    Failed to fetch http://http.kali.org/kali/pool/non-free/m/metasploit/metasploit_4.11.3-2015063001-1kali0_amd64.deb  404  Not Found
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    I've confirmed the proper repos are in my sources.list
    I've also tried deleting all files in /var/lib/apt/lists and then updating again.

    Upon browsing through the repo though, I see that the most up to date file is: metasploit-framework_4.11.4-2015071403-0kali2_amd64.deb

    So, why is apt looking for an old version and 404'ing on metasploit-framework_4.11.3-2015063001-1kali0_amd64.deb?

    How can I fix this?

    Thanks!

  2. #2
    Join Date
    2013-Dec
    Location
    Krakow
    Posts
    67

  3. #3
    Join Date
    2015-Aug
    Posts
    2
    I read through that post yesterday and used the repos from the link you posted for official and default values.

    I tried upgrading today and am still getting the 404's.

Similar Threads

  1. Non Kali Repo
    By Sagaryal in forum General Archive
    Replies: 2
    Last Post: 2017-03-27, 17:53
  2. updated 1.0.4 ISO becomes 1.0.5?
    By Quest in forum Building Archive
    Replies: 0
    Last Post: 2013-08-30, 13:33
  3. Replies: 0
    Last Post: 2013-05-24, 14:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •