Kali Linux v1.0.9a
Installed on HDD
GNOME v3.4.2

I'm not sure if I should post this here, or if I should split these into separate forums, so please let me know if I should.

Before I ask, I should probably mention that I have little to no experience with anything related to Linux, besides its basic features, so my apologies if I am a bit slow with anything.

So I have three questions; one about uninstalling Yamas.sh, one about the modified Yamas.sh made by SilverFoxx, and one for the installation of Kali itself.

1. How do I uninstall the original version of Yamas?

2. When I run the modded version of Yamas (uses Spoofa instead of Arfspoof), it starts up as normal, however when it gets to the part where it starts up Spoofa, it opens a window, like it should, but it then says

xterm: Can't execvp Spoofa: No such file or directory
root@kali: */Desktop#
I've tried doing what the readme here and here say, running all the commands 3 or 4 times over, but to no avail, and I could not find a solution to any of these problems.

3. When I try to install Kali, it tells me that it can't find drivers for my computer or something like that. When I plug in my computer via ethernet and then try to install it, it installs fine but then my wireless connections don't work.
I'm not going to risk trying to mess up my one good install of Kali, so if anyone has any advice for me, please let me know.

Thanks alot!