Results 1 to 9 of 9

Thread: Got stuck at the login

  1. #1
    Mikey Guest

    Got stuck at the login

    After a week of trying to get an image file to an Micro SD card for my Raspberry Pi I finally got one that works, well almost. It boots up, but when I get to the login screen I'm stumped with what to enter. Well it would be

    toor as the password and root as the username.

    But whatever sequence I put in (Upper and Lower case) I keep getting Invalid password.

    Its really frustrating when I eventually get the thing to boot and then get stumped at the login.

    I'd appropriate a bit of help here.

    Thanks a lot.


  2. #2
    Join Date
    Similar issue upgrading today on a throwaway/test system. Used standard upgrade-dist rules, after multiple failures/restarts, it finally completed. However when I log in, my old credentials under root and the default credentials (root/toor) do not log me in.

    I'd take the drive out and mount it with kali / change password etc but i'm 20 megs away from the .iso being downloaded so I'll be trying a fresh install from the ISO.

    But let's be honest, It installed after a couple restarts without complete failure. That's pretty good for day 1!

  3. #3
    Join Date
    I would hate to get stuck there. I do not have any advice at the moment. I have my raspberry pi but have not installed Kali on it.
    What do you use as your monitor ?

  4. #4
    Join Date
    i already upgrade to kali 2.0 and got stuck right there, i also try to change the password using recovery mode but it but nothing different. can anyone resolve this problem?

  5. #5
    Mikey Guest
    There's a way out of this and that's to edit the Kali image before flashing it to the SD card. But I don't know what to use in a windows environment to edit it and check the login and password parameters.

  6. #6
    Join Date
    Have struck the same problem on my box.

    Updated via apt - all went well. However, after my lockscreen popped up I could no longer authenticate using either my configured password or the 'toor' default. Rebooted and I'm still unable to log in.

    Would really prefer not to have to rebuild it, as it means staying up late tonight so I can use it for work in the morning.

    An unfortunate reminder to take snapshots before performing updates. However, wouldn't have ever expected something as dire as this to happen.

    Update: Fresh install... still cannot log in. Might have to disable updates during the install.
    Last edited by nykon; 2015-08-19 at 08:07.

  7. #7
    Join Date
    I am stuck there too. But Found a way to get in yesterday. Before that read my story.

    So It goes like this : I upgraded to kali 2.0 with no big issues. I rebooted it, a login screen came with username field. I entered "root" and submit then it asks for password, I entered that too... hit submit but it didn't recognize it. It says "Sorry, that didn't work. Please try again."
    I tried another user but the same.
    Then I hit Ctrl+Alt+F1 and went to console. I entered root user and password and it worked this time. I changed the password for root, rebooted, went back to gnome screen, tried again... NOTHING, its the same error.
    So again I went back to console mode and logged in again as root (No issues while login in console). I entered startx command. But "startx" is not recognized. I installed 'xorg' and tried again with startx. WoW... I am in Kali 2.0. Desktop looks new.
    So where is the problem. I rebooted kali. tried to log in again with default Gnome screen. Nothing... Same error. Again I logged in via console then startx. Now this time I locked the system. I get a lock screen with user root asking for password. I entered the password. Nothing again.... same error. At this stage I am unable to go to console mode again(tty1), although can go to tty2.

    Yesterday I tried to change password on boot via editing image file and login as single user mode but 'Kernel Panic'

    Then I logged in from console(tty1) as root, created a new user, logged off. Tried new logins in gdm3. And I am in. Now the problem is there is no root user here. Old accounts are shown in settings but they are not working.

    My thoughts are that gdm3 is pointing to different location but console is at default old kali.

  8. #8
    Join Date
    Hi all.
    I'm new to Kali, but a long term linux desktop user.
    Any idea how to solve it? I've got exactly the same problem. After locking cannot log in. I can switch to a console (ctrl+alt+f1) and then log in with no problems. I installed xfce4 and lightdm and removed gnome / gdm if that makes a difference.

  9. #9
    Join Date

    Lightbulb Using fsck command

    press ctrl+alt+f1
    login with credientials
    Use command: fsck

    It will ask you to overwrite existing partitions say yes. some more issues it solve say yes and enter it...
    after all process done use reboot command or use power off to power off and then repower it.

Similar Threads

  1. Deleted default login account, now stuck on timer (no login)
    By rrtn in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-12-11, 15:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts