Results 1 to 31 of 31

Thread: Armitage not starting on Kali 2.0

  1. #1
    Join Date
    2013-Mar
    Posts
    77

    Question Armitage not starting on Kali 2.0

    Hi

    I try to open Armitage and i am getting this error:

    Code:
    Connecting to 127.0.0.1:55553
    org.msgpack.UnpackException: parse error

    Any help?

    Thanks

  2. #2
    Join Date
    2015-Aug
    Posts
    2
    same problem! and after that shows up and the loading bar fills up it just closes

  3. #3
    Join Date
    2013-Mar
    Posts
    6
    The problem is described here:
    https://github.com/rsmudge/armitage/issues/184

  4. #4
    Join Date
    2015-Aug
    Posts
    5
    İ have same problem

  5. #5
    Join Date
    2013-Mar
    Posts
    77
    Ok so it seems that the problem exist for all of us and we have to wait for a fix.....

    @gotmilk
    About the warning that i got i want to let you know that i just report that the official instructions here:

    are not working on Kali 2.0

  6. #6
    Join Date
    2013-Mar
    Posts
    77
    Fix added by Kali team:

    But not yet pushed to Kali 2 apt-get update.....
    Last edited by pamamolf; 2015-08-13 at 03:01.

  7. #7
    Join Date
    2015-Aug
    Posts
    2
    JUST NOW it has been a release to fix that
    try this:

    apt-get update && apt-get upgrade
    you have to able to connect to security.kali.org to get that update if you get the error that says
    404 NOT FOUND
    then use USA or German VPN ...
    that sould work and you will see an update for armitage

  8. #8
    Join Date
    2015-Aug
    Posts
    2
    hey i apt udated and upgraded it still is having trouble for me on an installed on my hd copy. liveusb seems to work just fine???

  9. #9
    Join Date
    2015-Aug
    Posts
    2
    Quote Originally Posted by dirtyfrank View Post
    hey i apt udated and upgraded it still is having trouble for me on an installed on my hd copy. liveusb seems to work just fine???
    correction....

    apt-get cleanup

    then did

    apt-get update && apt-get upgrade

    armitage is working now yay

  10. #10
    Join Date
    2015-Aug
    Posts
    2
    I also have apt updated and upgraded and I'm still getting the parse error also

  11. #11
    Join Date
    2014-Aug
    Posts
    2
    You may need to add the entries in the source file as discussed in another post

    https://forums.kali.org/showthread.p...eaders-problem

  12. #12
    Join Date
    2015-Aug
    Posts
    4
    I have run apt-get && apt-get upgrade and have no issues or hiccups, but I didn't receive an Armitage update. I did however receive an Iceweasel update. Now it seems like there are just no updates at all.

    root@kali:~# apt-get update && apt-get upgrade
    Hit http://http.kali.org sana InRelease
    Hit http://security.kali.org sana/updates InRelease
    Hit http://http.kali.org sana-proposed-updates InRelease
    Hit http://http.kali.org sana/main Sources
    Hit http://http.kali.org sana/non-free Sources
    Hit http://security.kali.org sana/updates/main Sources
    Hit http://http.kali.org sana/contrib Sources
    Hit http://security.kali.org sana/updates/contrib Sources
    Hit http://security.kali.org sana/updates/non-free Sources
    Hit http://security.kali.org sana/updates/main amd64 Packages
    Hit http://http.kali.org sana/main amd64 Packages
    Hit http://http.kali.org sana/non-free amd64 Packages
    Hit http://security.kali.org sana/updates/contrib amd64 Packages
    Hit http://security.kali.org sana/updates/non-free amd64 Packages
    Hit http://http.kali.org sana/contrib amd64 Packages
    Hit http://http.kali.org sana-proposed-updates/main amd64 Packages
    Hit http://http.kali.org sana-proposed-updates/contrib amd64 Packages
    Hit http://http.kali.org sana-proposed-updates/non-free amd64 Packages
    Ign http://security.kali.org sana/updates/contrib Translation-en_US
    Ign http://security.kali.org sana/updates/contrib Translation-en
    Ign http://security.kali.org sana/updates/main Translation-en_US
    Ign http://security.kali.org sana/updates/main Translation-en
    Ign http://security.kali.org sana/updates/non-free Translation-en_US
    Ign http://security.kali.org sana/updates/non-free Translation-en
    Ign http://http.kali.org sana/contrib Translation-en_US
    Ign http://http.kali.org sana/contrib Translation-en
    Ign http://http.kali.org sana/main Translation-en_US
    Ign http://http.kali.org sana/main Translation-en
    Ign http://http.kali.org sana/non-free Translation-en_US
    Ign http://http.kali.org sana/non-free Translation-en
    Ign http://http.kali.org sana-proposed-updates/contrib Translation-en_US
    Ign http://http.kali.org sana-proposed-updates/contrib Translation-en
    Ign http://http.kali.org sana-proposed-updates/main Translation-en_US
    Ign http://http.kali.org sana-proposed-updates/main Translation-en
    Ign http://http.kali.org sana-proposed-updates/non-free Translation-en_US
    Ign http://http.kali.org sana-proposed-updates/non-free Translation-en
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    I haven't altered my repositories, they are just the regular and source Kali repositories? Do I need to use an different network mirror? Any help would be great.

  13. #13
    Join Date
    2013-Mar
    Posts
    77
    Just do:

    apt-get clean
    apt-get update
    apt-get upgrade

    and then run:

    /etc/init.d/postgresql start

    And then fire up Armitage !

  14. #14
    Join Date
    2015-Aug
    Posts
    8
    I can confirm that on my downloaded kali 2.0 vm armitage works. It did NOT however work right after I downloaded it, and after an update today it appears offsec released a patch for the issue as it works now.

  15. #15
    Join Date
    2015-Aug
    Posts
    2
    This is still an issue for me as I can't seem to get past this parse error no matter what I do even with update and upgrade.

    Screenshot from 2015-08-14 18:43:14.jpg

    Screenshot from 2015-08-14 18:44:02.jpg

    Any ideas on what to do next??

  16. #16
    Quote Originally Posted by fsociety View Post
    This is still an issue for me as I can't seem to get past this parse error no matter what I do even with update and upgrade.

    Screenshot from 2015-08-14 18:43:14.jpg

    Any ideas on what to do next??
    Your source files are incorrect - you only have security.kali.org - you are missing http.kali.org - you didn't install the patch yet.
    Check here: http://docs.kali.org/general-use/kal...t-repositories
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: https://tools.kali.org/

  17. #17
    Join Date
    2015-Aug
    Posts
    4
    since my thread was deleted, and I was linked to this thread... I will ask my questions here... I am getting the below error, I have went through all the suggested fixes in this post and nothing is fixing it. I have done all the updates, I have even done a complete reinstall of Metasploit framework

    A database appears to be already configured, skipping initialization
    [-] Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 7337?
    could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 7337?

  18. #18
    Join Date
    2015-Aug
    Posts
    1
    I had the same issue after a clean install, updating the source files fixed it. Thanks for your help!

  19. #19
    Quote Originally Posted by billbishere View Post
    since my thread was deleted, and I was linked to this thread... I will ask my questions here... I am getting the below error, I have went through all the suggested fixes in this post and nothing is fixing it. I have done all the updates, I have even done a complete reinstall of Metasploit framework

    A database appears to be already configured, skipping initialization
    [-] Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 7337?
    could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 7337?

    Make sure you have Metasploit started (method has changed in Kali 2.0)
    Source: https://www.kali.org/releases/kali-linux-20-released/
    Code:
    # Start the Postgresql Database
    /etc/init.d/postgresql start
    
    # Initialize the Metasploit Framework Database
    msfdb init
    
    # Run msfconsole
    msfconsole
    Running msfdb will show you all the commands (all of which are useful!).
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: https://tools.kali.org/

  20. #20
    Join Date
    2015-Aug
    Posts
    4
    This is almost my exact problem, except i have the http.kali.org and the security.kali.org repos. when I apt-get update && apt-get upgrade there are no updates, it's just like the updates aren't there. Any help?

  21. #21
    Join Date
    2015-Aug
    Posts
    17
    I've been following this thread to see what's going on and I'm also seeing this error.

    I've run:

    apt-get clean
    apt-get update
    apt-get upgrade

    but I haven't seen an update to armitage or msf. I have also verified that my sources.list is exactly as show in http://docs.kali.org/general-use/kal...t-repositories

    Is there a log file for armitage or msf that might help?
    How long does it usually take for a fix to hit the apt repos?

  22. #22
    Join Date
    2015-Aug
    Posts
    4
    Quote Originally Posted by mire3212 View Post
    I've been following this thread to see what's going on and I'm also seeing this error.

    I've run:

    apt-get clean
    apt-get update
    apt-get upgrade

    but I haven't seen an update to armitage or msf. I have also verified that my sources.list is exactly as show in http://docs.kali.org/general-use/kal...t-repositories

    Is there a log file for armitage or msf that might help?
    How long does it usually take for a fix to hit the apt repos?
    I've been having the same problem on both my usb persistence and my VirtualBox install. It might be overkill, but i've redownloaded both iso files and am doing another clean install on both, i'll let you know if anything works. I also tried apt-get purge and apt-get install armitage but i end up with this error.

    The following packages have unmet dependencies: armitage : Depends: metasploit but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

  23. #23
    Join Date
    2015-Aug
    Posts
    4
    i fixed my first problem by just reloading the VM... When I reloaded the VM, the first thing I did was do the updates, then start sql, then create the database and it worked great.



    I do have a version on my laptop though that I can't get past the parse error thing, even after everything in this thread.

  24. #24
    Join Date
    2015-Aug
    Posts
    4
    After fiddling with my repos for at least an hour, trying different mirrors etc..., and reinstalling Kali 2.0 I finally just updated it manually. Im not sure what is going on with apt-get or the Kali repos but at least I have Armitage running.

    So if anyone else can't get the Armitage update this is a surefire method to fix it.

    1. head over to http://www.fastandeasyhacking.com/download and download the tgz file
    2. cd /root/Downloads
    3. tar -xf armitage150813.tgz
    4. now head over to usr/share/armitage and replace all the files in that folder with your files you just downloaded and extracted.
    5. reboot [out of habbit]

    now you should have Armitage up and running

    remember to run /etc/init.d/postgresql start and msfdb init before you start Armitage

    Cheers
    Last edited by MMMarshal; 2015-08-15 at 04:30.

  25. #25
    Join Date
    2015-Aug
    Posts
    4
    i have the update on my laptop but it still not starting, after doing it all. i got it working on my VM, but still can't on the laptop full install.

  26. #26
    Join Date
    2015-Aug
    Posts
    4
    Quote Originally Posted by MMMarshal View Post
    After fiddling with my repos for at least an hour, trying different mirrors etc..., and reinstalling Kali 2.0 I finally just updated it manually. Im not sure what is going on with apt-get or the Kali repos but at least I have Armitage running.

    So if anyone else can't get the Armitage update this is a surefire method to fix it.

    1. head over to http://www.fastandeasyhacking.com/download and download the tgz file
    2. cd /root/Downloads
    3. tar -xf armitage150813.tgz
    4. now head over to usr/share/armitage and replace all the files in that folder with you files you just downloaded and extracted.
    5. reboot [out of habbit]

    now you should have Armitage up and running

    remember to run /etc/init.d/postgresql start and msfdb init before you start Armitage

    Cheers
    I can confirm this method worked for me after trying everything else. i did it through the gui copy and paste though, but it worked like a champ. thanks.

  27. #27
    Quote Originally Posted by MMMarshal View Post
    After fiddling with my repos for at least an hour, trying different mirrors etc..., and reinstalling Kali 2.0 I finally just updated it manually. Im not sure what is going on with apt-get or the Kali repos but at least I have Armitage running.

    So if anyone else can't get the Armitage update this is a surefire method to fix it.

    1. head over to http://www.fastandeasyhacking.com/download and download the tgz file
    2. cd /root/Downloads
    3. tar -xf armitage150813.tgz
    4. now head over to usr/share/armitage and replace all the files in that folder with your files you just downloaded and extracted.
    5. reboot [out of habbit]

    now you should have Armitage up and running

    remember to run /etc/init.d/postgresql start and msfdb init before you start Armitage

    Cheers
    OK good Thanks

  28. #28
    Join Date
    2015-Aug
    Posts
    1
    Quote Originally Posted by MMMarshal View Post
    After fiddling with my repos for at least an hour, trying different mirrors etc..., and reinstalling Kali 2.0 I finally just updated it manually. Im not sure what is going on with apt-get or the Kali repos but at least I have Armitage running.

    So if anyone else can't get the Armitage update this is a surefire method to fix it.

    1. head over to http://www.fastandeasyhacking.com/download and download the tgz file
    2. cd /root/Downloads
    3. tar -xf armitage150813.tgz
    4. now head over to usr/share/armitage and replace all the files in that folder with your files you just downloaded and extracted.
    5. reboot [out of habbit]

    now you should have Armitage up and running

    remember to run /etc/init.d/postgresql start and msfdb init before you start Armitage

    Cheers
    Thanks, works for me too!

  29. #29
    Join Date
    2014-Dec
    Posts
    34
    Quote Originally Posted by MMMarshal View Post
    After fiddling with my repos for at least an hour, trying different mirrors etc..., and reinstalling Kali 2.0 I finally just updated it manually. Im not sure what is going on with apt-get or the Kali repos but at least I have Armitage running.

    So if anyone else can't get the Armitage update this is a surefire method to fix it.

    1. head over to http://www.fastandeasyhacking.com/download and download the tgz file
    2. cd /root/Downloads
    3. tar -xf armitage150813.tgz
    4. now head over to usr/share/armitage and replace all the files in that folder with your files you just downloaded and extracted.
    5. reboot [out of habbit]

    now you should have Armitage up and running

    remember to run /etc/init.d/postgresql start and msfdb init before you start Armitage

    Cheers
    Note that while this may work temporarily, the next time you go to update the armitage package through the kali repos you will probably run into some issues.
    Top 10 Post Install Tips: Avoid Manual Installations of Tools in FSH Defined Directories

  30. #30
    Join Date
    2013-Sep
    Posts
    16
    You must do that before running armitage

    @service metasploit start
    @service postgresql start

    @/etc/init.d/postgresql start

    @armitage

  31. #31
    Join Date
    2015-Sep
    Posts
    1
    Quote Originally Posted by billbishere View Post
    since my thread was deleted, and I was linked to this thread... I will ask my questions here... I am getting the below error, I have went through all the suggested fixes in this post and nothing is fixing it. I have done all the updates, I have even done a complete reinstall of Metasploit framework

    A database appears to be already configured, skipping initialization
    [-] Failed to connect to the database: could not connect to server: Connection refused
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 7337?
    could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 7337?
    I am having the same problem. Getting the same error with metasploit as well as beef xss, and a few other programs:

    A database appears to be already configured, skipping initialization
    /usr/lib/x86_64-linux-gnu/ruby/2.1.0/enc/trans/transdb.so: [BUG] Bus Error at 0x007ff0e7669db8
    ruby 2.1.5p273 (2014-11-13) [x86_64-linux-gnu]

    -- Control frame information -----------------------------------------------
    c:0006 p:-3195116 s:0016 e:000015 TOP [FINISH]
    c:0005 p:---- s:0014 e:000013 CFUNC :require
    c:0004 p:0011 s:0010 e:000009 BLOCK <internal:enc/prelude>:3 [FINISH]
    c:0003 p:---- s:0007 e:000006 CFUNC :each
    c:0002 p:0010 s:0004 e:000003 TOP <internal:enc/prelude>:1 [FINISH]
    c:0001 p:0000 s:0002 E:000bd8 TOP [FINISH]

    -- Ruby level backtrace information ----------------------------------------
    <internal:enc/prelude>:1:in `<compiled>'
    <internal:enc/prelude>:1:in `each'
    <internal:enc/prelude>:3:in `block in <compiled>'
    <internal:enc/prelude>:3:in `require'

    -- C level backtrace information -------------------------------------------
    Inconsistency detected by ld.so: dl-open.c: 231: dl_open_worker: Assertion `_dl_debug_initialize (0, args->nsid)->r_state == RT_CONSISTENT' failed!

Similar Threads

  1. No menu when starting Kali
    By nitewalker41 in forum Installing Archive
    Replies: 1
    Last Post: 2015-06-23, 15:24
  2. Issues starting Postgresql to run Armitage
    By cyberphreax in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2014-09-19, 11:31
  3. Problem starting Kali
    By sianios in forum General Archive
    Replies: 0
    Last Post: 2013-07-30, 08:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •