Results 1 to 31 of 31

Thread: Kali 2.0 Will Not Shut Down or Restart

  1. #1
    Join Date
    2015-Aug
    Posts
    4

    Kali 2.0 Will Not Shut Down or Restart

    I did some quick searching and could not find any current solutions to a problem like this in linux or Kali specifically.

    I just did a fresh install (dual boot) of Kali 2.0 and everything works great except for when I want to shut down. Pressing the shutdown or restart buttons in the menu freeze the system and it hangs on the desktop. No applications close if any are open, and my mouse dissapears. Its seemed to be trying at first but I wait several minutes and it still does not shut down.

    Any advice? What sort of documentation or logs can I provide that would help?

    Thanks in advance!

  2. #2
    Join Date
    2015-Aug
    Posts
    1
    maybe typing 'halt -p' from command line should work...
    Yeah, I had the same problem as you did.
    Things changed greatly since 1.1.0a so we encounter a lot of problems. But let's stick togheter.

  3. #3
    Join Date
    2015-Aug
    Posts
    4
    'halt -p' worked. Is that an okay way to shut down for the time being? I have a standard user set up for normal everyday tasks and other programming endeavors, is there a logout command that might work the same way? (Logging out normally also locks up the system)

    Thanks Hiro!

  4. #4
    Join Date
    2015-Aug
    Posts
    1
    Same problem here!
    logout
    restart
    and shutdown not work and freez after that!

  5. #5
    Join Date
    2015-Aug
    Posts
    16
    I too have had hangs on shutdown using the GUI and reboot command.
    Hang is a black screen with a cursor in the upper left
    shutdown -h 0 seems to work well.

    Also during one of the hangs, I had been running ssh with X11 forwarding to a windows box, I closed the Xming client on my windows box and the Kali box immediately unfroze and shutdown.
    Hope this helps.

  6. #6
    I have the same problem, described by sierpwnsky, but for me 'halt', 'halt -p', 'poweroff', 'shutdown -h now' have the same result. I've also tried solutions suggested (in others linux distros forums) of modify the /etc/default/grub and /root/grub/grub.cfg archives "playing" with 'quiet', 'splash' 'acpi=force' and 'apm=power_off' commands but no one functioned for me, also this trouble happens with live kali 2.0 from the iso.

    The only two alternatives that had work for me are to press the sequence Alt+Sysrq+ (RSEIUB) and force the physical shutdown of my computer, but as you will advice to me none of these options are not for proper shutdown.

  7. #7
    Sorry for all, my problem was caused by mi lap's NVIDIA card, I've just configured bumblebee pack and add a script in /etc/rc.local to disable it because I do not pretend use it with Kali, all my problems gone and kali is working pretty nice for me.

  8. #8
    Join Date
    2014-Aug
    Posts
    34
    Oursnoir I dont understand quite what you said?
    I got same issue as you had, no command including halt -p and shutdown -h 0 work.
    I got nvidia optimus laptop with Nvidia card but have not installed bumblebee or nvidia drivers.

  9. #9
    Join Date
    2014-Aug
    Posts
    34
    Solved it:
    Added nomodset to the grub.cfg

  10. #10
    Join Date
    2015-Aug
    Posts
    3
    nomodeset dosen't work for me

  11. #11
    Join Date
    2015-Aug
    Posts
    3
    I have a similar problem in my 2.0 VM running on Vmware Fusion 7. It starts to shut down but then the CPU freezes. Screenshot here: https://robustfiles.com/dl.php?key=/...at22.20.46.jpg

  12. #12
    Rorshaq, does my solution work for you?:

    Go to the terminal and install Bumblebee

    apt-get install bumblebee

    then, execute the next command in your terminal and try to shut down or restart your computer by the waay you want, everyone should work:

    tee /proc/acpi/bbswitch <<<OFF

    If it works then, you can execute the command line inmediately your kali boots by access to /etc/rc.local by nano editor (or whichever you want):

    nano /etc/rc.local

    and then adding the next command line:

    tee /proc/acpi/bbswitch <<<OFF

    and thats all, now you can use kali linux as you want, you can now shutdown or restart your system before you started your session or by terminal commands or with gnome buttons, i hope it works for you

    Note: I stop my solution here because as i said in my last post I do not pretend use for now my NVIDIA card, but I've installed bumblebee because in a future I want to use it for parallel programming. If you want to use your GPU properly then follow the instructions to install and configure bumblebee in its page.

  13. #13
    Join Date
    2015-Aug
    Posts
    3
    I tried your solution but it didn't work for me. My OS still hangs out when restart or shut down. But is it possible that the problem come from my gpu which could be unstable ? because when i tried /etc/init.d/gdm3 stop to install the Nvidia proprietary driver the same thing happened.

    Thanks for your response and your help by the way =)

  14. #14
    Join Date
    2015-Jul
    Posts
    8
    Mine gives this output to tee after bumblebee install ..

    tee: /proc/acpi/bbswitch: No such file or directory
    OFF

  15. #15
    Join Date
    2015-Jul
    Posts
    8
    Hi everyone i have similiar problem, and i tried this bumblebee install but my tee /proc/acpi/bbswitch said no such file or directory grub.cfg i don't know how to modify because i did not understand the instructions. Can someone help me?

  16. #16
    Join Date
    2015-Aug
    Posts
    4
    So "halt -p" stopped working for me. The same issue has occurred when I use a live disk. I have since reinstalled Kali 2.0 and the problem occurs less often, but It still does. I try to be consistent and I kill all active programs then try shutting it down. It seems to work as long as I hope and think in my head "please work, please work, please work".

    All jokes aside, there is nothing I can see outright that is different about each time I shutdown, restart or log off. Occasionally, the system hangs and never shuts down. (It seems to be after killing everything first).

  17. #17
    Join Date
    2015-Jul
    Posts
    8
    I noticed that my computer freezes allso when i try to kill process with pkill maybe that is the reason to freeze after shutdown?
    my lcpsi did just run without any output and i tried to kill it.

  18. #18
    Join Date
    2013-Mar
    Location
    Brazil
    Posts
    52
    Ok guys!

    I have disabled the "Shared Folders" in VMWare machine options and everything gone back to normal.
    Last edited by PePeLeGal; 2015-08-31 at 12:45.

  19. #19
    Join Date
    2015-Sep
    Posts
    1
    Hello Kali Team,

    I have a HP DM4t-1100 with ATI graphics. I'm having the same issues; halt, bumblebee, and other fixes on this thread have not worked. I have to hard-shutdown the laptop every time, and after 10 or so of these data corruption occurs and I have to reinstall Kali. This has been my primary Kali Laptop and I've had to install the old version to continue using the OS.

    Thank You!
    Last edited by bahansen; 2015-09-01 at 03:17.

  20. #20
    Join Date
    2013-Mar
    Posts
    19
    Hi all,

    Please take a look at "https://forums.kali.org/showthread.p...-Reboot-Issues" and see if that helps.

  21. #21
    Join Date
    2015-Aug
    Posts
    4
    Thank you amorandi, that post fixed it for me! (It has been about a week now and I haven't had problems).

  22. #22
    Join Date
    2013-Mar
    Posts
    19
    Glad it worked sir! Thank you for replying!

  23. #23
    Join Date
    2015-Sep
    Location
    Sweden
    Posts
    3
    Hi all!

    I have tried all of the above solutions and nothing works for me. I have to use powerbutton to shutdown, and everytime i get a corrupted system and it wont start nomore.
    All works like a charm when im using Live boot from usb, but thats not a solution for me since i use my laptop as primary for work and studies.
    Im using a HP Pavilion dv6-3009so laptop.

    CPU/GPU:
    2,1 GHz AMD Athlon II Dual Core-processor P320
    ATI Mobility Radeon HD 5650

    Thanks in advance

    EDIT: its probably caused by using the full installer, i got 3 kids and no spare time, so im gonna try to install using mini and choose what to install myself when i get time..

    EDIT 2: problem was a compatiblity issue with my hardware, since i have no time fixing it i just installed it on my intel laptop and now i have no issues at all.. works like a charm. i recommend searching google for a fix outside of kali specific searches, like debian.
    Last edited by hagall; 2015-09-16 at 16:36. Reason: not solved, but found easier solution.

  24. #24
    Join Date
    2015-Sep
    Posts
    4
    Hi all,

    i have the same Problem. When i shutdown the computer or restart the screen went black. The Computer is still running, i have a black screen and nothing happens. I think the problem is about something with the grafic.

    During the installation i became the following screen:
    bbb.jpg

    My System:
    Intel Celeron N2940 (Bay-Trail)
    IntelĀ® HD Graphics

    Can me help somebody?

  25. #25
    Join Date
    2015-Jul
    Posts
    8
    Do you have similiar for ati graphics card?

  26. #26
    Join Date
    2015-Jul
    Posts
    8
    i solved my problem with opening /etc/modprobe.d/intel-microcode-blacklist.conf and adding line "blacklist snd-hda-intel" without the "" marks.

  27. #27
    Join Date
    2015-Oct
    Posts
    1
    Quote Originally Posted by Fall View Post
    i solved my problem with opening /etc/modprobe.d/intel-microcode-blacklist.conf and adding line "blacklist snd-hda-intel" without the "" marks.
    Just registered to say thank you man!!! it works!!

  28. #28
    Join Date
    2015-Jul
    Posts
    8
    Yes i guess intel sound drivers have conflict with something

  29. #29
    Join Date
    2015-Jul
    Posts
    8
    I got it work with sounds changing "blacklist snd-hda-intel" to "blacklist snd_hda_codec_hdmi" and adding to /etc/modprobe.d/alsa-base.conf file with one line "options snd-hda-intel model=auto" all these without "" marks ofcourse.

  30. #30
    Join Date
    2013-May
    Posts
    10

    Here is some of the commands you can use to shutdown or restart your system.
    init 0 -> change to runlevel 0 which shuts down system correctly
    logout -> leaving session
    reboot -> self explanatory
    shutdown -h now -> shutdown right NOW
    shutdown -h 16:30 & -> planned shutdown of system in background
    shutdown -c -> cancel planned shutdown of system
    telinit 0 -> another way of shut down

    Hope some of them help. Best of luck to you!

    ~ eof

  31. #31
    Join Date
    2013-May
    Posts
    10
    Try some of the commands I posted in this thread. Let me know if it works. Good luck!

Similar Threads

  1. Kali 2.0 Restart and Shutdown Hangs
    By nekromantik in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-09-29, 22:21
  2. Problem In System [ Shut Down ]
    By AllaWi in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-08-31, 22:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •