Results 1 to 17 of 17

Thread: Sana (2.0 Kali) - R/O file system with kali-rpi2.img

  1. #1
    Join Date
    2015-Feb
    Posts
    8

    Sana (2.0 Kali) - R/O file system with kali-rpi2.img

    I downloaded, extracted (kali-2.0-rpi2.img.xz) and imaged a microsd card for my raspberry pi 2. once the DD was done, I extended the partition with gparted to fill the disk, and then applied the changes. upon boot on the PI 2, the and trying to update/remove the ssh keys, I kept getting errors, apt-get update also failed, when digging in further I discovered the file system was read-only. is there an easy way to change this?

    I had no issues with the 1.1.0a image for the PI2.

    any help would be appreciated.

  2. #2
    Join Date
    2013-Mar
    Location
    Root
    Posts
    13
    I am having the same issue, wont let me startx due to read only file system.
    The only reason that you fail is because you quit....

  3. #3
    Join Date
    2015-Aug
    Posts
    1
    Nice to see i'm not the only one having the same issue.

    I noticed if you login and remount the filesystem as RW it seems to work

    mount -o remount,rw /

    However you will need to do that after each reboot.
    Very much less than ideal. I hope it gets sorted soon.

  4. #4
    Join Date
    2014-Mar
    Posts
    9
    Yep - same issue here. startx not working.

  5. #5
    Join Date
    2015-Aug
    Posts
    2
    Quote Originally Posted by zerocool View Post
    I am having the same issue, wont let me startx due to read only file system.
    I have the same problem...

  6. #6
    Join Date
    2015-Aug
    Posts
    6
    Hi there im new here.
    I got the same problem, but i solved it with:

    mount -n -o remount rw /
    Apply this after root login, then startx.

    Hope it helps.

  7. #7
    Join Date
    2015-Aug
    Posts
    2
    Quote Originally Posted by Naprosnia View Post
    Hi there im new here.
    I got the same problem, but i solved it with:



    Apply this after root login, then startx.

    Hope it helps.
    It works. Thank you

  8. #8
    Join Date
    2015-Aug
    Posts
    1
    here is the solution:

    1. mount -o remount,rw /
    2. blkid
    3. make your gstab file more info here
    4. resize your root partition more info here
    5. apt-get update
    6. apt-get install kali-linux-full
    7. don't forget to change your default ssh keys

  9. #9
    Join Date
    2015-Feb
    Posts
    8
    mount -o remount,rw /

    after this it loads kali login but freezes...

    tried two different keyboards...

  10. #10
    Join Date
    2015-Aug
    Posts
    6
    Quote Originally Posted by z0rx0 View Post
    here is the solution:

    1. mount -o remount,rw /
    2. blkid
    3. make your gstab file more info here
    4. resize your root partition more info here
    5. apt-get update
    6. apt-get install kali-linux-full
    7. don't forget to change your default ssh keys
    Hi, can you explain the 3 step?

  11. #11
    Join Date
    2015-Aug
    Posts
    1
    On the 64gb boot partition, edit cmdline.txt from "dwc_otg.fiq_fix_enable=1 console=tty1 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait ro rootflags=noload" to "dwc_otg.fiq_fix_enable=1 console=tty1 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait rw rootflags=noload"

    Worked for me.

  12. #12
    Join Date
    2015-Aug
    Posts
    4
    Note: moved this answer from another question. One of my talents, it seems, is giving correct answers to wrong questions. Oh well.

    I've got it sorted out.What happens is that the root volume is mounted read only by reason of a kernel boot option.

    I did some fiddling, and this will do the trick:

    boot, login as root.
    remount the root as writeable:
    mount -o,remount,rw

    And lo and behold, x starts up. Login as root.
    On roots desktop, there's an icon for a 64MB filesystem. Doubleclick to mount and open it. It looks suspiciously like the /boot partition you' ve been trying to find.
    Using a terminal go to the directory (something like /media/root/foo/) and use vi or nano to edit cmdline.txt
    change ro to rw
    save, reboot. All is well now.

    Note: yes, this is also the spot to put your config.txt file.

  13. #13
    Join Date
    2015-Aug
    Posts
    3
    I also have that issues, Today i install the kali2 on raspberry,but i try to use the touch commad to touch creare a file,it note the " Read-only file system",so i use "mount -o remount,rw / "commad to deal the problem,and it works again,but unfortunately ,i just reboot th PI ,the issues get apper again,maybe it is the system bug.

  14. #14
    Join Date
    2015-Aug
    Posts
    3
    Hi,i'm joe.Just now,i find a way to solv that issuse,i trying to add a system script ,and let it startup with system,so that script will remount the file system on system up.I think it will solv the issue temporary.Hope it can help u.My Email address : michael_joe@126.com.look forward your reply.Thanks.
    Last edited by michael_joe; 2015-08-13 at 09:27. Reason: sytanx errot

  15. #15
    Join Date
    2015-Aug
    Posts
    6
    Quote Originally Posted by RenePieters View Post
    Note: moved this answer from another question. One of my talents, it seems, is giving correct answers to wrong questions. Oh well.

    I've got it sorted out.What happens is that the root volume is mounted read only by reason of a kernel boot option.

    I did some fiddling, and this will do the trick:

    boot, login as root.
    remount the root as writeable:
    mount -o,remount,rw

    And lo and behold, x starts up. Login as root.
    On roots desktop, there's an icon for a 64MB filesystem. Doubleclick to mount and open it. It looks suspiciously like the /boot partition you' ve been trying to find.
    Using a terminal go to the directory (something like /media/root/foo/) and use vi or nano to edit cmdline.txt
    change ro to rw
    save, reboot. All is well now.

    Note: yes, this is also the spot to put your config.txt file.
    Hi. Thanks man, it worked for me.

  16. #16
    Join Date
    2014-Feb
    Posts
    298
    Hey all,

    Sorry about that, I've built a new image and it will hopefully be pushed out soon (I need to test another change made), that removes the ro from the cmdline and also enables root login without having an ssh key.

    The other comments about remount,rw are correct, and editing the cmdline if you don't want to wait or re-image.

    There's also a bug open about it already at https://bugs.kali.org/view.php?id=2504

  17. #17
    Join Date
    2015-Aug
    Posts
    4
    You can put the mount -o,remount,rw in /etc/rc.local, above the last line of that file.

Similar Threads

  1. Replies: 2
    Last Post: 2017-01-08, 19:51
  2. odroid XU4 with Kali 2 , read only file system
    By smile78 in forum ARM Archive
    Replies: 33
    Last Post: 2015-10-14, 17:31
  3. RPI2 Kali Sana how to resize filesystem?
    By Naprosnia in forum ARM Archive
    Replies: 15
    Last Post: 2015-09-14, 18:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •