Results 1 to 14 of 14

Thread: Kali 2.0 Update Issue

  1. #1
    Join Date
    2015-Aug
    Posts
    2

    Kali 2.0 Update Issue

    When ever I try and update the previous install of Kali to version 2.0 after changing the sources.list file with the new deb-src's I get this error mesages like "Err http://http.kali.org sana InRelease" and "Unable to connect to http.kali.org:http:" looking like that for each deb src. My sources.list contains

    deb http://http.kali.org/kali sana main contrib non-free
    deb-src http://http.kali.org/kali sana main contrib non-free
    deb http://security.kali.org/kali-security sana/updates main contrib non-free
    deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

    I tried changing them to the previous versions sources.list but that did nothing, actually looked like it failed the same way the original sources.list failed. Anyone have this issue and found a fix?

  2. #2
    Join Date
    2015-Jun
    Posts
    14
    Just a word of caution. I've tried performing upgrades on 3 different 1.1 installs and each one failed. As painful as it might be, you might want to start with a fresh install of 2.0.

  3. #3
    Join Date
    2014-Jun
    Posts
    71
    I prefer a fresh install. ! always. too many issues :/

  4. #4
    Join Date
    2015-Aug
    Posts
    1
    hey guys new here. any of you had success on this? every time i tried updating kali by downloading the zip then flashing from recovery it never updates no matter what 3x already with 2.0 and previous update versions when i type lsb_release -a always says 1.1.0. why is that?? even with a fresh zip download of 2.0

  5. #5
    Join Date
    2015-Aug
    Posts
    8
    I've tried updating two different machines as well with no success. I ended up doing a fresh install as all of my data was on different drives anyway, if you do get it to work let us know.

  6. #6
    Join Date
    2015-Jul
    Location
    U.S.A
    Posts
    5
    DAmmmmmm, I cant upgrade either, don't want new install, I have dual boot....

  7. #7
    Join Date
    2015-Jun
    Posts
    14
    Quote Originally Posted by produkt View Post
    DAmmmmmm, I cant upgrade either, don't want new install, I have dual boot....
    What's your base platform? I'm dual booting Yosemite and Kali on a Retina MacBook Pro and didn't have any issues other than my wireless not working in 2.0. The fresh install probably took less time than an upgrade anyway.
    Last edited by sil3ntcor3; 2015-08-13 at 15:08.

  8. #8
    Join Date
    2015-Jul
    Location
    U.S.A
    Posts
    5
    I a newly upgraded Os win7 to win10 and kali 1.x with grub loader. It all seems to download and all but at the end...nothing???

  9. #9
    Join Date
    2013-Jun
    Posts
    94
    Is there a process to update to the new kali without issues or is everyone just wiping the kali install and successfully installing the new kali, is it straight forward with leaving original grub and win7 on other partition, without problems....I understand issues could arrise as there are so many different install situations and operating systems dual booting etc. my original partitions for the operating systems were created before installing grub and things went smoothly last time with everything.
    I also understand that updating your sources.list for 2.0 and only using original sources in the past for upgrading is vital to a smooth upgrade.
    Last edited by undersc0re; 2015-08-13 at 18:21.

  10. #10
    Join Date
    2015-Jun
    Posts
    14
    Quote Originally Posted by produkt View Post
    I a newly upgraded Os win7 to win10 and kali 1.x with grub loader. It all seems to download and all but at the end...nothing???
    I'm not sure if it's the same for a Windows box or not, but for my Mac I just followed the same instructions as I did when I did it for the first time.

    Quote Originally Posted by undersc0re View Post
    Is there a process to update to the new kali without issues or is everyone just wiping the kali install and successfully installing the new kali, is it straight forward with leaving original grub and win7 on other partition, without problems....I understand issues could arrise as there are so many different install situations and operating systems dual booting etc. my original partitions for the operating systems were created before installing grub and things went smoothly last time with everything.
    I also understand that updating your sources.list for 2.0 and only using original sources in the past for upgrading is vital to a smooth upgrade.
    I haven't seen a successful 1.x to 2.0 upgrade yet and that's out of ~5. So I would suggest a fresh install.

  11. #11
    Join Date
    2013-May
    Posts
    15
    I'm having the same experience with upgrade attempts, no luck. 2012 MacMini and VMWare Fusion 7.1.2. Upgrading an up-to-date Kali 1.1 to 2.0. I could ditch the VM and lose nothing of value, but hey, I'd like to get it fixed just ~because~.

    This may not help anyone, but here's what I'm seeing.

    Attempting to boot gets me to a grey frowny face screen:
    Code:
    Oh no! Something has gone wrong.
    A problem has occurred and the system can't recover.
    Please log out and try again.
    Logging out doesn't help at all. Screen flashes black and then returns to the grey screen.

    I can boot into recovery mode and everything seems to be there and working fine, so it seemed like the GUI was failing. Trying to launch gnome-shell from here gives me this.
    Code:
    root@kali:~# gnome-shell
    
    (gnome-shell:2137): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to open display. You have to set the DISPLAY environment variable, or use the --display command line argument
    
    (gnome-shell:2137): mutter-ERROR **: Unable to initialize Clutter.
    
    [   29.468004] traps: gnome-shell[2137] trap int3 ip:7fed17feed30 sp:7fffca7c2050 error:0
    Trace/breakpoint trap
    root@kali:~#
    Trying to specify a display with something like --display 0 gives me a similar error, only the first line states "unable to open display '0'" and ends there, the rest of the lines are still present.

    I've tried removing and reinstalling gnome-shell, no progress. Googleing the Clutter/mutter errors doesn't seem to give me any relevant results.
    Last edited by BeanBagKing; 2015-08-14 at 13:03.

  12. #12
    Join Date
    2014-Aug
    Posts
    34
    I had this also.
    I think its due to the gdm install getting messed up.
    Also my Optimus laptop has always had issues with Linux but it was fairly simple with 1.1 as it defaulted to intel card.
    I got bit further by installing kde plasma and I get login screen but after login I get same oops something gone wrong.
    I will try reinstall nvidia drivers and gmd3.

  13. #13
    Join Date
    2015-Aug
    Posts
    2
    Same error.
    So then I re-upgraded the entire system and packages w.r.t errors in every package.

    Also I applied "Auto login" for my non-root account. And it worked perfect when this existed. But then I removed Auto-login and rebooted system only to get back stuck with the error.

    Also "gnome-shell --display=:0" gives an error -
    Fatal IO error 0 (Success) on X server :0.

  14. #14
    Join Date
    2015-Aug
    Posts
    2
    Figured out a way to load into the UI mode.
    You can go here and edit this file

    root@kali:~# vi /etc/gdm3/daemon.conf

    Add the below two lines to auto-log in as a non-root user

    AutomaticLoginEnable = true
    AutomaticLogin = Bose
    I was just playing around for hours with this config and came to know this bypass. Doesn't work for root user though. Logging off will again give you the same error.

Similar Threads

  1. Kali Linux 4.14.12 update issue (os won't boot)
    By Plagues in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2018-01-13, 10:34
  2. Kali Sana to Rolling update issue.
    By alacazam in forum Installing Archive
    Replies: 3
    Last Post: 2016-02-02, 06:40
  3. Kali Linux Update and Repository Issue
    By oanahmed in forum General Archive
    Replies: 0
    Last Post: 2013-07-11, 05:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •