Results 1 to 5 of 5

Thread: SSH authentication not working on new Nethunter 2.0

  1. #1
    Join Date
    2015-Aug
    Posts
    1

    SSH authentication not working on new Nethunter 2.0

    I recently updated Nethunter since Kali 2.0 was released. No matter what I do it is not accepting the default root and toor to login through SSH from my PC. I have completely reloaded and I'm still facing the same issue. I even tried creating another account with root access with no luck. I'm thinking perhaps SSH is hitting the actual phone and not the Kali install sitting on top of it perhaps?

  2. #2
    Yeah SSH appears to be broken I'm staying away from 2.0 for a few weeks a lot of stuff isn't working I finally managed to I think get my TP-LINKWN722N wireless card working.

  3. #3
    Join Date
    2015-Aug
    Posts
    2
    It's not broken, the SSH daemon is just configured to not permit root login via password.

    If you want to change that, it works:

    edit /etc/ssh/sshd_config

    change:
    PermitRootLogin without-password

    to:
    PermitRootLogin yes

    That's it. After that the login with password works.

  4. #4
    Join Date
    2015-Oct
    Posts
    1
    Hi, ive tried these methods to get my ssh to work but it is still not working. I'm running kali nethunter 2.0 lollipop on my nexus 10 32gb. I have tried editing the sshd_config file but to no avail. Ive also tried editing thte /root/.ssh/authorized_keys file but that also dosent work. Any help would be apreciated.

  5. #5
    Join Date
    2016-Nov
    Posts
    12

    PubKey

    Quote Originally Posted by logicalien View Post
    Hi, ive tried these methods to get my ssh to work but it is still not working. I'm running kali nethunter 2.0 lollipop on my nexus 10 32gb. I have tried editing the sshd_config file but to no avail. Ive also tried editing thte /root/.ssh/authorized_keys file but that also dosent work. Any help would be apreciated.
    Also needed to uncomment the PubKeyAuthentication and it works

Similar Threads

  1. Nethunter 3 + Nexus 5 + TL-WN722N = NOT WORKING
    By BlackMagic in forum NetHunter General Questions
    Replies: 1
    Last Post: 2016-11-27, 21:34
  2. BadUSB not working in Nethunter 3.0
    By Rajnish357 in forum NetHunter General Questions
    Replies: 4
    Last Post: 2016-03-12, 07:44
  3. NetHunter in Note 3, working!
    By yak_vi in forum Building NetHunter
    Replies: 5
    Last Post: 2016-02-25, 04:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •