Results 1 to 11 of 11

Thread: Can't login after the upgrade to Kali linux 2.0

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2015-Aug
    Posts
    5

    Can't login after the upgrade to Kali linux 2.0

    I'm having a problem after the upgrade attempts, no luck. Upgrading an up-to-date Kali 1.1 to 2.0. but hey, I'd like to get it fixed just ~because~.

    This may not help anyone, but here's what I'm seeing.

    Attempting to boot gets me to a grey frowzy face screen:
    Code:
    Oh no! Something has gone wrong.
    A problem has occurred and the system can't recover.
    Please log out and try again.
    I have two cards installed
    Code:
    Nvidia
    Intel
    After reading the X.org error I found that there is an error which is "No screens found", I've tried uninstalling the gdm3 and the xorg.conf but nothing happened.

  2. #2
    Join Date
    2015-Aug
    Posts
    5
    I solve the problem by removing the Nvidia drivers.
    after the black screen I click the ALT+CTRL+F1 and after that use this code
    Code:
    apt-get remove nvidia* --purge
    and after that
    Code:
    reboot
    it works fine

  3. #3
    Join Date
    2014-Feb
    Posts
    1

    Thank you

    Quote Originally Posted by mohdows View Post
    I solve the problem by removing the Nvidia drivers.
    after the black screen I click the ALT+CTRL+F1 and after that use this code
    Code:
    apt-get remove nvidia* --purge
    and after that
    Code:
    reboot
    it works fine
    Simple solution, worked perfect! Thanks

  4. #4
    Join Date
    2015-Aug
    Posts
    7
    Hello my friend ..
    I had the same problem
    And I fixed it this way ..
    First u need to boot to recovery
    And plug ethernet cable to your laptop/pc
    Then .
    Apply .
    nano /etc/apt/sources.list
    And erase all sources and past this
    PHP Code:
    deb http://http.kali.org/kali sana main non-free contrib
    deb http://security.kali.org/kali-security sana/updates main contrib non-free
    deb-src http://http.kali.org/kali sana main non-free contrib
    deb-src http://security.kali.org/kali-security sana/updates main contrib non-free 
    Then Ctrl x
    Y
    Enter
    Then apply
    PHP Code:
    apt-get update
    apt
    -get upgrade
    apt
    -get dist-upgrade 
    And I wish it will help u

  5. #5
    Join Date
    2013-Dec
    Posts
    2
    None of the options helped me

    I don't have any nvidia driver (coming from a vmware machine) and no luck after adding the two src lines (I already had the others).

    Any help?


    It happened after I dist upgraded to 2.0.

  6. #6
    Join Date
    2015-Sep
    Posts
    1
    Finally ,no need of startx i think i have a solution When logout error appear just press
    (Ctrl+Alt and F1 or F2 )
    And enter your previously used root username password or create another user and after that run this command
    # vi /etc/gdm3/daemon.conf (use sudo for non root user )

    And change it
    AutomaticLoginEnable=false
    AutomaticLogin=root or user1 (if u create a new user and want to login from it)

    To

    AutomaticLoginEnable=true
    AutomaticLogin=root or user1

  7. #7
    Join Date
    2013-Dec
    Posts
    2
    Quote Originally Posted by Psysin View Post
    Finally ,no need of startx i think i have a solution When logout error appear just press
    (Ctrl+Alt and F1 or F2 )
    And enter your previously used root username password or create another user and after that run this command
    # vi /etc/gdm3/daemon.conf (use sudo for non root user )

    And change it
    AutomaticLoginEnable=false
    AutomaticLogin=root or user1 (if u create a new user and want to login from it)

    To

    AutomaticLoginEnable=true
    AutomaticLogin=root or user1
    Thank you! that finally fixed it for me!

  8. #8
    Join Date
    2016-Jan
    Posts
    1
    Quote Originally Posted by Psysin View Post
    Finally ,no need of startx i think i have a solution When logout error appear just press
    (Ctrl+Alt and F1 or F2 )
    And enter your previously used root username password or create another user and after that run this command
    # vi /etc/gdm3/daemon.conf (use sudo for non root user )

    And change it
    AutomaticLoginEnable=false
    AutomaticLogin=root or user1 (if u create a new user and want to login from it)

    To

    AutomaticLoginEnable=true
    AutomaticLogin=root or user1
    Psysin, thank you. This works.

    I have been do so many apt-get install/remove/update/upgrade/dist-upgrade/purge/autoremove commands that I'm surprised the system works at all.

  9. #9
    Join Date
    2016-Jan
    Posts
    1
    hey psysin it is showing that - no such file or directory exists plz help me !!!!!

  10. #10
    Join Date
    2013-Nov
    Location
    Staten Island, NY
    Posts
    3
    Hey guys. I've tried all of the above options and I still get the "Oh no! Something has gone wrong..." error. What else can I try?

  11. #11
    Join Date
    2013-Apr
    Posts
    182
    cd /etc/X11/ if there are xorg.conf . and rename it .

    if not resolve , apt-get install lightdm

    and dpkg-reconfigure gdm3 change gdm3 to lightdm .

    if still not workable ,

    apt-get remove gnome-shell .


    reboot .

    and them apt-get install gnome-shell and gnome-core .

    hope this can help you .

Similar Threads

  1. Black screen after login after upgrade/dist-upgrade
    By pendragyn in forum TroubleShooting Archive
    Replies: 16
    Last Post: 2017-03-29, 10:13
  2. Replies: 0
    Last Post: 2016-02-21, 04:46
  3. Unable to login as root after PWK upgrade to Kali Linux 2.0
    By goku-vinu in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2015-09-27, 11:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •