Results 1 to 2 of 2

Thread: Installation Error drivers awus036ac-rtl8812au.

  1. #1
    Join Date

    Unhappy Installation Error drivers awus036ac-rtl8812au.

    Hi, I'm trying to install the drivers for the card awus036ac-rtl8812au-Kali2.0. During installation I get this answer
    root@snofi:~/Desktop/rtl8812au-linux# make
    make ARCH= CROSS_COMPILE= -C  M=/root/Desktop/rtl8812au-linux  modules
    make[1]: *** M=/root/Desktop/rtl8812au-linux: No such file or directory. Stop.
    Makefile:1040: commands for target 'modules' failed
    make: *** [modules] Error 2
    When you create a directory in the lib / modules / 4.0.0-kali1-amd64 / "builid"
    I get this answer
    root @ snofi: ~ / Desktop / rtl8812au-linux # make
    make ARCH = x86_64 CROSS_COMPILE = C /lib/modules/4.0.0-kali1-amd64/build M = / root / Desktop / rtl8812au-linux modules
    make [1]: Entering directory '/lib/modules/4.0.0-kali1-amd64/build'
    make [1]: *** No rule to perform object 'modules'. Stop.
    make [1]: Leaving directory '/lib/modules/4.0.0-kali1-amd64/build'
    Makefile: 1040: commands for target 'modules' failed
    make: *** [modules] Error 2
    I also tried the script on this page are getting this answer
    root@snofi:~/Desktop# ./ 
    ./ linia 6: eselect:command is not found
    Please ensure the eselected kernel source and running kernel are the same version, then try again.
    Please write as you go through the process of installing these drivers. Regards

    I tried even as it is written on this web site (, the previous version installed without problems. Here for the first command I get a good response. On the second I got it
    root@snofi:~/git/rtl8812AU_8821AU_linux# sudo dkms add -m rtl8812AU_8821AU_linux -v 1.0
    sudo: dkms: command is not found
    I can not install dkms.

    I worked it out with DKMS downloaded Debian package installed and the second command went ok, but the third and fourth sinus trouble again.
     root@snofi:~/git/rtl8812AU_8821AU_linux# sudo dkms build -m rtl8812AU_8821AU_linux -v 1.0
    Error! echo
    Your kernel headers for kernel 4.0.0-kali1-amd64 cannot be found at
    /lib/modules/4.0.0-kali1-amd64/build or /lib/modules/4.0.0-kali1-amd64/source.
    root@snofi:~/git/rtl8812AU_8821AU_linux# sudo dkms install -m rtl8812AU_8821AU_linux -v 1.0
    Error! echo
    Your kernel headers for kernel 4.0.0-kali1-amd64 cannot be found at
    /lib/modules/4.0.0-kali1-amd64/build or /lib/modules/4.0.0-kali1-amd64/source.
    Last edited by snofi; 2015-08-17 at 15:19. Reason: Because I have to.

  2. #2
    Join Date

    Did you solve this?
    I'm having the exact same issue and gets the same errors.

Similar Threads

  1. Replies: 1
    Last Post: 2017-12-21, 17:32
  2. Replies: 0
    Last Post: 2017-08-23, 14:39
  3. Kali Linux AWUS036AC driver installation problems
    By Frouse in forum General Archive
    Replies: 3
    Last Post: 2016-05-21, 11:18
  4. Kali Linux VBox awus036ac driver installation
    By plkas12 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-08-10, 06:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts