Results 1 to 3 of 3

Thread: Simple Solution to the airmon-ng-networkmanager problem in kali2.0

  1. #1
    Join Date
    2013-Jul
    Posts
    841

    Simple Solution to the airmon-ng-networkmanager problem in kali2.0

    Here is a simple solution to the network manager interference problem.

    It was suggested by seen_bawl during the negative-one problems and MTeams have been using it ever since.

    Leaving network manager running

    airmon-ng start wlan0
    ifconfig wlan0mon down
    iwconfig wlan0mon mode monitor
    ifconfig wlan0mon up

    Now just run airodump-ng

    This works for us

    To put back in managed mode

    airmon-ng stop wlan0mon
    ifconfig wlan0 down
    iwconfig wlan0 mode managed
    ifconfig wlan0 up


    Musket Teams

  2. #2
    Join Date
    2013-Mar
    Posts
    38
    airmon-ng isnt doing anything for you here

    just

    ifconfig wlan1 down
    iwconfig wlan1 mode monitor
    ifconfig wlan1 up

    run airodump on wlan1

  3. #3
    Join Date
    2013-Jul
    Posts
    841
    To wurmt0ngue

    We wondered when someone would recognize this -well done. Our current view on this matter is as follows:

    We have been going thru the lines of code in the newer airmon-ng trying to remove the inability to make multiple monitors. When placing the device into monitor mode to allow packet injection etc there is extensive use of iwconfig mode monitor in the process.

    We notice with kali-2.0 that if you put the device in monitor
    mode with airmon-ng,

    airmon-ng start wlan0

    then the airmon-ng program itself doesnot recognize that it has just completed the process. Furthermore if you try and remove the very same monitor in this case wlan0mon, airmon-ng tells you there is no monitor present and gives you a long warning message.

    The only way to remove the wlan0mon thru the terminal window
    is to:

    ifconfig wlan0mon down
    iwconfig wlan0mon mode monitor
    ifconfig wlan0mon up
    airmon-ng stop wlan0mon

    (you could unplug the device instead)

    This is telling us that the system is not recognizing that the device is in monitor mode?

    Under the older airmon-ng we had a negative one issue

    If after making your monitor ie mon0 you place the device wlan0 in mode monitor then the negative-one issue dissappeared and everything ran fine. Remember airmon-ng made the virtual device first.

    We think the problem is the bundling of the physical device and the virtual device into one entity. This is confusing Network Manager which is trying to access a device. Since you can no longer turn off individual wifi devices and since mode monitor is not recognized then network manager keeps trying to use the device.

    MTeams

Similar Threads

  1. Replies: 6
    Last Post: 2016-10-10, 22:59
  2. Airmon-ng Network-manager Commentary Kali2.0
    By mmusket33 in forum General Archive
    Replies: 7
    Last Post: 2016-02-14, 23:21
  3. Replies: 1
    Last Post: 2016-01-13, 17:18
  4. Replies: 0
    Last Post: 2015-08-16, 03:42
  5. Replies: 1
    Last Post: 2014-05-30, 06:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •