Results 1 to 2 of 2

Thread: Hostapd + "Device Not Managed"

  1. #1
    Join Date

    Hostapd + "Device Not Managed"

    Hello all,

    I am running Kali on a Raspberry Pi 2. I attempted to use an adapter running a Ralink 2080/3070 chipset driven by rt2800usb to create a wireless hotspot to host a server from (ie no NAT necessary). I could not get any devices to associate with the hotspot. I assume the issues are probably with the driver. I have nl80211 listed in /etc/hostapd/hostapd.conf. Intuitively you would think that rt2800usb should be listed, but when I do that it says invalid/unknown driver which I find bizarre considering I have used the adapter to connect to the internet with no problems.

    More issues came when I decided to give up on the hotspot. Now, my wireless device cannot be used to connect to the internet. Network Manager claims that the device is not managed, but iwconfig insists that it is. I have tried manually changing its mode to managed with no luck. I have double checked that /etc/network/interfaces is back to default with no luck. The adapter still works with other computers.

    It is worth mentioning that this also happens when I try to do it with a laptop running Kali, but rebooting the system restores functionality to the wireless card.

  2. #2
    Join Date
    I do have the similar problem, can't get working my awus036nh (ralink 2080/3070) working with HOSTAPD.
    Tried to run hostapd.conf file with nl80211 or rt2800usb - unsuccessful.

Similar Threads

  1. Replies: 2
    Last Post: 2023-04-12, 10:27
  2. Replies: 0
    Last Post: 2022-04-14, 02:30
  3. Replies: 2
    Last Post: 2019-05-27, 10:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts