Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Installing a different web browser Kali 2.0

  1. #1
    Junior Member
    Join Date
    Aug 2015
    Posts
    2

    Unhappy Installing a different web browser Kali 2.0

    Hello everyone,
    I'm new around here and I just installed Kali 2.0 and I'm using it as the main os on my laptop, for personal reasons I need at least 2 browsers so I tried to install Google chrome and after few hours of research I found that I needed the depencies libappindicator1 which I couldn't install, here is the error:
    'The following packages have unmet dependencies:
    google-chrome-stable : Depends: libappindicator1 but it is not installable'

    So I'm looking for a way to install chrome or the depencies if possible, otherwise what would you recommend as a second browser that I can actually install?

    Thanks a lot for your help, and have a good day

  2. #2
    Senior Member
    Join Date
    Jul 2015
    Location
    /home/duxim
    Posts
    400
    use
    apt-get install
    google chrome, but in this moment I can not remember what exactly you should type
    is it google chrome or google chrome stabile (research a little)
    and do this from user account with sudo

  3. #3
    Member
    Join Date
    Jun 2015
    Posts
    48
    It may be Chromium not Chrome.

  4. #4
    Junior Member
    Join Date
    Aug 2015
    Posts
    5
    I have successfully installed google chrome on kali 2.0, you can do this as follows:
    (1) use iceweasel to open "https://www.google.com/chrome/browser/desktop/index.html", and download "google-chrome-stable_current_i386.deb" or "google-chrome-stable_current_amd64.deb" based on your system.
    (2) dpkg -i xxxx.deb
    (3) you can see the chrome icon on application menu----->internet
    (3) apt-get install alacarte
    (4) add a new user "chromeuser" using command adduser -m chromeuser
    (5) open application menu--->usual appplications----> accessories---->main menu and find chrome's icon, click preferences, add command "gksu -u chromeuser /usr/bin/google-chrome-stable", and quit.
    (6) click the chrome icon, wait a minute then the chrome run.

  5. #5
    Junior Member
    Join Date
    Aug 2015
    Posts
    2
    Thanks for your input, I get a problem on the second step with this message: 'The following packages have unmet dependencies:
    google-chrome-stable : Depends: libappindicator1 but it is not installable'

  6. #6
    Junior Member
    Join Date
    Aug 2015
    Posts
    5
    if you get such a problem, you should do other things before the second setp as follows:
    (1) add other source at /etc/apt/source.list 's end:
    ## Regular repositories
    deb http://http.kali.org/kali kali main non-free contrib
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    ## Source repositories
    deb-src http://http.kali.org/kali kali main non-free contrib
    deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

    then you input command :
    apt-get update
    apt-get install -f
    you should begin to install libappindicator1 and update

    (2) By the way, I add one more point.
    on the fifth step, if useing gksu -u xxx, I find that the chrome will happen some problem, other input method is not working as usually. As a result, you should use command " /usr/bin/google-chrome-stable --no-sandbox"
    before doing this, you should edit file such as follow:
    leafpad /opt/google/chrome/google-chrome or google-chrome-stable
    add "–user-data-dir" at end.

    good lucky!

  7. #7
    Junior Member
    Join Date
    Aug 2015
    Posts
    1
    Quote Originally Posted by hanxing View Post
    if you get such a problem, you should do other things before the second setp as follows:
    (1) add other source at /etc/apt/source.list 's end:
    ## Regular repositories
    deb http://http.kali.org/kali kali main non-free contrib
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    ## Source repositories
    deb-src http://http.kali.org/kali kali main non-free contrib
    deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

    then you input command :
    apt-get update
    apt-get install -f
    you should begin to install libappindicator1 and update

    (2) By the way, I add one more point.
    on the fifth step, if useing gksu -u xxx, I find that the chrome will happen some problem, other input method is not working as usually. As a result, you should use command " /usr/bin/google-chrome-stable --no-sandbox"
    before doing this, you should edit file such as follow:
    leafpad /opt/google/chrome/google-chrome or google-chrome-stable
    add "ľuser-data-dir" at end.

    good lucky!
    Hi, after searching for ages your steps seem to get me the closest to success. yet when i run chrome from terminal "google-chrome &" i get an error code back "6132" and no information.

  8. #8
    Junior Member
    Join Date
    Aug 2015
    Posts
    5
    At first, you can login the system with other user, then run chrome from terminal "google-chrome", if chrome run normally, the browser is OK. otherwise, you should run again "dpkg -i xxx.deb"
    then you can login using root,
    if you login the system using root, you can read "(2) By the way, I add one more point". After editing /opt/google/chrome/google-chrome, you should input command " google-chrom --no-sandbox".

  9. #9
    Quote Originally Posted by gourraguis View Post
    Hello everyone,
    I'm new around here and I just installed Kali 2.0 and I'm using it as the main os on my laptop, for personal reasons I need at least 2 browsers so I tried to install Google chrome and after few hours of research I found that I needed the depencies libappindicator1 which I couldn't install, here is the error:
    'The following packages have unmet dependencies:
    google-chrome-stable : Depends: libappindicator1 but it is not installable'

    So I'm looking for a way to install chrome or the depencies if possible, otherwise what would you recommend as a second browser that I can actually install?

    Thanks a lot for your help, and have a good day
    I dont mean to question your inteligence and sorry if this seems like a stupid question, but have you manually downloaded the chroot, and updated the app? This has been something i have spent blood sweat and tears to discover. If u have already done this try putting this in your terminal through vnc.

    apt-get update
    apt-get install firefox-esr

  10. #10
    Junior Member
    Join Date
    Oct 2013
    Posts
    9
    hey guys,
    following the steps. getting to step 2 and this is what I get:
    Code:
    root@kali:~# dpkg -i '/root/Downloads/google-chrome-stable_current_amd64.deb'
    Selecting previously unselected package google-chrome-stable.
    (Reading database ... 303607 files and directories currently installed.)
    Preparing to unpack .../google-chrome-stable_current_amd64.deb ...
    Unpacking google-chrome-stable (57.0.2987.98-1) ...
    dpkg: dependency problems prevent configuration of google-chrome-stable:
     google-chrome-stable depends on libappindicator1; however:
      Package libappindicator1 is not installed.
    
    dpkg: error processing package google-chrome-stable (--install):
     dependency problems - leaving unconfigured
    Processing triggers for menu (2.1.47) ...
    Processing triggers for gnome-menus (3.13.3-8) ...
    Processing triggers for desktop-file-utils (0.23-1) ...
    Processing triggers for mime-support (3.60) ...
    Processing triggers for man-db (2.7.5-1) ...
    Errors were encountered while processing:
     google-chrome-stable
    root@kali:~#
    what should I do from here?

    thanks

    p.s. here is what I found and how I am running it right now: http://unix.stackexchange.com/questi...-in-kali-linux
    this is not the best way I'm sure but it does the job for now. I am currently searching and trying to make it work the proper way.
    Last edited by martimarti; 2017-03-16 at 08:09 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •