Results 1 to 2 of 2

Thread: Need some help while installing my Broadcom driver

  1. #1
    Join Date

    Need some help while installing my Broadcom driver

    Hey, firstly thank you to anyone taking the time out of their day to read this thread. I appreciate the help. (sorry if this is a dup thread, I couldnt find the post)

    I recently managed to Install Kali via my USB disk using "Unetbootin" and
    proceeded to follow the instructions listed on to get the Wireless Adapter Driver working.

    "install kernel-PAE-devel

    On Ubuntu, you will need headers and tools. Try these commands:
    # apt-get install build-essential linux-headers-generic
    # apt-get build-dep linux"

    (It doesn't list Debian/Kali in the readme, but it supports it)

    Since I ONLY have access to wifi at the moment, I can not hookup my ethernet and I manually had to search the respatory for
    "build-essential_11.7_amd64.deb" via Windows 7.

    I ran the package through the Kali installer but the install status flies by then closes without confirmation

    and when I run the Make file for the wireless driver I get

    "make: *** /lib/modules/"release"/build: No such file or directory. Stop."

    And the error in the readme that corresponds to this is

    "you do not have the proper packages installed, since installing the
    proper packages will create /lib/modules/"release"/build on your system."

    So my question is this, since I can't run apt-get, is there any possibly way that I can run apt-get in my virtual box and
    once the files have each installed on that; copy the installed directories to my installed version of Kali?

    Otherwise how do I manually download the dependencies bit by bit? (On my win7)

  2. #2
    Have you had any luck so far? I am in the same boat. You would think something like this would be included in the base install as compiling from source is a fairly common thing in linux. I was thinking maybe it may be somehow on the installation disk and possible to install from there. I'm at work now so I won't be able to give it a shot for a bit yet.

    So I attempted adding the install disk using:
    apt-cdrom add
    Then retried installing build-essential to no avail. While I had a chance on my phone I located the install package for build-essential and manually installed it using the package installer program. It claimed to have failed the install, but after retrying apt-get it claimed it had in fact installed. I believe package installer was trying to resolve the dependencies and could not due to lack of an Internet connection. When I sought out to get the dependencies in the same manner I quickly realized that is an extensive list.
    Last edited by Deadlysporks; 2015-09-15 at 19:57. Reason: Update

Similar Threads

  1. Replies: 3
    Last Post: 2020-07-24, 14:14
  2. Installing missing Broadcom wl driver in Live Usb Persistance
    By virtum in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-05-23, 11:03
  3. Can't install STA driver for Broadcom
    By lkomarci in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-02-28, 22:23
  4. problem when installing WIFI driver for broadcom BCM43142
    By jerry.goyal in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-04-07, 10:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts