Results 1 to 2 of 2

Thread: upgraded to kali 2.0 and stuck with unresolved dependencies

  1. #1
    Join Date
    2014-Nov
    Posts
    18

    upgraded to kali 2.0 and stuck with unresolved dependencies

    I ran the following commands:

    apt-get update
    apt-get dist-upgrade

    My sources.list containts:
    #deb http://kali.mirror.garr.it/mirrors/kali sana main non-free contrib
    deb http://ftp.halifax.rwth-aachen.de/kali sana main non-free contrib

    #deb http://kali.mirror.garr.it/mirrors/kali-security/ sana/updates main contrib non-free
    deb http://ftp.halifax.rwth-aachen.de/kali-security/ sana/updates main contrib non-free

    I didn't change the sources.list to include any non-standard sources, ever.

    After dist-upgrade I am left with the following problem:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
    console-setup-linux : Depends: keyboard-configuration (= 1.123) but 1.88 is installed
    kde-runtime : Depends: plasma-scriptengine-javascript (= 4:4.14.2-2) but 4:4.8.4-2 is installed
    Depends: libgpgme++2 (>= 4:4.11) but it is not installed
    Depends: libkxmlrpcclient4 (>= 4:4.11) but it is not installed
    Depends: libssh-gcrypt-4 (>= 0.6.1) but it is not installed
    kde-window-manager : Depends: kde-style-oxygen (= 4:4.11.13-2) but 4:4.8.4-6 is installed
    Depends: libgles2-mesa (>= 7.8.1) but it is not installed or
    libgles2
    Depends: libkdecorations4abi2 (= 4:4.11.13-2) but it is not installed
    Depends: libkwineffects1abi5 (= 4:4.11.13-2) but it is not installed
    Depends: libkwinglesutils1 (= 4:4.11.13-2) but it is not installed
    Depends: libkwinglutils1abi2 (= 4:4.11.13-2) but it is not installed
    Depends: libxcb-damage0 but it is not installed
    Depends: libxcb-xtest0 but it is not installed
    kde-workspace-bin : Depends: plasma-desktop (= 4:4.11.13-2) but 4:4.8.4-6 is installed or
    plasma-netbook (= 4:4.11.13-2) but it is not installed
    Depends: kde-style-oxygen (= 4:4.11.13-2) but 4:4.8.4-6 is installed
    Depends: libkscreensaver5 (= 4:4.11.13-2) but 4:4.8.4-6 is installed
    Depends: libnepomukcore4 (>= 4:4.10.0) but it is not installed
    Depends: libplasmagenericshell4 (= 4:4.11.13-2) but 4:4.8.4-6 is installed
    Depends: libprocesscore4abi1 (= 4:4.11.13-2) but 4:4.8.4-6 is installed
    Depends: libprocessui4a (= 4:4.11.13-2) but 4:4.8.4-6 is installed
    kdepim-runtime : Depends: libakonadi-calendar4 (>= 4:4.11.1) but it is not installed
    Depends: libakonadi-contact4 (>= 4:4.14.2-2~) but it is not installed
    Depends: libakonadi-kabc4 (>= 4:4.14.2-2~) but 4:4.8.4-2 is installed
    Depends: libkalarmcal2 (>= 4:4.8.1) but it is not installed
    Depends: libkgapi2-2 (>= 2.0.1) but it is not installed
    Depends: libkmbox4 (>= 4:4.5.86) but it is not installed
    libicu-dev : Depends: icu-devtools (>= 52.1-8+deb8u2) but it is not installed
    libkactivities-bin : Depends: libkactivities-models1 (>= 4:4.10.0) but it is not installed
    Depends: libnepomukcore4 (>= 4:4.10.0) but it is not installed
    lsof : Depends: libperl4-corelibs-perl but it is not installed or
    perl (< 5.12.3-7) but 5.20.2-3+deb8u1 is installed
    vlc : Depends: libfreerdp-cache1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libfreerdp-client1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libfreerdp-codec1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libfreerdp-core1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libfreerdp-crypto1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libfreerdp-gdi1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libfreerdp-locale1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libfreerdp-rail1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libfreerdp-utils1.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libgles1-mesa (>= 7.8.1) but it is not installed or
    libgles1
    Depends: libgles2-mesa (>= 7.8.1) but it is not installed or
    libgles2
    Depends: libva-drm1 (>= 1.1.0) but it is not installed
    Depends: libvlccore8 (>= 2.2.0~pre1) but it is not installed
    Depends: libvncclient0 (>= 0.9.9) but it is not installed
    Depends: libwinpr-rpc0.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libwinpr-sspi0.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Depends: libwinpr-utils0.1 (>= 1.1.0~beta1+git20130629) but it is not installed
    Recommends: vlc-plugin-samba (= 2.2.0~rc2-2+deb8u1) but it is not installed
    vlc-nox : Depends: libvlc5 (>= 2.1.0) but 2.0.3-5+deb7u2+b1 is installed
    Depends: libvlccore8 (>= 2.2.0~pre1) but it is not installed
    vlc-plugin-notify : Depends: libvlccore8 (>= 2.0.0) but it is not installed
    vlc-plugin-pulse : Depends: vlc-data (= 2.2.0~rc2-2+deb8u1) but 2.0.3-5+deb7u2 is installed
    xpdf : Depends: libxm4 (>= 2.3.4) but it is not installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies

    KDE stopped working. Many applications, including network configuration are broken. I connected to my wifi from command line and I am posting here.

  2. #2
    The upgrade will actually not so good than ever before. I would upgrade if it is safe
    Download Free Games -> Taigamemienphihay.net

Similar Threads

  1. Upgraded to Kali Rolling and having dpkg warnings/errors
    By bruce13 in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-12-24, 05:07
  2. Upgraded Lenovo T440 to Kali Rolling and can't login
    By fonestar in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2016-05-24, 15:17
  3. Something is missing after upgraded to kali linux sana 2
    By prakash in forum Installing Archive
    Replies: 0
    Last Post: 2015-08-14, 09:44
  4. Will Kali be upgraded to Debian 7? I need UEFI support for Surface Pro
    By schutzhund3 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2013-07-20, 15:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •