Results 1 to 8 of 8

Thread: Recent Kali 2 Update Killed OpenVas

  1. #1
    Join Date
    2015-Aug
    Posts
    17

    Recent Kali 2 Update Killed OpenVas

    I just updated Kali 2 today with a couple of PHP modules and now OpenVas no longer scans. The GreenBone Admin portal works fine and I can add/edit new targets, add/edit new scans, but it doesn't actually begin the scan.

    I am reletively confident the recent update is what caused the issue given that I was able to run a scan yesterday morning just fine and the only thing that's changed is the update.

    Anyone have any experiencing in troubleshooting the OpenVas tooling? The logs are pretty empty and don't really provide any assistance and nothing is showing in syslog regarding the scanner's functions.

    Thanks!!

  2. #2
    Join Date
    2013-Apr
    Posts
    182
    Quote Originally Posted by mire3212 View Post
    I just updated Kali 2 today with a couple of PHP modules and now OpenVas no longer scans. The GreenBone Admin portal works fine and I can add/edit new targets, add/edit new scans, but it doesn't actually begin the scan.

    I am reletively confident the recent update is what caused the issue given that I was able to run a scan yesterday morning just fine and the only thing that's changed is the update.

    Anyone have any experiencing in troubleshooting the OpenVas tooling? The logs are pretty empty and don't really provide any assistance and nothing is showing in syslog regarding the scanner's functions.

    Thanks!!
    hey , I have same problem with yours . The openvas-scanner is not running , it show that the redis server is not running ,

    still i am waiting for some one can resolve this problem .

    you can use sytemctl to check details too .

    it show openvas-manager and redis server load failed

  3. #3
    Join Date
    2015-Sep
    Posts
    1
    Quote Originally Posted by when123 View Post
    hey , I have same problem with yours . The openvas-scanner is not running , it show that the redis server is not running ,

    still i am waiting for some one can resolve this problem .

    you can use sytemctl to check details too .

    it show openvas-manager and redis server load failed

    Consider running

    Code:
    openvas-check-setup
    This will validate your setup and provide instruction for what needs to be done to work.

  4. #4
    Join Date
    2013-Apr
    Posts
    182
    Quote Originally Posted by h3ll0 View Post
    Consider running

    Code:
    openvas-check-setup
    This will validate your setup and provide instruction for what needs to be done to work.
    root@debain:~# openvas-check-setup
    openvas-check-setup 2.3.0
    Test completeness and readiness of OpenVAS-8
    (add '--v6' or '--v7' or '--9'
    if you want to check for another OpenVAS version)

    Please report us any non-detected problems and
    help us to improve this check routine:
    http://lists.wald.intevation.org/mai...penvas-discuss

    Send us the log-file (/tmp/openvas-check-setup.log) to help analyze the problem.

    Use the parameter --server to skip checks for client tools
    like GSD and OpenVAS-CLI.

    Step 1: Checking OpenVAS Scanner ...
    OK: OpenVAS Scanner is present in version 5.0.1.
    OK: OpenVAS Scanner CA Certificate is present as /var/lib/openvas/CA/cacert.pem.
    OK: OpenVAS Scanner server certificate is valid and present as /var/lib/openvas/CA/servercert.pem.
    OK: NVT collection in /var/lib/openvas/plugins contains 40639 NVTs.
    OK: Signature checking of NVTs is enabled in OpenVAS Scanner.
    OK: The NVT cache in /var/cache/openvas contains 40639 files for 40639 NVTs.
    OK: redis-server is present in version v=2.8.17.
    OK: scanner (kb_location setting) is configured properly using the redis-server socket: /var/lib/redis/redis.sock
    ERROR: redis-server is not running or not listening on socket: /var/lib/redis/redis.sock
    FIX: You should start the redis-server or configure it to listen on socket: /var/lib/redis/redis.sock

    ERROR: Your OpenVAS-8 installation is not yet complete!

    Please follow the instructions marked with FIX above and run this
    script again.

    If you think this result is wrong, please report your observation
    and help us to improve this check routine:
    http://lists.wald.intevation.org/mai...penvas-discuss
    Please attach the log-file (/tmp/openvas-check-setup.log) to help us analyze the problem.

  5. #5
    Join Date
    2013-Apr
    Posts
    182
    Quote Originally Posted by h3ll0 View Post
    Consider running

    Code:
    openvas-check-setup
    This will validate your setup and provide instruction for what needs to be done to work.

    root@debain:~# service redis-server start
    Job for redis-server.service failed. See 'systemctl status redis-server.service' and 'journalctl -xn' for details.
    root@debain:~# journalctl -xn
    -- Logs begin at Wed 2015-09-23 09:16:17 CST, end at Wed 2015-09-23 12:50:00 CST. --
    Sep 23 12:50:00 debain systemd[1]: redis-server.service: control process exited, code=exited status=1
    Sep 23 12:50:00 debain systemd[1]: Failed to start Advanced key-value store.
    -- Subject: Unit redis-server.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman.../systemd-devel
    --
    -- Unit redis-server.service has failed.
    --
    -- The result is failed.
    Sep 23 12:50:00 debain systemd[1]: Dependency failed for Open Vulnerability Assessment System Scanner Daemon.
    -- Subject: Unit openvas-scanner.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman.../systemd-devel
    --
    -- Unit openvas-scanner.service has failed.
    --
    -- The result is dependency.
    Sep 23 12:50:00 debain systemd[1]: Unit redis-server.service entered failed state.
    Sep 23 12:50:00 debain systemd[1]: redis-server.service start request repeated too quickly, refusing to start.
    Sep 23 12:50:00 debain systemd[1]: Failed to start Advanced key-value store.
    -- Subject: Unit redis-server.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman.../systemd-devel
    --
    -- Unit redis-server.service has failed.
    --
    -- The result is failed.
    Sep 23 12:50:00 debain systemd[1]: Dependency failed for Open Vulnerability Assessment System Scanner Daemon.
    -- Subject: Unit openvas-scanner.service has failed
    -- Defined-By: systemd
    -- Support: http://lists.freedesktop.org/mailman.../systemd-devel
    --
    -- Unit openvas-scanner.service has failed.
    --
    -- The result is dependency.
    Sep 23 12:50:00 debain systemd[1]: Unit redis-server.service entered failed state.

  6. #6
    Join Date
    2013-Apr
    Posts
    182
    finnally , i fixed the problem . the /var/log/redis/redis-log write permission is disable .
    so just chmod 777 this file .it works now .thanks

  7. #7
    Join Date
    2015-Oct
    Posts
    1
    Quote Originally Posted by when123 View Post
    finnally , i fixed the problem . the /var/log/redis/redis-log write permission is disable .
    so just chmod 777 this file .it works now .thanks
    when123 can your teach me how to fix it..can u give the code ..help me bro

  8. #8
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    805
    Thanks for the tip, when123

Similar Threads

  1. OnlyKey isn't working after a recent update
    By 5aru in forum General Archive
    Replies: 2
    Last Post: 2017-12-20, 02:52
  2. Replies: 4
    Last Post: 2013-10-20, 18:50
  3. Latest update - killed zenmap
    By AfterBurn in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-06-03, 16:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •