Results 1 to 31 of 31

Thread: [Customising] Kali 2.x + XFCE 4 Window Manager + axiomd Theme

  1. #1

    Lightbulb [Customising] Kali 2.x + XFCE 4 Window Manager + axiomd Theme

    This has been tried & tested on Kali 2.0 (x86 & x64 - Full & Light).
    ...Other variations of Kali may not work out of the box.

    For Kali 1 users, see this script.

    Quick / TL;DR
    Open a terminal window and paste in the following command (this will pull the rest of commands, and automatically run them):
    Code:
    curl -s http://pastebin.com/raw.php?i=58wsGhBD | tr -d '\15\32' | bash

    Comparison (GNOME vs XFCE)
    On the left is GNOME 3.10, the right XFCE 4.10.

    Other XFCE4 Screenshots



    What is XFCE4?
    It's a Window Manager/Desktop Environment.
    By default, Kali 2.0 and Kali mini (x86 & x64 builds) use GNOME 3.10. This will install XFCE4, allowing you to switch between them each time you login to Kali.
    Please note, Kali Light and Kali ARM already use XFCE4 - just without the 'axiomd theme' or any configurations.
    If you don't like XFCE, you can switch back to GNOME next time you login.



    How do I start XFCE?
    On the login screen, when you type in your password there is a settings button (as seen in the screenshot below) allowing you to select which desktop environment to use for that session.

    If you wish to change the default, run the following command:
    Code:
    echo xfce4-session > /root/.xsession


    Why switch to XFCE4? What's wrong with GNOME?
    There's lots of reasons for and against them both. I'm not going to get into it here.
    This is here purely if you wish to use my personal take/build/customisations of Kali using XFCE4.



    What other tweaks can I do with my Kali install afterwards?




    Like this sort of stuff? Want more?


    Any off topic replies will be deleted.
    Last edited by g0tmi1k; 2015-08-31 at 14:46.
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  2. #2
    Man thnx a lot works fine!! XFCE for me is the best =) and system works better with xfce then gnome =)

  3. #3
    Join Date
    2015-Sep
    Posts
    4
    Hello,

    you write the command "echo xfce4-session > /root/.xsession" set XFCE as Default. Who can i choose Gnome Classic as System-Default?

  4. #4
    Quote Originally Posted by Stefan.W View Post
    Hello,

    you write the command "echo xfce4-session > /root/.xsession" set XFCE as Default. Who can i choose Gnome Classic as System-Default?
    Just need to remove it =).
    Code:
    rm /root/.xsession
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  5. #5
    Join Date
    2015-Sep
    Posts
    4
    rm /root/.xsession
    rm: das Entfernen von „/root/.xsession“ ist nicht möglich: Datei oder Verzeichnis nicht gefunden
    I have not installed XFCE. I only want that Gnome-Classic is the System-Default.

  6. #6
    Join Date
    2014-May
    Posts
    3
    By default Kali 2.0 include XFCE 4.8
    But already we have 4.12 release of XFCE. Can i update to 4.12 without functional problems?
    4.12 not presented in Kali official repository.

  7. #7
    Quote Originally Posted by Stefan.W View Post
    I have not installed XFCE. I only want that Gnome-Classic is the System-Default.
    Little offtopic, so then these pages cover it: https://askubuntu.com/questions/6283...ng-auto-logins
    https://help.gnome.org/admin/system-...n-user.html.en



    Quote Originally Posted by ice99 View Post
    By default Kali 2.0 include XFCE 4.8
    But already we have 4.12 release of XFCE. Can i update to 4.12 without functional problems?
    4.12 not presented in Kali official repository.
    I haven't done it - so I cannot comment.
    I dont see a need to upgrade to anything higher than whats in the repo (personally I dont need the features/support it offers).
    If you want to try - go for it. Best of luck.
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  8. #8
    Join Date
    2014-May
    Posts
    3
    Quote Originally Posted by g0tmi1k View Post
    I dont see a need to upgrade to anything higher than whats in the repo (personally I dont need the features/support it offers).
    Unfortunately 4.8 don't have (in Desktop properties tab) option "Use single click on desktop icons". In Thunar everything is ok, but not on desktop icons and files.

    Oh, by the way- on top screenshot you have XFCE 4.10 version on Kali 2. HOW, you install it? i only can install 4.8 from repository.
    Last edited by ice99; 2015-10-13 at 17:43.

  9. #9
    Quote Originally Posted by ice99 View Post
    Unfortunately 4.8 don't have (in Desktop properties tab) option "Use single click on desktop icons". In Thunar everything is ok, but not on desktop icons and files.

    Oh, by the way- on top screenshot you have XFCE 4.10 version on Kali 2. HOW, you install it? i only can install 4.8 from repository.
    Everything is from the kali repo.
    Using the standard repos (not rolling/bleeding edge etc).

    See the pastebin link for the exact commands used. There isn't anything more done.
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  10. #10
    Join Date
    2013-Jul
    Posts
    41
    Quote Originally Posted by g0tmi1k View Post
    Like this sort of stuff? Want more?


    Any off topic replies will be deleted.
    As I mentioned in the other post, Thanks for sharing your script.

    I do have another question, that I could not find myself.

    I've searched through your script, I'm not sure what part of the script is needed to configure the console . I would like to apply the customization you have done to the console, on a new user account w/o re-running the script again.

    Once again, thanks for sharing.

  11. #11
    Join Date
    2013-Jul
    Posts
    41
    I have a fresh install of Kali, I've downloaded the recent os-scripts from your github.

    For some reason I get the following error when I begin the script .

    [+] Disabling notification package updater service ~ in case it runs during this script
    [!] Failed to kill /usr/lib/apt/methods/http
    [!] There another service (other than this script) using Advanced Packaging Tool currently
    apt is not running anywhere else. I've tried a few dfferent things, no luck.

  12. #12
    Quote Originally Posted by hightech316 View Post
    I've searched through your script, I'm not sure what part of the script is needed to configure the console . I would like to apply the customization you have done to the console, on a new user account w/o re-running the script again.
    The script was not designed for this (nor Kali). It would be a lot of work to make it happen - "root" has been used & hardcoded (and without permission checks).




    Quote Originally Posted by hightech316 View Post
    For some reason I get the following error when I begin the script .
    apt is not running anywhere else. I've tried a few dfferent things, no luck.
    If you are 100% sure, nothing else is using 'apt-get' - remove the following files before re-running the script:

    /var/lib/dpkg/lock
    /var/lib/apt/lists/lock
    Last edited by g0tmi1k; 2015-11-03 at 12:55.
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  13. #13
    Join Date
    2013-Jul
    Posts
    41
    Quote Originally Posted by g0tmi1k View Post
    The script was not designed for this (nor Kali). It would be a lot of work to make it happen - "root" has been used & hardcoded (and without permission checks).





    If you are 100% sure, nothing else is using 'apt-get' - remove the following files before re-running the script:

    /var/lib/dpkg/lock
    /var/lib/apt/lists/lock
    For some reason the latest script did not agree with my Kali Installation

    I used the last revision of the script , I was able to get a little further until
    [i] Detected multiple kernels installed
    Seems I do have more then one,
    root@kb0x:~/Desktop# dpkg --list | grep linux-image
    ii linux-image-4.0.0-kali1-amd64 4.0.4-1+kali2 amd64 Linux 4.0 for 64-bit PCs
    ii linux-image-4.1.0-kali1-amd64 4.1.6-1kali2 amd64 Linux 4.1 for 64-bit PCs
    ii linux-image-amd64 4.1+67+kali1 amd64 Linux for 64-bit PCs (meta-package)
    I'm using the latest kernel at the moment. What do you suggest I do?

    EDIT:

    I've tried renaming the old kernel, no luck.

    I removed the old one that was not in use and now the script is running.
    Last edited by hightech316; 2015-11-04 at 14:07.

  14. #14
    Quote Originally Posted by hightech316 View Post
    I used the last revision of the script , I was able to get a little further until


    Seems I do have more then one,


    I'm using the latest kernel at the moment. What do you suggest I do?

    I've tried renaming the old kernel, no luck.
    Don't rename. Remove.

    Reboot & make sure you are using the latest version before removing the older kernels. There's various guides online how todo this.
    Last edited by g0tmi1k; 2015-11-04 at 14:09.
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  15. #15
    Join Date
    2013-Jul
    Posts
    41
    Quote Originally Posted by g0tmi1k View Post
    Don't rename. Remove.

    Reboot & make sure you are using the latest version before removing the older kernels. There's various guides online how todo this.
    Thanks,

    I verified that I was booting with the most recent kernel by checking grub.conf. Then removed others with apt .

    Script finished.

  16. #16
    Any more posts asking how to use whats on Github will be removed.

    If I came from Github, ask on Github.
    This thread is for getting XFCE on Kali, using whats on pastebin.
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Search: https://www.kali.org/search/
    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: http://tools.kali.org/

  17. #17
    Join Date
    2015-Aug
    Posts
    26
    My apologies

    of course you're right, this thread gives only a subtile hint to the postinstall script on github. I followed your advice and had opened an issue as you have surely noticed. Hope to hear from you guys.

    Thx

  18. #18
    Join Date
    2013-Nov
    Posts
    38
    For some reason the TL;DR code did not work.

    I used this:
    Code:
    curl -s http://pastebin.com/raw/58wsGhBD | tr -d '\15\32' | bash

  19. #19
    Join Date
    2016-Jan
    Posts
    17
    Quote Originally Posted by r0tati0n View Post
    For some reason the TL;DR code did not work.

    I used this:
    Code:
    curl -s http://pastebin.com/raw/58wsGhBD | tr -d '\15\32' | bash
    Use this in termainal:

    Code:
    curl -s http://pastebin.com/raw/58wsGhBD | tr -d '\15\32' | bash
    Say thank you !!

    I tested this and works, but cant control brightness with FN+F5 or F6 keys. Also sound in missing... These options works great in default Gnome in Kali 2.0. How to get working this things in XFCE4?

    EDIT: I fixed brightness issues with installing this packages via "Packages" utility:

    Last edited by deanMKD1; 2016-01-06 at 01:54. Reason: solving issues

  20. #20
    Join Date
    2016-Jan
    Posts
    12
    Hello, since running kali.sh script I'm not being able to access shares through gnome or XFCE, I've tried Thunar and Nautilus and the result is the same, can you help me sort this out please?

    Best Regards.

    Gn0m3

  21. #21
    Join Date
    2016-Jan
    Posts
    2
    Followed the script on new 2016 release of Kali. Works ok just one problem. There is icons missing for the folders and subfolders of application menu. Any fix?

  22. #22
    Join Date
    2016-Jan
    Posts
    17
    Can you post screenshot where is that icons that is missing? In my Kali is all OK.

  23. #23
    Join Date
    2016-Feb
    Posts
    3

  24. #24
    Join Date
    2016-Jan
    Posts
    2
    Quote Originally Posted by deanMKD1 View Post
    Can you post screenshot where is that icons that is missing? In my Kali is all OK.
    take a look at this attachment

    Kali2.0-icon-missing.jpg

  25. #25
    Join Date
    2015-Dec
    Posts
    2
    Quote Originally Posted by Andys View Post
    take a look at this attachment

    Kali2.0-icon-missing.jpg

    I'm in the same boat. Looks like you can change it via a menu file but I can't seem to find the correct file to modify.

    Update

    I did an upgrade and a dist-upgrade, and now the category menu icons are back. Note, I have not upgraded to the rolling release yet.
    Last edited by brew balls; 2016-03-11 at 21:19.

  26. #26
    Join Date
    2016-Jun
    Posts
    12
    hi there,

    do you have this "axiomd" theme around? the DL is broken and I only found the light theme "Axiom", but not the dark one (was not included in the tar gz)
    Ironically, I DL and installed this theme (the dark one!) just 1-2 weeks ago (!) But now, I can not find it on the Internet...

    I mean, there are still some "90145-axiom-xfwm.tar.gz" out there - but only the light theme is included, tried 6 differents DL thus far...

    Oh and the script does not run 100% on ARM chromebooks... but at least, I got the "Kali Start button" for the applications-menu



    Cheers!
    Last edited by Onkelpoe; 2016-07-07 at 11:10.

  27. #27
    Join Date
    2016-Jun
    Posts
    12
    the DL is working again and now contains the axiomd (dark) theme again

    yiehhhaahh

  28. #28
    Join Date
    2016-Oct
    Posts
    2
    The link to the Axiomd theme doesn't work, in order to fix it, make a file and copy g0tmi1k's code into it,
    in the end of the code, there's a link with 'curl', change the url in the quotes to the following url :
    https://dl.opendesktop.org/api/files...5-axiom.tar.gz

    Have fun :-)

  29. #29
    Join Date
    2016-Oct
    Posts
    2
    Quote Originally Posted by kalasel View Post
    The link to the Axiomd theme doesn't work, in order to fix it, make a file and copy g0tmi1k's code into it,
    in the end of the code, there's a link with 'curl', change the url in the quotes to the following url :
    https://dl.opendesktop.org/api/files...5-axiom.tar.gz

    Have fun :-)
    after making a file with g0tmi1k's code, do the following:

    cat filename | tr -d '\15\32' | bash

    it should work now, have a great day =)

  30. #30
    Join Date
    2015-Oct
    Posts
    25
    hello can you help me to install that themes :

    https://www.gnome-look.org/content/s...content=136291

    https://www.gnome-look.org/p/1012873/


    i am using kali 2016 x86 how can i install them?i copied folders to usr/share/themes but Legacy theme was not in drop down list to aply it,and tron theme could not install properly ... so can you help?

  31. #31
    Join Date
    2017-Oct
    Posts
    1
    curl -s https://pastebin.com/raw/t6BcrDVj | tr -d '\15\32' | bash
    I have replaced the line with Axiom and applied the theme.
    Thank you for your help.

Similar Threads

  1. Troubleshooting Network Manager AP on XFCE using Kali Sana.
    By pwntoken in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-03-11, 20:42
  2. Replies: 16
    Last Post: 2015-09-08, 07:47
  3. Replies: 45
    Last Post: 2015-08-31, 08:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •