Results 1 to 1 of 1

Thread: Solution for Reboot Issues

  1. #1
    Join Date
    2013-Mar
    Posts
    19

    Solution for Reboot Issues

    Hi folks,

    I've been seeing lots of people looking for a solution to reboot freezes and why you get a blank screen after installing Nvidia packages. Hope this helps if you're also facing those issues.

    HW Specs: Intel i7-4710MQ, 32GB RAM, Samsung EVO-850 SSD disk, NVidia GTX870M 6GB

    The freezing and reboot issues are related to the nouveau modules, extremely incompatible with Optimus enabled cards such as GTX 870M. There's a simple process to have your Nvidia card running as it should when it comes to cudaHashcat and its correct overall functioning, without having to go through that 15 step guide. I don't really care if my Gnome session is using the GPU to render stuff, keep in mind that Kali is pentest-oriented, and if you require running software that uses GPU a lot, I recommend you to install the latest Debian distro and add the shell extensions, repositories and kernel from the Kali repos, and building your own personalized OS.

    IMPORTANT: Keep in mind that I ran the steps below right after installing Kali 2 to the hard drive.

    Steps:

    1- Check your apt sources as per http://docs.kali.org/general-use/kal...t-repositories;
    2- Run "apt-get update && apt-get dist-upgrade";
    3- Create the following file: "/etc/modprobe.d/nouveau-blacklist.conf";
    4- Edit that file and add only one line that says "blacklist nouveau";
    5- Reboot your PC;
    6- Run "apt-get install libcuda1 libnvidia-ml1 --no-install-recommends -y";
    7- DO NOT reboot your PC at this point. You must edit one file before doing so or your GDM greeter won't work;
    8- Edit the file "/etc/modprobe.d/nvidia.conf" and comment out the second line that says "remove nvidia-current rmmod nvidia nvidia-uvm", or delete that line. Make sure that file has only one line that says "alias nvidia nvidia-current";
    9- Run "apt-get install nvidia-kernel-amd64 nvidia-kernel-common nvidia-kernel-dkms";
    10- Reboot your PC.

    At this point, you should have both GDM and cudaHashcat working without issues.
    You can run "glxinfo | grep direct" to check that you're running the correct GLX modules and also "cudaHashcat64.bin -b" will benchmark it for you.

    Hope this helps! Cheers!


    EDIT: The nvidia-kernel won't work with GDM if you uncomment GRUB_GFXMODE in "/etc/default/grub". Also, Kali seems to have issues loading NVidia drivers and kernels if you set the BadRAM options also, so it's best to leave those settings commented out if you're working with Nvidia.
    Last edited by amorandi; 2015-09-10 at 13:58. Reason: Grammar and formatting fixes; Added driver kernel install step; Grub observation added

Similar Threads

  1. Replies: 0
    Last Post: 2016-05-11, 00:49
  2. Replies: 0
    Last Post: 2014-10-30, 15:34
  3. fglrx solution?
    By Stainedhat in forum General Archive
    Replies: 0
    Last Post: 2014-01-31, 03:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •