Results 1 to 3 of 3

Thread: Issues with VPN on Raspberry

  1. #1
    Join Date

    Issues with VPN on Raspberry

    Ive been google'ing around to get this to work, now im so frustrated and desperate that i cant get it to work. Ive done this so far:

    apt-get install network-manager-openvpn-gnome
    apt-get install network-manager-pptp
    apt-get install network-manager-pptp-gnome
    apt-get install network-manager-vpnc
    apt-get install network-manager-vpnc-gnome

    I wanted to install:
    apt-get install network-manager-strongswan

    When i do this, i get this:
    Package network-manager-strongswan is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsolered, or is only available from another source

    E: Package 'network-manager-strongswan' has no installation candidate

    I dont know if strongswan is significant, so i tried to set up a VPN-connection..
    When doing so, when i click the VPN connection that i want to connect to, nothing happends at all..

    Ive tried to get my sources.list to point at a package that i know contained strongswan.
    Ive reinstalled Kali like 10 times to i was absolute certain that i havnt done any mistakes.
    Ive tried to install strongswan manually, but got stuck at installing some other packages - dbus-glib1 - again i see that its at the destination my sources.list is pointing at, but it wont install it..

    So - now in all of my frustrations, im writing here to try get sum hlp to get this to work.. Plz anyone?

  2. #2
    Join Date

    It was kicked out of Jessie because it FTBFS (failed to build from source) - so we don't have it in Kali 2.0.

    Keep in mind that just because a package exists in a repository somewhere doesn't mean that it is supported by the architecture you're running on, most external repositories aren't built for armel/armhf, so it's likely that if you've added some external repository, it exists for amd64 or x86 but not arm.

    Your best bet would be to open a bug in our bug tracker and ask us to import the version from testing since they seem to have fixed it there.

  3. #3
    Join Date
    Thanks a lot, that saved me an headache, at least its not just me that fail at some point..

Similar Threads

  1. Raspberry Pi 2 Model B Issues
    By rickyoswald in forum Installing Archive
    Replies: 1
    Last Post: 2016-04-11, 20:45
  2. Issues with Kali 2.1 and Raspberry PI2
    By the2ndson in forum ARM Archive
    Replies: 0
    Last Post: 2016-03-08, 18:57
  3. Raspberry PI - Issues with Metasploit
    By ouam3r in forum ARM Archive
    Replies: 2
    Last Post: 2014-01-14, 20:56

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts