Results 1 to 3 of 3

Thread: Getting Alfa AWUS036NEH (RA3070) working in monitor mode

  1. #1
    Join Date
    2013-Aug
    Posts
    25

    Getting Alfa AWUS036NEH (RA3070) working in monitor mode

    I'm trying to do something very basic for the moment:
    - put card in monitor mode
    - run airodump-ng


    ifconfig shows the Alfa USB adapter as wlan0

    I run:

    airmon-ng start wlan0

    Then I kill off the problem processes with:
    airmon-ng check kill



    I get this error below however when trying to run airodump-ng so below is how I resolve that

    --
    ioctl(SIOCSIWMODE) failed: Device or resource busy
    ARP linktype is set to 1 (Ethernet) – expected ARPHRD_IEEE80211,
    ARPHRD_IEEE80211_FULL or ARPHRD_IEEE80211_PRISM instead. Make
    sure RFMON is enabled: run ‘airmon-ng start wlan0 <#>’
    Sysfs injection support was not found either.
    --



    To resolve the above error, I do:

    ifconfig wlan0mon down
    iwconfig wlan0mon mode monitor
    ifconfig wlan0mon up



    Then I check iwconfig and verify that the wlan0mon is in "monitor" mode, and it is.


    However, when I run:

    airodump-ng wlan0mon


    It doesn't see anything on any channel, which is not possible as there are two wireless routers not far from me.


    So something is wrong but I'm not sure what?


    Thanks

  2. #2
    Join Date
    2015-Sep
    Posts
    2
    I have found that first running:

    airmon-ng check kill

    and then running

    airmon-ng start wlan0


    makes aircrack-ng and its utils run smoother.

    This also creates the mon0 interface as opposed to wlan0mon. In the past I was able to create mon0 using:

    iw dev wlan0 interface add mon0 type monitor

    but that doesn't work with the new Kali 2 setup. Running airmon-ng in the order mentioned above puts my wlan0 into monitor mode as mon0 and I don't need to resort to using iw at all.

    I hope this helps.
    Last edited by jasper; 2015-09-09 at 18:24.

  3. #3
    Join Date
    2015-Aug
    Posts
    11
    @natv
    first do this -

    Code:
    service network-manager restart
    service avahi-daemon start
    Code:
    ifconfig wlan0 down
    macchanger -m 00:02:03:04:05:06 wlan0
    ifconfig wlan0 up
    Code:
    iw wlan1 interface add wlan0mon type monitor
    Code:
    ifconfig wlan0mon down
    macchanger -m 00:04:05:06:07:08 wlan1mon
    ifconfig wlan0mon up
    Code:
    ifconfig -a
    Code:
    airodump-ng wlan0mon --ignore-negative-one

    request to refer -
    https://forums.kali.org/printthread....1&pp=10&page=1

    thanking you.

Similar Threads

  1. Alfa AWUS036ACH on kali 2017.1 monitor mode issue
    By superbosu in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2017-08-30, 03:19
  2. Can't get alfa awus036h in monitor mode
    By rafltdcpa in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-11-05, 23:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •