Results 1 to 4 of 4

Thread: Changing Greenbone Security Assistant (GSA) default listening address not working

  1. #1
    Join Date

    Changing Greenbone Security Assistant (GSA) default listening address not working

    The config options for greenbone security assistant are kept in /etc/default/greenbone-security-assistant. Be default, the listening address for greenbone-security-assistant is which means you can't connect to GSA from a remote web browser. The way to fix this is to change the GSA_ADDRESS parameter in /etc/default/greenbone-security-assistant to although even after changing it, and restarting the greenbone-security-assistant service, the service still listens only on I have even tried overriding /etc/init.d/greenbone-security-assistant and the gsad executable still only listens on The only way I have found to correctly override the default listening address is to manually start gsad like this:"nohup /usr/sbin/gsad --foreground --listen= --port=9392 --mlisten= --mport=9390 &". What I can't figure out is why isn't /etc/defaults/greenbone-security-assistant being read correctly and why doesn't changing the default options in /etc/init.d/greenbone-security-assistant work for overriding the default address either. Clearly I am missing something.

  2. #2
    Join Date
    I've just hit this, fairly sure it is trying to use systemd to restart greenbone-security-assistant, when I was expecting it to run /etc/init.d/greenbone-security-assistant

    Now I'll have to reread the systemd documentation, somehow it never sticks, system VR3 start-up was so much more reliable.
    Last edited by sickn3ss; 2016-02-08 at 19:31.

  3. #3
    Join Date

    vi /lib/systemd/system/greenbone-security-assistant.service

    Found the offending IP address.

  4. #4
    Quote Originally Posted by SimonW View Post

    vi /lib/systemd/system/greenbone-security-assistant.service

    Found the offending IP address.
    That's the one. Thanks SimonW

    root@tiger:/# ps aux | grep 9392 | grep -v grep
    root 9748 0.0 4.6 457480 46212 ? SLsl 19:02 0:00 /usr/sbin/gsad --foreground --listen= --port=9392 --mlisten= --mport=9390
    root 9750 0.0 0.3 170748 3404 ? Sl 19:02 0:00 /usr/sbin/gsad --foreground --listen= --port=9392 --mlisten= --mport=9390

Similar Threads

  1. Replies: 4
    Last Post: 2021-12-07, 14:35
  2. Replies: 0
    Last Post: 2020-12-29, 12:40
  3. Mdk3 not working (mac address not changing)
    By bobd432 in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2016-02-13, 03:43
  4. Replies: 1
    Last Post: 2015-03-05, 07:31
  5. openvas Greenbone Security Assistant broken
    By when123 in forum General Archive
    Replies: 0
    Last Post: 2015-01-01, 07:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts