Results 1 to 4 of 4

Thread: dpkg returning error code 1 after upgrade from Kali 1.0 to Kali 2.0

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2013-May
    Posts
    9

    Unhappy dpkg returning error code 1 after upgrade from Kali 1.0 to Kali 2.0

    Hello guys, I have decided to upgrade my Kali to 2.0 this weekend.

    I did not have my source.list modified, so I have choosen easy way, "apt-get distr-update" after setting new Kali 2.0 source list.

    But, I took kinda log time, so I have been doing other things while NB was working, and somehow happend that my battery get down a NB torned off in middle of process. I have fixed that by running "dpkg --configure -f" and than again "apt-get distr-upgrade", but there are still some broken packages it seems, which did not fixed automaticaly.

    Here is report from dpkg:
    Code:
    rRr-kali:~# apt-get dist-upgrade 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following packages have been kept back:
      db5.1-util
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
    8 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    Setting up tex-common (5.03) ...
    Running mktexlsr. This may take some time... done.
    Running updmap-sys. This may take some time... 
    updmap-sys failed. Output has been stored in
    /tmp/updmap.8vgshroO
    Please include this file if you report a bug.
    
    Sometimes, not accepting conffile updates in /etc/texmf/updmap.d
    causes updmap-sys to fail.  Please check for files with extension
    .dpkg-dist or .ucf-dist in this directory
    
    dpkg: error processing package tex-common (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of texlive-generic-recommended:
     texlive-generic-recommended depends on tex-common (>= 3); however:
      Package tex-common is not configured yet.
    
    dpkg: error processing package texlive-generic-recommended (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of prerex:
     prerex depends on texlive-generic-recommended; however:
      Package texlive-generic-recommended is not configured yet.
    
    dpkg: error processing package prerex (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of tex-gyre:
     tex-gyre depends on tex-common (>= 3); however:
      Package tex-common is not configured yet.
    
    dpkg: error processing package tex-gyre (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-fonts-recommended:
     texlive-fonts-recommended depends on tex-common (>= 3); however:
      Package tex-common is not configured yet.
    
    dpkg: error processing package texlive-fonts-recommended (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of texlive-fonts-recommended-doc:
     texlive-fonts-recommended-doc depends on tex-common (>= 3); however:
      Package tex-common is not configured yet.
    
    dpkg: error processing package texlive-fonts-recommended-doc (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of tipa:
     tipa depends on tex-common (>= 3); however:
      Package tex-common is not configured yet.
    
    dpkg: error processing package tipa (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of vprerex:
     vprerex depends on prerex; however:
      Package prerex is not configured yet.
    
    dpkg: error processing package vprerex (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     tex-common
     texlive-generic-recommended
     prerex
     tex-gyre
     texlive-fonts-recommended
     texlive-fonts-recommended-doc
     tipa
     vprerex
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    rRr-kali:~#
    The system looks running so far, but I still would like to have "apt-get" commands to not throw errors everytime I do upgrade or update.

    To be honest, I have no idea what are those packages for, BUT when I tried to remove them and reinstall, it threw that removing them will remove also like 40 others packages, which will be little bit too much work to reinstall after. So I decided to first ask here

    Could anyone help me please?

  2. #2
    Join Date
    2015-Sep
    Posts
    2
    I'm getting the same after rebooting following:

    apt-get dist-upgrade

    Please be gentle, if anyone can offer a solution, as I am a Kali Linux noob. I am very familiar with all things windows and msdos since Windows 2, but this is my first serious foray into Linux. I am running Windows 7 ultimate with Kali Linux installed on Virtual Box 5.0.4 using kali-linux-1.0.9a-i386.iso image. I have given KL 20 Gb to play with. Having succesfully installed KL I went to the faq pages in order to update prior to installing the Nvidia drivers, which someone, somewhere on the internet said I should do in order to run all tools available within Kali. This is a reinstall, having binned my first attempt when it fell over. I am following the instructions at:

    http://docs.kali.org/general-use/ins...-on-kali-linux

    I have narrowed down the problem to tex-common after command:

    sudo dpkg --configure -a

    dpkg: error processing package (--configure):
    dependancy problems - leaving unconfigured


    Pic attached of the output - sorry haven't worked out how to get the log as text yet, but I suspect I will have to learn a pipe command
    Any help would be appreciated

    kali texlive prob.jpg

  3. #3
    Join Date
    2015-Sep
    Posts
    2
    Never mind

    Unsurprisingly I was getting a few things wrong. But for others with a similar prob...

    Firstly it would appear there are no drivers available for my gpu from nvidia for this version of Debian

    Second I was using the upgrade/update commands, and sources, available to Kali 2.0 rather than 1.0.9a which I had installed. I was confused by the fact that there were no 64 bit sources for intel based machines. The available ver 2. of Kali had the letters amd in it and I presumed this was not designed to be used on intel machines - wrong. So instead I re-downloaded, but this time chose the vbox version of ver 2.0. This produces an .ova file instead of an .iso. The .ova should be imported into vbox and not mounted as a disc. It has all the upgrades (except those since it was compiled) in it and therefore saves hours of installing

    For anyone else getting the problem with tex-common I ran these commands from the recovery console:

    apt-get remove nvidia-kernel-dkms
    apt-get remove nvidia-* --purge
    apt-get remove nvidia* --purge
    service gdm3 stop
    reboot

    it may be that you also need to run the following before rebooting - I dont remember :

    apt-get update
    apt-get dist-upgrade

  4. #4
    Quote Originally Posted by Johnyy View Post
    Never mind

    Unsurprisingly I was getting a few things wrong. But for others with a similar prob...

    Firstly it would appear there are no drivers available for my gpu from nvidia for this version of Debian

    Second I was using the upgrade/update commands, and sources, available to Kali 2.0 rather than 1.0.9a which I had installed. I was confused by the fact that there were no 64 bit sources for intel based machines. The available ver 2. of Kali had the letters amd in it and I presumed this was not designed to be used on intel machines - wrong. So instead I re-downloaded, but this time chose the vbox version of ver 2.0. This produces an .ova file instead of an .iso. The .ova should be imported into vbox and not mounted as a disc. It has all the upgrades (except those since it was compiled) in it and therefore saves hours of installing

    For anyone else getting the problem with tex-common I ran these commands from the recovery console:

    apt-get remove nvidia-kernel-dkms
    apt-get remove nvidia-* --purge
    apt-get remove nvidia* --purge
    service gdm3 stop
    reboot

    it may be that you also need to run the following before rebooting - I dont remember :

    apt-get update
    apt-get dist-upgrade
    Why can change what others have to change anyway / I hope will change gradually and will reach its goal

Similar Threads

  1. Replies: 0
    Last Post: 2017-10-20, 01:42
  2. Kali 2.0 to Rolling: /usr/bin/dpkg returned an error code
    By timewarp in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2016-04-13, 22:57
  3. dpkg returned an error code (1)
    By discipuloosho in forum NetHunter General Questions
    Replies: 1
    Last Post: 2016-03-01, 21:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •