Results 1 to 6 of 6

Thread: Raspberry Pi - RTL8188CUS Wifi dongle Monitor mode issue

  1. #1
    Join Date
    2015-Sep
    Posts
    2

    Raspberry Pi - RTL8188CUS Wifi dongle Monitor mode issue

    Hi guys

    I own a Wifi USB dongle: RTL8188CUS. I have a personal laptop which runs Kali Linux, and when i plug it to my Laptop i can get it into monitor mode with no issues.

    Unfortunatly, the issue begins when i plug the same dongle to my Raspberry Pi 2 B. On my Pi, i run Kali Linux as well, and i'm trying to get the same dongle into monitor mode with airmon-ng, and with "iwconfig wlan0 mode monitor", but Both fails. Looks like to me that its not a hardware issue, since i can get it into monitor mode on my laptop, but not on the pi.

    The Airmon-ng shows on the PHY "null" for some reason.

    Just to mention, my Pi recognizes the dongle well, and i'm getting wifi signal and can clearly see the interface of the dongle on iwconfig. however the only issue is with the monitor mode.

    few things i already try:

    updated realtek firmware with apt-get install firmware-realtek
    Also Tried airmon-ng check kill
    Aircrack is updated to the last version


    Any suggestions? Thank you guys
    Last edited by snir_l; 2015-09-17 at 21:53.

  2. #2
    Join Date
    2015-Nov
    Posts
    2
    I am in the same situation as you.

    I am on the Edimax RTL8188CUS and I can't seem to get monitor mode to work as well. Was wondering if you manage to get it up?

  3. #3
    Join Date
    2015-Jan
    Posts
    30
    I have this one and it is working fine, even on the same Pi2 with ALfa RT3070 adapter.
    https://wikidevi.com/wiki/Edimax_EW-7811Un
    What can I help - some script checks or firmware etc.

    PS: Sorry just saw the issue is in monitor mode, didn't check that. I'm using it only in managed mode.
    Last edited by mikrostart; 2015-11-12 at 08:16. Reason: the issue is in monitor mode

  4. #4
    Join Date
    2015-Nov
    Posts
    2
    Hi All,

    So after doing research for a few days I gave up and bought a TP-Link WLAN USB (WN722N) http://www.tp-link.com/en/products/d...TL-WN722N.html

    Monitor mode works fine after that. I also did dual boot on a laptop with Kali together with Win 7 Pro and the Edimax WLAN USB dongle with RTL8188CUS chipset works fine on laptop.

    The thing is that the ARM version of Kali for Rasp Pi 2 does not work for chipset RTL8188CUS however it works fine if you are booting it up Kali on a laptop.

    I hope this helps everyone =) ... Also hopefully ARM Kali can help fix the chipset for RTL8188CUS.

  5. #5
    Join Date
    2015-Dec
    Posts
    1

    Lightbulb EW-7811Un 802.11n Wireless Adapter [RTL8188CUS] not suitable for monitoring mode

    Thanks a lot. I am digging the same for the last 3 days . i am using kali linux in my Raspberry pi 2
    my pi configurations are https://www.raspberrypi.org/forums/v...867069#p867069

    I am going to buy new wifi adapter .
    Thanks
    Vidhya
    Quote Originally Posted by jamezco View Post
    Hi All,

    So after doing research for a few days I gave up and bought a TP-Link WLAN USB (WN722N) http://www.tp-link.com/en/products/d...TL-WN722N.html

    Monitor mode works fine after that. I also did dual boot on a laptop with Kali together with Win 7 Pro and the Edimax WLAN USB dongle with RTL8188CUS chipset works fine on laptop.

    The thing is that the ARM version of Kali for Rasp Pi 2 does not work for chipset RTL8188CUS however it works fine if you are booting it up Kali on a laptop.

    I hope this helps everyone =) ... Also hopefully ARM Kali can help fix the chipset for RTL8188CUS.

  6. #6
    Join Date
    2013-Jul
    Posts
    41
    Quote Originally Posted by jamezco View Post
    I am in the same situation as you.

    I am on the Edimax RTL8188CUS and I can't seem to get monitor mode to work as well. Was wondering if you manage to get it up?
    As am I.

    Has anyone been able to get the RTL* chipsets in monitor mode yet?
    I've tried 3 different types wifi cards all with Realtek chipsets
    Will post back if I do.

    So I've revived some old threads, probably one too many.

    Seems rebuilding the kernel with rtl8192cu instead of the mainline version that comes with the current kernel enabled will do the trick,

    here is the article.

    http://raspberrypi.stackexchange.com...sb-on-raspbian

    I don't have the time to do what the article suggests at the current moment.

    Can anyone give it a go and post back?
    Last edited by hightech316; 2016-03-09 at 17:56. Reason: Added Article - http://raspberrypi.stackexchange.com/questions/36747/enable-monitoring-mode-for-rtl8188cus-via-usb-on-raspbia

Similar Threads

  1. Replies: 4
    Last Post: 2013-10-07, 14:49
  2. Fern won't recognize my usb wifi dongle (Raspberry Pi)
    By Robbert in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-07-08, 06:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •