Results 1 to 1 of 1

Thread: Issues found when launching Mana from NetHunter app menu

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2015-Sep
    Posts
    2

    Issues found when launching Mana from NetHunter app menu

    Hello guys, I just found a strange issue when launching mana from NetHunter app menu, my test phone is 1+plus with 4.4.4 Kitkat, and the script i'm using is /usr/share/mana-toolkit/run-mana/start-nat-full-kitkat.sh.

    After lauched from app menu, sslsplit would die along with the script after the script finish executing. I try nohup, setsid, and include the full command in brackets, none of them works, and the parent process doesn't change as well. I have to either remove '&' at the end of the command, or add 'wait $pid' as the last line of the script to prevent it exiting. However when i launch the script in terminal like ssh, this issue is gone, sslsplit won't exit when script finished. I note sslsplit is the only binary being executed in that script as background process, the rests like sslstrip, firelamb, etc are all python scripts and not affected.

    So i wonder is there someone else had this issue before, and is there any better solutions? I really don't like there are multiple scripts still running when their jobs are done
    (root 5385 0.0 0.0 964 472 ? S 20:24 0:00 /system/bin/sh /system/bin/bootkali mana-full-kitkat start
    root 5400 0.0 0.0 2168 968 ? S 20:24 0:00 /bin/bash /usr/bin/start-mana-full-kitkat
    root 5401 0.2 0.0 2184 1048 ? S 20:24 0:00 /bin/bash ./start-nat-full-kitkat.sh)


    PS: Another issue, but i've solution, when launching dhcpd with wlan0 attached to a network, it would be failed due to the reason '/var/run/dhcpd.pid' exists, so have to remove it before 'dhcpd -cf /etc/mana-toolkit/dhcpd.conf $phy'. Anyone experience it before?
    Last edited by s0b31t; 2015-09-28 at 06:49.

Similar Threads

  1. Mana issues on Nethunter 2.0 / Lollipop
    By stinkybit in forum NetHunter General Questions
    Replies: 9
    Last Post: 2015-10-08, 12:59
  2. Mana Tool Kit No upstream on Nethunter
    By cybeh in forum NetHunter General Questions
    Replies: 0
    Last Post: 2015-08-15, 10:13
  3. Having a lot of issues getting Mana to work.
    By Altrez in forum NetHunter General Questions
    Replies: 2
    Last Post: 2015-04-13, 12:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •