Results 1 to 4 of 4

Thread: issues installing kernal headers.

  1. #1
    Join Date
    2015-Apr
    Posts
    18

    issues installing kernal headers.

    So I have been through many threads, many google pages and still cannot fix this.

    Im trying to install my nVidia drivers, but its telling me I need to install the kernal headers for my distro.

    Ive tried,

    apt-get update
    apt-get upgrade
    apt-get upgrade

    sudo apt-get install linux-headers-$(uname -r)

    and multiple other commands. Tried adding all repos and I get packages have no installation candidate.

    Im still convinced this is a issue with an incorrect repository but what is the right one?

    Cheers!

  2. #2
    Join Date
    2015-Aug
    Posts
    13
    Hi

    I am new to Mint so I have just tried to get the information from the net without trying it out myself.

    sudo apt-get install linux-headers-generic
    https://www.kernel.org/doc/Documenta...rs_install.txt

    As for myself I have AMD drivers but use the flgrx drivers,
    Kind Regards
    ShenLun

  3. #3
    Join Date
    2015-Apr
    Posts
    18
    Quote Originally Posted by ShenLun View Post
    Hi

    I am new to Mint so I have just tried to get the information from the net without trying it out myself.

    sudo apt-get install linux-headers-generic
    https://www.kernel.org/doc/Documenta...rs_install.txt

    As for myself I have AMD drivers but use the flgrx drivers,
    Kind Regards
    ShenLun
    kali@kali:~$ sudo apt-get install linux-headers-generic
    [sudo] password for kali:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package linux-headers-generic is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'linux-headers-generic' has no installation candidate

  4. #4
    Join Date
    2015-Apr
    Posts
    18
    Code:
    sudo gedit /etc/apt/sources.list
    add these repos

    Code:
    # 
    
    # deb cdrom:[Debian GNU/Linux 2.0 _Sana_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150811-08:02]/ sana contrib main non-free
    
    #deb cdrom:[Debian GNU/Linux 2.0 _Sana_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150811-08:02]/ sana contrib main non-free
    
    deb http://security.kali.org/kali-security/ sana/updates main contrib non-free
    deb-src http://security.kali.org/kali-security/ sana/updates main contrib non-free
    
    deb-src http://http.kali.org/kali sana main non-free contrib
    deb-src http://security.kali.org/kali-security sana/updates main contrib non-free 
    
    deb http://http.kali.org/kali sana main non-free contrib
    
    deb http://http.kali.org/kali kali main contrib non-free
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    
    deb http://repository.spotify.com stable non-free
    Code:
    sudo apt-get install linux-headers-$(uname -r)

Similar Threads

  1. Having problems installing kernel headers (Dependency error)
    By mightybyte in forum TroubleShooting Archive
    Replies: 6
    Last Post: 2017-12-12, 15:58
  2. Installing Kernel Headers
    By slimer in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-03-22, 17:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •