Results 1 to 2 of 2

Thread: Can't set a .jar file to open with java or openjdk

  1. #1
    Join Date

    Can't set a .jar file to open with java or openjdk

    I've been having a lot of problems with this. I have all of the software I need as far as I know and the .jar file works flawless on windows. I go to open with on the file (which has execute as program enabled) and there is no open with java run time or openjdk. I tried to run it with run software and nothing happens. I've tried doing java -jar [jar file name] and I just get this:

    Exception in thread "main" java.lang.UnsupportedClassVersionError: Client : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass( :800)
    at .java:449)
    at$100(URLClassLoader. java:71)
    at$ 361)
    at$ 355)
    at Method)
    at ava:354)
    at java.lang.ClassLoader.loadClass( 25)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launche
    at java.lang.ClassLoader.loadClass( 58)
    at sun.launcher.LauncherHelper.checkAndLoadMain(Launc

    I've literally downloaded almost every java package on the installer with the hopes something would work, but nope. Please tell me what I am missing installation wise or please tell me how I can open this .jar file with jre or openjdk. Thanks in advance.

    java -version results
    java version "1.7.0_79"
    OpenJDK Runtime Environment (IcedTea 2.5.6) (7u79-2.5.6-1~deb8u1)
    OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)
    Last edited by rAWjAW; 2015-10-09 at 17:34.

  2. #2
    Join Date
    Ok so I ran the command 'dpkg --configure -a' and deleted and redownloaded the .jar file and now the command java -jar [jarfile name] works perfectly to open it. I hope this helps someone in the future ^.^

    @Thank you rAWjAW for allowing me to post this question, although I didn't receive any responses it gave me the motivation to keep messing around with it while I waited xD.

Similar Threads

  1. java-18-openjdk-amd64/lib/
    By Anselmino in forum Kali Linux General Questions
    Replies: 1
    Last Post: 2023-05-29, 11:23
  2. Could not open lock file.
    By TwirlBowls in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-04-30, 16:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts