Results 1 to 2 of 2

Thread: OSError: [Errno 2] No such file or directory (Wifite)

  1. #1
    Join Date
    2015-Oct
    Posts
    1

    OSError: [Errno 2] No such file or directory (Wifite)

    I run WiFite v2 (r87). When I select my target, which is my own network, I get the next error when the handshake is captured:

    Code:
    [0:00:10] handshake captured! saved as "hs/mynetwork_XX-XX-XX-XX-XX-XX.cap"
    Traceback (most recent call last):
      File "./wifite.py", line 3525, in <module>
        engine.Start()
      File "./wifite.py", line 1462, in Start
        if wpa_attack.RunAttack():
      File "./wifite.py", line 2146, in RunAttack
        self.wpa_get_handshake()
      File "./wifite.py", line 2286, in wpa_get_handshake
        if self.RUN_CONFIG.WPA_STRIP_HANDSHAKE: self.strip_handshake(save_as)
      File "./wifite.py", line 2537, in strip_handshake
        rename(capfile + '.temp', output_file)
      File "./wifite.py", line 1653, in rename
        os.rename(old, new)
    OSError: [Errno 2] No such file or directory
    With the handshake file physically located at hp folder (which is automatically created) I can subsequently run the command:

    aircrack-ng -w [wordlist file] -b [bssid] [any name]-01.cap

    and get correctly my password. But I have no idea why wifite is stopping at that point. Any idea to solve it and hack the password in only one step instead of writing the last command independently?

  2. #2
    Join Date
    2013-Aug
    Posts
    12

    Turn off handshake stripping

    Hello antecessor,

    Something is failing when wifite attempts to strip the pcap for the WPA handshake and strip off the unnecissary packets. I'm assuming its Tshark is objecting to kali being root, or pyrit is just failing cause... pyrit. Either way it's an unessisary step. Nano the wifite file which is probably in '/usr/bin/wifite' and use a -c when you use nano so you can see the line numbers. Go to line 172 and change the self.WPA_STRIP_HANDSHAKE = True to self.WPA_STRIP_HANDSHAKE = False.
    That should fix it. It worked for me.

Similar Threads

  1. No such file or directory
    By lpvmc in forum Installing Archive
    Replies: 0
    Last Post: 2015-08-18, 13:44
  2. Metsvc No such file or directory
    By cacaocaca in forum How-To Archive
    Replies: 0
    Last Post: 2014-09-29, 19:36
  3. Replies: 1
    Last Post: 2014-07-22, 04:21

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •