Results 1 to 8 of 8

Thread: Error Installing Kali 2.0 using VMWorkstation 12: Something has happened...

  1. #1
    Join Date

    Error Installing Kali 2.0 using VMWorkstation 12: Something has happened...

    Hello everyone,

    I'm trying to use the Kali 2.0 Image found here using VMWare Workstation 12. Kali Linux 32 bit VM PAE

    Going through this process, it seems to start okay, and then I get the following:

    "Oh no, Something has gone wrong. A problem has occurred and the system cannot recover"

    I can press ctrl+alt+f1 which gives me a prompt to login. I can login using the default root user, but when i type startx, I get the following "-bash: startx: command not found"

    The following are articles or other posts that seem similar, but either no answer or an answer that doesn't help my situation.

    Other Information:
    I can run an older version of Kali (1.0.6) using VMWare Workstation 12.
    I can run Kali from a live USB on the same system.
    I verified there is enough hard drive space.

    I apologize if this post is a bit all over the place, I read the "How to make a valid thread" and tried to hit most of the requirements.

    Thank you.
    Attached Images Attached Images

  2. #2
    "startx" isn't a valid command any more (That was a backtrack thing).
    "gdm3" should start up GNOME (which is the current default window manager).

    Does the x64 also do it? (if your hardware supports it)
    Can you live boot an ISO?
    Can you import the virtualbox image?
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Documentation: (Offline PDF version)
    Bugs Reporting & Tool Requests:
    Kali Tool List, Versions & Man Pages:

  3. #3
    Join Date
    Thank you for the reply.

    Unfortunately, my computer doesn't support 64 bit vm.

    I did try the the virtual box image and ran into the same issue.

    I'll try the live boot from the ISO tonight and post the results.

  4. #4
    Join Date
    Live booting from the ISO gave the same issue.

    I did go into the BIOS and enable "Virtualization Technology". I then selected "Virtualize Intel VT-x..." and then get "Virtualized Intel VT-x/EPT is not supported on this platform" . I'm wondering if there is possibly some hardware issue or some minimum requirement I don't have.

    I honestly don't know what all i've done at this point. If there are no obvious issues, I may just try and restart the process again and see if I've just missed something.

    Extra notes:
    The following is basically the computer I'm trying to use

  5. #5
    Join Date
    Another side note... if I go into Virtual Box under "Settings", the "Acceleration" tab is disabled.

  6. #6
    Join Date
    Went ahead and moved on. I'd like to come back to this at some point and see if I can figure out the issue. For now, I gave up on the VM.

    Hooked up my old desktop for now and dual booted with Kali 2.0 with no problems.

    Thanks for the suggestions. I've already learned a lot reading through these forum s the last few days.

  7. #7
    Join Date
    I've also had this problem. I'm using some shoddy hardware, (modern but low powered - practically a tablet) which may be the common factor. I tried installing from the ISOs, running the prebuilt offsec vmware images, enabling virtualisation support in my bios, running from vmware (im using vmware workstation 12 player) and running from virtualbox; all the same; black screen then the "oh no.. " screen.

    I also tried dropping to the command line (cntrl alt f1) and installing a range of other window managers. all failed to make any difference.

    In the end I got it working as follows: Using the offsec kali 2 prebuilt custom 64 bit vmware image in vmware workstation 12 player, edit the virtual machine config as follows:

    [drum roll]

    Virtual machine settings > Hardware > Display > 3D graphics > tick the Accelerate 3D Graphics check box

    .... and that was it. Doh.

  8. #8
    Glad you got it figured out. Just for the sake of future people checking this thread for troubleshooting problems in VMware Workstation, I'll throw out a fix to a problem I see fairly frequently. This usually happens when the virtual machine or workstation itself doesn't get to shut down cleanly. In the folder where the virtual machine's folders and files are stored, delete any files or folders with .ick as the extension. These are temporary files used when the VM is running. They get removed automatically when the VM is cleanly shut down, but they prevent a VM from opening.

Similar Threads

  1. What happened to
    By Saytan in forum NetHunter General Questions
    Replies: 2
    Last Post: 2015-09-24, 16:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts