Results 1 to 2 of 2

Thread: Killer 1525 Wireless Card can't connect

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2015-Nov
    Posts
    1

    Killer 1525 Wireless Card can't connect

    Hello, I recently installed Kali on a live USB using these instructions for Windows. Kali works great, but it won't connect to the Internet wirelessly. This is a clean install; I wiped the USB and started over after bumbling around on this issue for a while.

    I have a Qualcomm Atheros Killer 1525 wireless adapter on an Alienware 15 I just purchased this fall. I can connect just fine on Windows, but am forced to use Ethernet for Kali if I want to connect to the Internet.

    Here are some outputs for commands I have been told could be useful:

    uname -a
    Code:
    root@kali:/# uname -a
    Linux kali 4.0.0-kali1-amd64 #1 SMP Debian 4.0.4-1+kali2 (2015-06-03) x86_64 GNU/Linux
    lsb_release -a
    Code:
    root@kali:/# lsb_release -a
    No LSB modules are available.
    Distributor ID:	Kali
    Description:	Kali GNU/Linux 2.0
    Release:	2.0
    Codename:	sana
    lshw -class network
    Code:
    root@kali:/# lshw -class network
      *-network               
           description: Ethernet interface
           product: Killer E220x Gigabit Ethernet Controller
           vendor: Qualcomm Atheros
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: eth0
           version: 10
           serial: 20:47:47:b2:01:14
           size: 100Mbit/s
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=alx duplex=full ip=10.50.41.86 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
           resources: irq:43 memory:f7400000-f743ffff ioport:d000(size=128)
      *-network
           description: Network controller
           product: Qualcomm Atheros
           vendor: Qualcomm Atheros
           physical id: 0
           bus info: pci@0000:03:00.0
           version: 20
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
           configuration: driver=ath10k_pci latency=0
           resources: irq:33 memory:f6800000-f69fffff
    ifconfig -a
    Code:
    root@kali:/# ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 20:47:47:b2:01:14  
              inet addr:10.50.41.86  Bcast:10.50.41.87  Mask:255.255.255.248
              inet6 addr: fe80::2247:47ff:feb2:114/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:24802 errors:0 dropped:0 overruns:0 frame:0
              TX packets:18401 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:26353611 (25.1 MiB)  TX bytes:2969560 (2.8 MiB)
              Interrupt:18 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:472 errors:0 dropped:0 overruns:0 frame:0
              TX packets:472 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:40256 (39.3 KiB)  TX bytes:40256 (39.3 KiB)
    iwconfig
    Code:
    root@kali:/# iwconfig
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    dmesg | tail
    Code:
    root@kali:/# dmesg | tail
    [ 1407.804988] ACPI: \_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
    [ 1407.805001] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
    [ 2233.515927] nouveau E[   PIBUS][0000:01:00.0] HUB0: 0x10ecc0 0xffffffff (0x1b40822c)
    [ 2238.796126] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
    [ 2238.796444] ACPI: \_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
    [ 2238.796448] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
    [ 2288.027924] nouveau E[   PIBUS][0000:01:00.0] HUB0: 0x10ecc0 0xffffffff (0x1940822c)
    [ 2293.028095] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
    [ 2293.028410] ACPI: \_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
    [ 2293.028413] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150204/nsarguments-95)
    I'm a bit of a newbie to this, but I'm willing to learn. Any help would be greatly appreciated.

  2. #2
    Join Date
    2016-Aug
    Location
    Anchorage, AK
    Posts
    16
    I just had this same issue with my Alienware 15 R2. Try this:
    Code:
    modprobe alx
    echo 1969 e0a1 > sys/bus/pci/drivers/alx/new_id
    This will restore your ethernet, so plug it in and update your system.
    Code:
    apt-get update
    apt-get dist-upgrade
    After dist-upgrade completes, reboot and you should now have Wi-Fi connectivity. If you notice that your fonts are displaying as boxes you can fix them with:
    Code:
    apt-get install --reinstall fonts-cantarell
    Hope this gets you back up and running!

Similar Threads

  1. WLan Issues Killer Wireless-AC 1535
    By Misc in forum TroubleShooting Archive
    Replies: 11
    Last Post: 2017-04-25, 21:52
  2. Help with wireless card iwlwifi - killer 3160
    By Cyb3rg0d in forum How-To Archive
    Replies: 0
    Last Post: 2015-01-15, 19:27

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •