Results 1 to 4 of 4

Thread: Stuck on booting up at "random: nonblocking pool is initiated" on Raspberry Pi 2

  1. #1

    Cool Stuck on booting up at "random: nonblocking pool is initiated" on Raspberry Pi 2

    So this is an unusual problem in that I've been getting mostly consistent results no matter what hardware or distro of kali that I use. On bootup everything seems to be going fine until it gets to the step "random: nonblocking pool is initiated" where it freezes up. Usually it does that after about 3 seconds. Now that step won't even come up until even after 72 seconds (the only difference is I'm on a different tv and now I'm plugged straight in via ethernet instead of using a usb wifi adaptor). The step seems to have something to do with "creating entropy" for the random number generator.

    So the weird thing is that I've tried this using Kali 2.0.1, the build specific for the Raspberry Pi 2. That was the first version I tried and that's when I ran in to the problem. I found a version 1 of kali for the same hardware and I tried downgrading to that (using a different microsd card). But I still ran in to the same hangup on boot using the older version of kali.

    I've tried using 2 other Raspberry Pi 2 boards with the same result. I've tried different keyboards and mouses to the same result. I've tried it on 2 different tv's. I've tried using an ethernet cable straight in to the router, and I've tried it with a usb wifi adaptor. I've tried most every combination of usb devices.

    So, that's where I am with trying to get kali to work on a Raspberry Pi, can't even get the bootup sequence to finish out

  2. #2
    Join Date
    2013-Aug
    Posts
    25

    added tut link

    #same deal here! exactly.... I did the encypted install with dropbear ssh kali 2
    # https://www.offensive-security.com/k...sk-encryption/

    #this line is in the cmdline.txt
    dwc_otg.fiq_fix_enable=2 console=tty1 console=tty1 root=/dev/mapper/crypt_sdcard cryptdevice=/dev/mmcblk0p2:crypt_sdcard rootfstype=ext4 rootwait rootflags=noload


    #I wonder if the "rootwait & rootflags=noload" really needs to be there at the end?????


    #I also noticed that my config.txt is blank also when i open it...
    #I wonder if in this step:
    echo initramfs initramfs.gz 0x00f00000 & /boot/config.txt

    #was anything supposed to make it into the config.txt file?
    Last edited by careyjames; 2015-11-16 at 17:06. Reason: add tut link

  3. #3
    yep iv got exactly the same problem and its driving me mental. iv tried editing the cmdline.txt with no joy, just get the same shitting "random: nonblocking pool is initiated".
    some one out there must have an answer
    PPPLLLLLEEEEAAASSSSEEEE

  4. #4
    Finally sorted it out
    Re-download image
    Unzip using 7zip (last time I used winrar)
    Write image to disk with win32diskimager.

    This method sorted it out for me

Similar Threads

  1. Boot stuck with message "[OK] Started User Manager for UID 132."
    By dip7777 in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2017-06-17, 00:19
  2. Replies: 2
    Last Post: 2016-11-01, 21:29
  3. Stuck at Kali Installation - "Registered Protocol Family 1"
    By Manuel95 in forum Installing Archive
    Replies: 2
    Last Post: 2016-09-18, 16:21
  4. Kali Linux VirtualBox Startup stuck on "Loading, Please wait."
    By viperish11 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-08-11, 01:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •