Results 1 to 4 of 4

Thread: Nethunter chroot unable to update armhf packages, help

  1. #1
    Join Date
    2015-Feb
    Posts
    5

    Nethunter chroot unable to update armhf packages, help

    Hi all, hope you are are well

    I have kali nethunter on nexus 10, and always been fine.
    But I have just tried to update it via chroot, but it I get errors for all armhf packages, it says : 404 not found
    I must admit I have not been updating it as regular as I should- as I have been very ill, so this tells me that maybe the sources.list is out of date?

    Can anyone help me please? if it is the case that the sources.list needs to be updated, how do I do this?

    Thank you so much if you can help :-)

    jwm

  2. #2
    Make sure to read this blog post: https://www.kali.org/news/kali-moto-eol/

    You will need to switch to the kali 2 or change repos to point to the archive server.
    Either way, you will need to edit your source.lst file.
    This is a Kali-Linux support forum - not general IT/infosec help.

    Useful Commands: OS, Networking, Hardware, Wi-Fi
    Troubleshooting: Kali-Linux Installation, Repository, Wi-Fi Cards (Official Docs)
    Hardware: Recommended 802.11 Wireless Cards

    Documentation: http://docs.kali.org/ (Offline PDF version)
    Bugs Reporting & Tool Requests: https://bugs.kali.org/
    Kali Tool List, Versions & Man Pages: https://tools.kali.org/

  3. #3
    Join Date
    2015-Feb
    Posts
    5
    Hi g0tmi1k
    thank you, i have followed the instruction in the link you gave, but did not download/update completely, so tried it again, now i get a "hash sum mismatch" on binary-armhf/packages
    what can i do now please?

    thank you :-)
    Last edited by jwm; 2015-12-04 at 14:11.

  4. #4
    Join Date
    2015-Feb
    Posts
    5
    Hi Just an update, i have redone the update, now i get the following error, which i have pasted here:

    root@kali:~# apt-get update
    Hit http://http.kali.org sana Release.gpg
    Hit http://security.kali.org sana/updates Release.gpg
    Hit http://security.kali.org sana/updates Release
    Hit http://http.kali.org sana Release
    Hit http://security.kali.org sana/updates/main armhf Packages
    Hit http://http.kali.org sana/main armhf Packages
    Hit http://security.kali.org sana/updates/contrib armhf Packages
    Hit http://http.kali.org sana/non-free armhf Packages
    Hit http://security.kali.org sana/updates/non-free armhf Packages
    Hit http://http.kali.org sana/contrib armhf Packages
    Ign http://security.kali.org sana/updates/contrib Translation-en
    Ign http://security.kali.org sana/updates/main Translation-en
    Ign http://http.kali.org sana/contrib Translation-en
    Ign http://security.kali.org sana/updates/non-free Translation-en
    Ign http://http.kali.org sana/main Translation-en
    Ign http://http.kali.org sana/non-free Translation-en
    Reading package lists... Error!
    E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/http.kali.org_kali_dists_sana_non-free_i18n_Translation-en
    E: The package lists or status file could not be parsed or opened.

    Can anyone help please?
    Thank you

Similar Threads

  1. postgresql update failing in chroot update
    By AWV in forum NetHunter General Questions
    Replies: 4
    Last Post: 2015-05-31, 14:18
  2. Update Kali Chroot
    By stgrosso in forum NetHunter General Questions
    Replies: 2
    Last Post: 2015-01-30, 10:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •