Results 1 to 9 of 9

Thread: Alfa AWUS036NH RT3070L USB on Kali v2.0 - Injection and wash error. Buggy firmware ?

  1. #1
    Join Date
    2015-Nov
    Posts
    46

    Alfa AWUS036NH RT3070L USB on Kali v2.0 - Injection and wash error. Buggy firmware ?

    I've just got a new Alfa AWUS036NH (fake according to Alfa Network support) USB adapter and i'm having some injection + wash scan problems...

    Device photos:
    IMG_6701.jpg
    IMG_6704.jpg
    IMG_6700.jpg
    IMG_6703.jpg

    I'm running Kali v2.0 USB Persistence.

    Just after the restart everything is ok

    wlan2 is the alfa adapter

    Code:
    root@kali:~# airmon-ng check kill
    
    Killing these processes:
    
      PID Name
     1473 wpa_supplicant
     1565 dhclient
    
    root@kali:~# iwconfig
    wlan0     IEEE 802.11bg  ESSID:off/any
              Mode:Managed  Access Point: Not-Associated   Tx-Power=30 dBm
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
    
    wlan2     IEEE 802.11bgn  ESSID:off/any
              Mode:Managed  Access Point: Not-Associated   Tx-Power=33 dBm
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
    
    root@kali:~# airmon-ng start wlan2
    
    
    PHY     Interface       Driver          Chipset
    
    phy0    wlan0           b43             non-mac80211 device? (report this!)
    phy1    wlan2           rt2800usb       Ralink Technology, Corp. RT2870/RT3070
    
                    (mac80211 monitor mode vif enabled for [phy1]wlan2 on [phy1]wlan2mon)
                    (mac80211 station mode vif disabled for [phy1]wlan2)
    
    root@kali:~# aireplay-ng -9 wlan2mon
    19:45:54  Trying broadcast probe requests...
    19:45:54  Injection is working!
    19:45:56  Found 1 AP
    
    19:47:27  Trying directed probe requests...
    19:47:27  XX:XX:XX:XX:XX:XX - channel: 11 - 'test'
    19:47:27  Ping (min/avg/max): 2.103ms/11.600ms/25.750ms Power: -46.20
    19:47:27  30/30: 100%
    but when i disable monitor mode and enable again

    Code:
    root@kali:~# airmon-ng stop wlan2mon
    
    PHY     Interface       Driver          Chipset
    
    phy0    wlan0           b43             non-mac80211 device? (report this!)
    phy1    wlan2mon        rt2800usb       Ralink Technology, Corp. RT2870/RT3070
    cat: /sys/class/ieee80211/phy1/device/net/wlan2/type: No such file or directory
    
                    (mac80211 station mode vif enabled on [phy1]wlan2)
    
                    (mac80211 monitor mode vif disabled for [phy1]wlan2mon)
    
    root@kali:~# airmon-ng
    
    PHY     Interface       Driver          Chipset
    
    phy0    wlan0           b43             non-mac80211 device? (report this!)
    phy1    wlan3           rt2800usb       Ralink Technology, Corp. RT2870/RT3070
    
    root@kali:~# airmon-ng check kill
    
    
    root@kali:~# airmon-ng start wlan3
    
    
    PHY     Interface       Driver          Chipset
    
    phy0    wlan0           b43             non-mac80211 device? (report this!)
    phy1    wlan3           rt2800usb       Ralink Technology, Corp. RT2870/RT3070
    
                    (mac80211 monitor mode vif enabled for [phy1]wlan3 on [phy1]wlan3mon)
                    (mac80211 station mode vif disabled for [phy1]wlan3)
    for some reason it becomes wlan3, and injection stops working

    Code:
    root@kali:~# aireplay-ng -9 wlan3mon
    19:48:25  Trying broadcast probe requests...
    19:48:27  No Answer...
    19:48:27  Found 1 AP
    
    19:48:27  Trying directed probe requests...
    19:48:27  XX:XX:XX:XX:XX:XX - channel: 11 - 'test'
    19:48:33   0/30:   0%
    Trying to run wash scan:

    Code:
    root@kali:~# wash -i wlan3mon
    
    Wash v1.5.2 WiFi Protected Setup Scan Tool
    Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>
    mod by t6_x <t6_x@hotmail.com> & DataHead & Soxrok2212
    
    BSSID                  Channel       RSSI       WPS Version       WPS Locked        ESSID
    ---------------------------------------------------------------------------------------------------------------
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    [!] Found packet with bad FCS, skipping...
    Some related demsg
    Code:
    [   20.621485] usbcore: registered new interface driver rt2800usb
    [   20.923092] rt2800usb 4-1:1.0 wlan2: renamed from wlan1
    [   28.330826] ieee80211 phy1: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
    [   28.371656] rt2800usb 4-1:1.0: firmware: direct-loading firmware rt2870.bin
    [   28.384248] ieee80211 phy1: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29
    [  178.349792] device wlan2mon entered promiscuous mode
    [  307.986854] rt2800usb 4-1:1.0 wlan3: renamed from wlan2
    [  307.987177] systemd-udevd[2618]: renamed network interface wlan2 to wlan3
    If i do all the steps above with wlan0, everything works fine (b43 firmware is perfect)...

    Seems to be a buggy RT3070 firmware.

    Does anyone knows how to get a fixed firmware for this device or fix these issues ?

    Thanks !
    Last edited by brunoaduarte; 2015-12-11 at 22:51.

  2. #2
    Join Date
    2015-Jul
    Location
    /home/duxim
    Posts
    408
    "for some reason it becomes wlan3, and injection stops working"
    it is normal

    wash -i wlan3mon
    add -C at the end of command to look like this
    wash -i wlan3mon -C
    Repetitio est mater studiorum

  3. #3
    Join Date
    2015-Nov
    Posts
    46
    Quote Originally Posted by duxim View Post
    "for some reason it becomes wlan3, and injection stops working"
    it is normal

    wash -i wlan3mon
    add -C at the end of command to look like this
    wash -i wlan3mon -C
    yeah, i know about this -C (--ignore-fcs) flag, but it seems to me just like hiding the problem.

    About the injection, why do you say it's normal that it stops working ? that doesn't happen with my wlan0 (b43) device... i can stop and start airmon-ng repeatedly and injection still works.

    Doesn't that (injection test -9 stop working) means that the card injection capabilities are compromised?

  4. #4
    Join Date
    2015-Dec
    Location
    Germany
    Posts
    1
    i have exactly the same problem with the same adapter (rt3070 Chipset)

  5. #5
    Join Date
    2014-Jun
    Posts
    71
    I just purchased this adapter

    Should I have not??

  6. #6
    Join Date
    2015-Nov
    Posts
    46
    Well, is awus036nh genuine from Alfa ?

    I've returned my cloned AWUS036NH because it's a piece of **** !

    Done a couple of tests here, and even though you can set it's txpower up to 2000mW (33 dBm), the link quality was worst than my laptop's (1000 mW - 30 dBm) built in wifi.

    I've just bought an Alfa genuine AWUS036NH from another seller to test (still waiting for it to arrive).

  7. #7
    Join Date
    2014-Jun
    Posts
    71
    Quote Originally Posted by brunoaduarte View Post
    Well, is awus036nh genuine from Alfa ?

    I've returned my cloned AWUS036NH because it's a piece of **** !

    Done a couple of tests here, and even though you can set it's txpower up to 2000mW (33 dBm), the link quality was worst than my laptop's (1000 mW - 30 dBm) built in wifi.

    I've just bought an Alfa genuine AWUS036NH from another seller to test (still waiting for it to arrive).
    how can you tell if its genuine

  8. #8
    Join Date
    2015-Nov
    Posts
    46
    send pictures of it to alfa support http://www.alfa.com.tw/

  9. #9
    Join Date
    2016-Mar
    Posts
    2

Similar Threads

  1. Replies: 9
    Last Post: 2016-09-09, 22:56
  2. ALFA AWUS036NH Ralink RT2870: Driver / Firmware
    By nigelmercier in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-07-18, 18:40
  3. Alfa awus036nh driver installing error.
    By Blacksnakehp in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-02-10, 17:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •