Results 1 to 3 of 3

Thread: 'apt-get update' Always showing 404 Not Found on Kali 2.0

  1. #1
    Join Date

    Unhappy 'apt-get update' Always showing 404 Not Found on Kali 2.0

    Hello guys, I have successfully installed Kali Linux 2.0 but when I update it, it always shows the same error

    This is the output of the terminal EVERYTIME I use 'apt-get update'

    Get:1 sana/updates InRelease [11.9 kB]
    Get:2 sana InRelease [20.3 kB]  
    Get:3 sana/updates/main Sources [80.9 kB]
    Get:4 sana/updates/contrib Sources [20 B]             
    Get:5 sana/main Sources [9,090 kB]                        
    Ign sana/updates/contrib Translation-en_PH            
    Ign sana/updates/contrib Translation-en               
    Ign sana/updates/main Translation-en_PH               
    Ign sana/contrib Translation-en_PH                        
    Ign sana/updates/main Translation-en                  
    Ign sana/contrib Translation-en                           
    Ign sana/updates/non-free Translation-en_PH           
    Ign sana/main Translation-en_PH                           
    Ign sana/updates/non-free Translation-en              
    Ign sana/main Translation-en                              
    Ign sana/non-free Translation-en_PH                       
    Ign sana/non-free Translation-en                          
    Get:6 sana/non-free Sources [123 kB]                      
    Err sana/main Sources                                     
    Err sana/main Sources                                     
      404  Not Found
    Get:7 sana/updates/non-free Sources [20 B]            
    Get:8 sana/contrib Sources [58.3 kB]                      
    Get:9 sana/updates/main amd64 Packages [252 kB]       
    Get:10 sana/main amd64 Packages [12.8 MB]                 
    Get:11 sana/updates/contrib amd64 Packages [20 B]     
    Get:12 sana/non-free amd64 Packages [164 kB]              
    Err sana/main amd64 Packages                              
    Get:13 sana/updates/non-free amd64 Packages [20 B]    
    Get:14 sana/contrib amd64 Packages [87.7 kB]              
    Fetched 22.7 MB in 6min 19s (59.8 kB/s)                                        
    W: Failed to fetch  404  Not Found
    W: Failed to fetch  Hash Sum mismatch
    E: Some index files failed to download. They have been ignored, or old ones used instead.
    I tried different mirrors, but the same error keeps popping up. I also tried different methods such as using 'apt-get clean', using namespace/s: ' and', and clening my '/var/lib/apt/lists/' direcory. And still got no luck

    Would anyone in this forum help me? Thanks

    *NOTE: Only the kali/sana/main/source/Sources is getting a not found result

    Last edited by haken29a; 2015-12-12 at 01:03. Reason: Title

  2. #2
    Join Date
    Make sure to have instead of simply in your /etc/apt/sources.list file

  3. #3
    Join Date
    Hi there

    Your /etc/apt/sources.list has to contain the following lines:
    # Regular repositories
    deb sana main non-free contrib
    deb sana/updates main contrib non-free
    If you want source or kali-dev repositories too, read more -->

    regards, reidamaxia

Similar Threads

  1. Replies: 0
    Last Post: 2017-03-16, 16:27
  2. airbase-ng showing 2 essids since Kali update/upgrade
    By SAH1376 in forum General Archive
    Replies: 8
    Last Post: 2015-12-17, 15:12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts