Results 1 to 5 of 5

Thread: Kali Docker Full Install Error

  1. #1
    Join Date
    2014-Dec
    Posts
    30

    Kali Docker Full Install Error

    I started with the docker that Kali offers:
    muts@macbook-air:~$ docker pull kalilinux/kali-linux-docker
    muts@macbook-air:~$ docker run -t -i kalilinux/kali-linux-docker /bin/bash

    The commands I've run so far and my current issue.
    apt-get update
    apt-get upgrade
    apt-get install kali-linux-all

    Error:
    Processing triggers for menu (2.1.47) ...
    Errors were encountered while processing:
    uhd-host
    gqrx
    kali-linux-sdr
    kali-linux-full
    kali-linux-wireless
    kali-linux-all
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@ecaf67e69a63:/# apt-get install uhd-host
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    uhd-host is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    6 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up uhd-host (3.7.3-1) ...
    sysctl: cannot stat /proc/sys/net/core/rmem_max: No such file or directory
    sysctl: cannot stat /proc/sys/net/core/wmem_max: No such file or directory
    dpkg: error processing package uhd-host (--configure):
    subprocess installed post-installation script returned error exit status 255
    dpkg: dependency problems prevent configuration of gqrx:
    gqrx depends on uhd-host; however:
    Package uhd-host is not configured yet.

    dpkg: error processing package gqrx (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kali-linux-sdr:
    kali-linux-sdr depends on gqrx; however:
    Package gqrx is not configured yet.
    kali-linux-sdr depends on uhd-host; however:
    Package uhd-host is not configured yet.

    dpkg: error processing package kali-linux-sdr (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kali-linux-full:
    kali-linux-full depends on kali-linux-sdr; however:
    Package kali-linux-sdr is not configured yet.

    dpkg: error processing package kali-linux-full (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kali-linux-wireless:
    kali-linux-wireless depends on kali-linux-sdr; however:
    Package kali-linux-sdr is not configured yet.

    dpkg: error processing package kali-linux-wireless (--configure):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kali-linux-all:
    kali-linux-all depends on kali-linux-full; however:
    Package kali-linux-full is not configured yet.
    kali-linux-all depends on kali-linux-sdr; however:
    Package kali-linux-sdr is not configured yet.
    kali-linux-all depends on kali-linux-wireless; however:
    Package kali-linux-wireless is not configured yet.

    dpkg: error processing package kali-linux-all (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    uhd-host
    gqrx
    kali-linux-sdr
    kali-linux-full
    kali-linux-wireless
    kali-linux-all

  2. #2
    Any luck with fixing this bug? I'm encountering the same issue. The only other thing I found relevant to this is: http://askubuntu.com/questions/67331...dockers-ubuntu but it wasn't particularly helpful.

  3. #3
    When setting it up, try running the image with more flags: docker run -it --net="host" --privileged kalilinux/kali-linux-docker /bin/bash

  4. #4
    Join Date
    2014-Dec
    Posts
    30
    I'm in the process of testing it now. I hope that works but not sure what the net command would do to resolve the errors that we have been getting.

    I'm not sure if there is a maximum file size for an image or container.

  5. #5
    Join Date
    2015-Dec
    Location
    India
    Posts
    1
    Your problem may be caused by broken packages.

Similar Threads

  1. No docker.io or docker-ce for Kali 2017.1?
    By datajerk in forum General Archive
    Replies: 0
    Last Post: 2017-05-02, 03:14
  2. Rpi2 kali-linux-full 64gig sd install error
    By Ianlmt in forum ARM Archive
    Replies: 2
    Last Post: 2017-03-03, 22:25
  3. Full Kali 2.0 install to SD card without modifying MBR possible?
    By funkytechmonkey in forum Installing Archive
    Replies: 0
    Last Post: 2015-09-04, 20:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •