Results 1 to 3 of 3

Thread: Applications not working in root account

  1. #1
    Join Date

    Exclamation Applications not working in root account

    I got two accounts in my kali linux, installed in a is root while the other one is non-root. When i installed applications (e.g. chromium, vlc, wine), it worked without any problems(instance launch) in the non-root account but in the root account, which i always use, have the icon appear in the application menu but when i click the app(s), no respond. For wine, it worked from the terminal command but also not launching ui. Many thx!!

  2. #2
    Join Date
    this is basic Linux security. read about it and you will understand why is that.
    you can make those apps to work under root account. just use google.
    Repetitio est mater studiorum

  3. #3
    Join Date
    This is the security issue. Try to use in non-root account more than root as it increases security threats while root and many programs are made to warn you while trying use it on root. It can be resolved but not good idea.

    As a I prefer to use terminal (Command Line Procedure) much more I switch to superuser mode often for any task. This way I know for which application I am giving the required access.

Similar Threads

  1. Changing administrator account to root
    By sushanth in forum General Archive
    Replies: 5
    Last Post: 2016-08-28, 02:08
  2. Can not login as root after deleting other account
    By pedropt in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2014-04-05, 21:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts