Results 1 to 4 of 4

Thread: Kali Linux with Intel Skylake graphics doens't boot

  1. #1
    Join Date

    Kali Linux with Intel Skylake graphics doens't boot

    Hello guys,
    So after a couple of days which in I thoroughly tried to install Kali Linux on my brand new Dell Inspiron 7359 - i7 6500U (VMware) and failed, I delved through the interwebs and finally came to the conclusion the only source to the problem (black screen/ kernel problems) is the graphics driver not compatible with the linux kernel which is installed with the linux.
    Any known solutions? I did search thoroughly but found nothing.
    If there's no solution I read it's possible to upgrade the kernel to 4.3 (?). any guides on how to do so?

    Thanks a lot guys, that's my first post, please don't disappoint me

  2. #2
    Join Date
    I know only two solutions.

    1. Install Ubuntu 15.10;
    2. Execute:
    For 32-bit:
    cd /tmp; wget; sudo dpkg -i *.deb; sudo update-grub; sudo reboot
    For 64-bit:
    cd /tmp; wget; sudo dpkg -i *.deb; sudo update-grub; sudo reboot
    3. Install Katoolin;

    Install Ubuntu 16.04 and Katoolin;

  3. #3
    Join Date
    Alright I'm pretty much in the same boat as you. I have a new yoga 900. Kali doesn't see the trackpad, wifi, or touchscreen. I have just upgraded the kernel to 4.4 by following Nutso_futso in "", since you have to modify some of the code before you compile the new kernel otherwise the touchscreen and trackpad wont work. After I rebooted I used katoolin to install all of the utilities. Here's where i ran into trouble. Katoolin installed all of the utilities but not in the nice neat organized sections like they should be. It showed up in one single long list, all 330 of them. I moved on but then Armitage wouldnt work, and I spent about 4 hours messing with it before it gave up. It seemed to be a problem with the database.yml file not being created and when i tried to copy one over or make a new one, it kept failing. I couldnt find any help so reverted back to installing kali with the 4.4 kernel and crossed my fingers..... Unfortunately kali with the 4.4 kernel didn't do anything...yet. My touchscreen, trackpad, and wifi are all still broken. If you find a way You should post it here and i'll do the same.

  4. #4
    Join Date
    Hey I got mine working, however you should check it out under "New yoga 900 install issues", might be of use to you.

Similar Threads

  1. Driver for Intel Skylake Integrated Graphics fails to load
    By adven in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2016-01-23, 00:08
  2. Kali 1.0.7 and intel HD4400 graphics
    By fennica2003 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-07-15, 14:03
  3. inject intel graphics patch into kali .iso?
    By 1manjugband in forum Building Archive
    Replies: 0
    Last Post: 2014-01-03, 05:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts